Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ClusterSSH

  1. #1

    Default ClusterSSH

    I have just upgraded my openSUSE installation from 11.0 to 11.1 which everything is working great. Kudos to the development team and all those involved! I really like 11.1. One problem I have encountered is I cannot get clusterssh working. It appears to install just fine but whenever I try to execute like I did in 11.0 I get the following error:
    Connection to server failed -- (version 11.0)
    No protocol specified
    at /usr/local/bin/cssh line 1883

    I tried to find a version for 11.1, rpm version that is, but no luck. I even download the source from SourceForge and still nada, same error. Not sure what is going on and looking for some assistance cause I really need clusterssh or another means to connect to several other machines to conduct changes.

    Thanks and keep up the great work!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,278
    Blog Entries
    15

    Default Re: ClusterSSH

    Quote Originally Posted by D8TA
    I have just upgraded my openSUSE installation from 11.0 to 11.1 which
    everything is working great. Kudos to the development team and all those
    involved! I really like 11.1. One problem I have encountered is I cannot
    get clusterssh working. It appears to install just fine but whenever I
    try to execute like I did in 11.0 I get the following error:
    Connection to server failed -- (version 11.0)
    No protocol specified
    at /usr/local/bin/cssh line 1883

    I tried to find a version for 11.1, rpm version that is, but no luck. I
    even download the source from SourceForge and still nada, same error.
    Not sure what is going on and looking for some assistance cause I really
    need clusterssh or another means to connect to several other machines to
    conduct changes.

    Thanks and keep up the great work!

    Hi
    Have you tried rebuilding (see below) the src rpms after a search of the
    11.0 rpm at http://software.opensuse.org/search?
    Code:
    rpmbuild --rebuild perl-X11-Protocol-0.56-6.1.src.rpm
    
    rpmbuild --rebuild clusterssh-3.19.1-20.1.src.rpm
    
    sudo rpm
    -Uhv /usr/src/packages/RPMS/noarch/perl-X11-Protocol-0.56-6.1.noarch.rpm
    
    sudo zypper rpm
    -Uhv /usr/src/packages/RPMS/noarch/clusterssh-3.19.1-20.1.noarch.rpm
    Note the rpm install commands is all on one line.
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
    up 1 day 16:44, 2 users, load average: 0.23, 0.32, 0.18
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,278
    Blog Entries
    15

    Default Re: ClusterSSH

    Quote Originally Posted by Malcolm
    Quote Originally Posted by D8TA
    I have just upgraded my openSUSE installation from 11.0 to 11.1 which
    everything is working great. Kudos to the development team and all those
    involved! I really like 11.1. One problem I have encountered is I cannot
    get clusterssh working. It appears to install just fine but whenever I
    try to execute like I did in 11.0 I get the following error:
    Connection to server failed -- (version 11.0)
    No protocol specified
    at /usr/local/bin/cssh line 1883

    I tried to find a version for 11.1, rpm version that is, but no luck. I
    even download the source from SourceForge and still nada, same error.
    Not sure what is going on and looking for some assistance cause I really
    need clusterssh or another means to connect to several other machines to
    conduct changes.

    Thanks and keep up the great work!

    Hi
    Have you tried rebuilding (see below) the src rpms after a search of the
    11.0 rpm at http://software.opensuse.org/search?
    Code:
    rpmbuild --rebuild perl-X11-Protocol-0.56-6.1.src.rpm
    
    rpmbuild --rebuild clusterssh-3.19.1-20.1.src.rpm
    
    sudo rpm
    -Uhv /usr/src/packages/RPMS/noarch/perl-X11-Protocol-0.56-6.1.noarch.rpm
    
    sudo zypper rpm
    -Uhv /usr/src/packages/RPMS/noarch/clusterssh-3.19.1-20.1.noarch.rpm
    Note the rpm install commands is all on one line.
    Hi
    Ahh you also need to run xhost + <username> and when finished xhost -
    <username> to enable/disable access control on the X server.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
    up 1 day 17:00, 2 users, load average: 0.62, 0.42, 0.31
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  4. #4

    Default Re: ClusterSSH

    Code:
    Hi
    Ahh you also need to run xhost + <username> and when finished xhost -
    <username> to enable/disable access control on the X server.
    I followed the rpmbuild and upgrade and everything went well. When I still try to run cssh name name1 name2 I get the same error:
    Connection to server failed -- (version 11.0)
    No protocol specified
    at /usr/local/bin/cssh line 1883

    I am confused with the above. Run xhost+<username>. I never had to do that before with ClusterSSH.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,278
    Blog Entries
    15

    Default Re: ClusterSSH

    Quote Originally Posted by D8TA
    Code:
    --------------------
    Hi
    Ahh you also need to run xhost + <username> and when finished xhost -
    <username> to enable/disable access control on the X server.
    --------------------


    I followed the rpmbuild and upgrade and everything went well. When I
    still try to run cssh name name1 name2 I get the same error:
    Connection to server failed -- (version 11.0)
    No protocol specified
    at /usr/local/bin/cssh line 1883

    I am confused with the above. Run xhost+<username>. I never had to do
    that before with ClusterSSH.

    Hi
    Security changes with 11.1 it would appear, did you try it?
    xhost + works, but better to include your username so it only relates
    to you.

    Maybe someone else on the forum could comment on the xhost requirement?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
    up 17:42, 1 user, load average: 0.22, 0.17, 0.16
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  6. #6

    Default Re: ClusterSSH

    Thanks but still same error.
    Connection to server failed -- (version 11.0)
    No protocol specified
    at /usr/local/bin/cssh line 1883

    I ran xhost + and my clients were added. I received the message name@host being added to access control list but then I try to run cssh name@host name@host and get the above error.

    What is the syntax you are using? Maybe I am not keying it correctly.

    Thanks for your help.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,278
    Blog Entries
    15

    Default Re: ClusterSSH

    Quote Originally Posted by D8TA
    Thanks but still same error.
    Connection to server failed -- (version 11.0)
    No protocol specified
    at /usr/local/bin/cssh line 1883

    I ran xhost + and my clients were added. I received the message
    name@host being added to access control list but then I try to run cssh
    name@host name@host and get the above error.

    What is the syntax you are using? Maybe I am not keying it correctly.

    Thanks for your help.

    Hi
    I just ran xhost + or xhost + <myusername> in your case <name> if you
    use the @ it will in the NIS family. See the man page for xhost.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
    up 19:51, 1 user, load average: 0.43, 0.25, 0.14
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  8. #8

    Default Re: ClusterSSH

    Thanks I have it working now.

    Greatly appreciate your assistance and patience.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,278
    Blog Entries
    15

    Default Re: ClusterSSH

    Quote Originally Posted by D8TA
    Thanks I have it working now.

    Greatly appreciate your assistance and patience.

    Hi
    Your welcome

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
    up 21:12, 1 user, load average: 0.00, 0.03, 0.03
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  10. #10
    supermathie NNTP User

    Default Re: ClusterSSH

    This problem isn't limited to SSH. It seems something fundamental is broken in the X11:rotocol module. Even this simple test program breaks:

    Code:
    michael@challenger:~> cat testx.pl 
    #!/usr/bin/perl -w
    use X11::Protocol;
    
    $xdisplay = X11::Protocol->new();
    
    michael@challenger:~> ./testx.pl 
    Name "main::xdisplay" used only once: possible typo at ./testx.pl line 4.
    Connection to server failed -- (version 11.0)
    No protocol specified
     at ./testx.pl line 4
    But X11 is working fine otherwise:
    Code:
    michael@challenger:~> xlsfonts |head -n2
    -adobe-courier-bold-o-normal--10-100-75-75-m-60-iso10646-1
    -adobe-courier-bold-o-normal--10-100-75-75-m-60-iso10646-1

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •