Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: KDE 4.1 Desktop Effects stopped working

  1. #1

    Default KDE 4.1 Desktop Effects stopped working

    My Desktop Effects have worked fine up until now. I have an nvidia 9400 gt pcie video card with the 180.29 drivers installed. When i try to enable them again i get the following error

    "Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

    Check your X configuration. You may also consider changing advanced options, especially changing the compositing type
    "

    I've googled and seen similar problems on other disto's and i have found ones on this forum but none that help me. Does anyone else have this problem and what can i do to fix it. I dont know if this was caused by an update or what but i have reinstalled my drivers multiple times and different driver versions but all resulting in the same error above. Cannot switch to XRender either but prefer opengl as it is faster then xrenderAny help is appreciated.

    Thanks,
    Dwight

    p.s. I am using opensuse 11.1
    Last edited by jett713; 10-May-2009 at 13:43. Reason: forgot some info

  2. #2

    Default Re: KDE 4.1 Desktop Effects stopped working

    Nvidia cards have been known to have issues with KDE 4, especially if you use kwin.

  3. #3
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: KDE 4.1 Desktop Effects stopped working

    jett713 adjusted his/her AFB on Sunday 10 May 2009 21:36 to write:

    >
    > My Desktop Effects have worked fine up until now. I have an nvidia 9400
    > gt pcie video card with the 180.29 drivers installed. When i try to
    > enable them again i get the following error
    >
    > "*Failed to activate desktop effects using the given configuration
    > options. Settings will be reverted to their previous values.
    >
    > Check your X configuration. You may also consider changing advanced
    > options, especially changing the compositing type*"
    >
    > I've googled and seen similar problems on other disto's and i have
    > found ones on this forum but none that help me. Does anyone else have
    > this problem and what can i do to fix it. I dont know if this was caused
    > by an update or what but i have reinstalled my drivers multiple times
    > and different driver versions but all resulting in the same error above.
    > Cannot switch to XRender either but prefer opengl as it is faster then
    > xrenderAny help is appreciated.
    >
    > Thanks,
    > Dwight
    >
    >


    Have you checked that the composite is set to "on" in your xorg.conf??

    you probably have but that is the first step I would do.

    HTH

    --
    Mark

    Nullus in verba
    Nil illigitimi carborundum


  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE 4.1 Desktop Effects stopped working

    Please post your xorg.conf located at /etc/X11

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5

    Default Re: KDE 4.1 Desktop Effects stopped working

    Here is my xorg looks like it is enabled to me

    Code:
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "dri"
      Load         "dbe"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "14"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Logitech USB Receiver"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  408 255
      HorizSync    30-82
      Identifier   "Monitor[0]"
      ModelName    "ACER AL1916W"
      Option       "DPMS"
      VendorName   "ACR"
      VertRefresh  43-76
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline 	"1440x900" 106.00 1440 1520 1672 1904 900 903 909 934
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1440x900" "1152x864" "1024x768" "800x600" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1440x900" "1152x864" "1024x768" "800x600" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1440x900" "1152x864" "1024x768" "800x600" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1440x900" "1152x864" "1024x768" "800x600" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "GeForce 9400 GT"
      Driver       "nvidia"
      Identifier   "Device[0]"
      VendorName   "NVIDIA"
      Option       "ModelValidation" "DFP-0:NoDFPNativeResolutionCheck"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "Composite" "on"
    EndSection
    need anymore info just let me know

    thanks,
    Dwight

  6. #6
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: KDE 4.1 Desktop Effects stopped working

    Have you checked that the composite is set to "on" in your xorg.conf??
    It means that you have the section
    Code:
    Section "Extensions"
            Option  "Composite" "Enabled"
    EndSection
    (or "on")
    included in your /etc/X11/xorg.conf file.
    Anyway, the compositing probably will switch of on high process load. I'm posted it to KDE forums: LID standby disables Desktop Effects - Page 1.
    Good luck.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  7. #7
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE 4.1 Desktop Effects stopped working

    You do not have aiglx enabled and you'll also need to run some commands.

    First hit alt+f2 and type

    Code:
    kdesu kwrite /etc/X11/xorg.conf
    then under Section "ServerLayout" add

    Code:
    option "aiglx" "true"
    Save and exit that. Then open a terminal and enter these commands one by one:

    Code:
    su
    enter root password then type these one by one

    Code:
    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    Then restart and try your desktop effects.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  8. #8
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: KDE 4.1 Desktop Effects stopped working

    I'm no longer playing KDE4, so I made a link to this post on KDE forums. I hope someone will find it useful.
    Thank you.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  9. #9

    Default Re: KDE 4.1 Desktop Effects stopped working

    I did what you said still get the error. This is what xorg looks like now.

    Code:
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen         "Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        Option         "aiglx" "true"
        Option         "Clone" "off"
        Option         "Xinerama" "off"
    EndSection
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/URW"
        FontPath        "/usr/share/fonts/Speedo"
        FontPath        "/usr/share/fonts/PEX"
        FontPath        "/usr/share/fonts/cyrillic"
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath        "/usr/share/fonts/baekmuk:unscaled"
        FontPath        "/usr/share/fonts/japanese:unscaled"
        FontPath        "/usr/share/fonts/kwintv"
        FontPath        "/usr/share/fonts/truetype"
        FontPath        "/usr/share/fonts/uni:unscaled"
        FontPath        "/usr/share/fonts/CID"
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"
        FontPath        "/usr/share/fonts/xtest"
        FontPath        "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "freetype"
        Load           "extmod"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"
        Option         "Buttons" "14"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "Logitech USB Receiver"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
        Identifier         "Modes[0]"
        ModeLine     "1440x900" 106.00 1440 1520 1672 1904 900 903 909 934
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor[0]"
        VendorName     "ACR"
        ModelName      "ACER AL1916W"
        UseModes       "Modes[0]"
        DisplaySize     408    255
        HorizSync       30.0 - 82.0
        VertRefresh     43.0 - 76.0
        Option         "CalcAlgorithm" "XServerPool"
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device[0]"
        Driver         "nvidia"
        VendorName     "NVIDIA"
        BoardName      "GeForce 9400 GT"
    EndSection
    
    Section "Screen"
        Identifier     "Screen[0]"
        Device         "Device[0]"
        Monitor        "Monitor[0]"
        DefaultDepth    24
        Option         "ModelValidation" "DFP-0:NoDFPNativeResolutionCheck"
        Option         "RenderAccel" "True"
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Depth       15
            Modes      "1440x900" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection     "Display"
            Depth       16
            Modes      "1440x900" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection     "Display"
            Depth       24
            Modes      "1440x900" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection     "Display"
            Depth       8
            Modes      "1440x900" "1152x864" "1024x768" "800x600"
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection

  10. #10
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE 4.1 Desktop Effects stopped working

    Hmm....

    Your xorg.conf is configured correctly.

    The only other thing I can think of is that you have an effect option enabled that's not supported by your card. Or perhaps you should try the drivers from the openSUSE Nvidia website

    I myself use compiz-fusion and have no problems at all with my Geforce 4 MX 4000. But what works for one doesn't always work for another.

    Sorry I couldn't be of more help.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •