Results 1 to 2 of 2

Thread: Cups will not reconize Xerox Phaser 6120

  1. #1
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Cups will not reconize Xerox Phaser 6120

    I posted twice to Cups mail list with no response.

    REF:
    Message ID; 35173-cups.general@news.easysw.com
    Message ID: (References above) 35213-cups.general@news.easysw.com

    rpm -qa |grep cups
    cups-1.3.9-7.2.1
    cups-libs-1.3.9-7.2.1
    libgnomecups-0.2.3-108.12
    cups-autoconfig-0.1.0-158.7
    cupsddk-1.2.3-65.105
    cups-drivers-1.3.9-2.10
    cups-libs-32bit-1.3.9-7.2.1
    cups-backends-1.0-103.162
    cups-client-1.3.9-7.2.1
    cups-devel-1.3.9-7.2.1

    Message ID; 35173-cups.general@news.easysw.com
    Message ID: (References above) 35213-cups.general@news.easysw.com

    Thinking this is openSUSE 11.1 (x86_64) problem. Since last Sunday after
    successfully repairing errors on my disk drive (ext3 formatted) I can not
    print to my Xerox Phaser 6120. I can print from another openSuSE 11.1
    (X86_32) system that does not have all the updates and from a 11.2
    milestone 1 (X86_64) system. My 11.1 system is my production system and has
    all the updates before Last Sunday. rest of configuration is below in
    signature.

    If I follow the link in the error message it says to change the version of
    Avahi back to the native version. One bug (plus 2 duplicates) in bugzilla
    talked about this and said it is fixed. I have the latest updates for cups
    1.3.9 installed, is this a regression? I will open a bug report.

    Start up log error:

    May 9 07:34:42 linux-ebgz cupsd[3881]: *** WARNING *** The program 'cupsd'
    uses the Apple Bonjour compatibility layer of Avahi.
    May 9 07:34:42 linux-ebgz cupsd[3881]: *** WARNING *** Please fix your
    application to use the native API of Avahi!
    May 9 07:34:42 linux-ebgz cupsd[3881]: *** WARNING *** For more information
    see <http://0pointer.de/avahi-compat?s=libdns_sd&e=cupsd>

    any suggestions on how to manual fix would be appreciated. I can not print
    from my production system without emailing the file to my 11.2 system.
    --
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2.1 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



  2. #2
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Cups will not reconize Xerox Phaser 6120

    russbucket wrote:

    > I posted twice to Cups mail list with no response.
    >
    > REF:
    > Message ID; 35173-cups.general@news.easysw.com
    > Message ID: (References above) 35213-cups.general@news.easysw.com
    >
    > rpm -qa |grep cups
    > cups-1.3.9-7.2.1
    > cups-libs-1.3.9-7.2.1
    > libgnomecups-0.2.3-108.12
    > cups-autoconfig-0.1.0-158.7
    > cupsddk-1.2.3-65.105
    > cups-drivers-1.3.9-2.10
    > cups-libs-32bit-1.3.9-7.2.1
    > cups-backends-1.0-103.162
    > cups-client-1.3.9-7.2.1
    > cups-devel-1.3.9-7.2.1
    >
    > Message ID; 35173-cups.general@news.easysw.com
    > Message ID: (References above) 35213-cups.general@news.easysw.com
    >
    > Thinking this is openSUSE 11.1 (x86_64) problem. Since last Sunday after
    > successfully repairing errors on my disk drive (ext3 formatted) I can not
    > print to my Xerox Phaser 6120. I can print from another openSuSE 11.1
    > (X86_32) system that does not have all the updates and from a 11.2
    > milestone 1 (X86_64) system. My 11.1 system is my production system and
    > has all the updates before Last Sunday. rest of configuration is below in
    > signature.
    >
    > If I follow the link in the error message it says to change the version of
    > Avahi back to the native version. One bug (plus 2 duplicates) in bugzilla
    > talked about this and said it is fixed. I have the latest updates for cups
    > 1.3.9 installed, is this a regression? I will open a bug report.
    >
    > Start up log error:
    >
    > May 9 07:34:42 linux-ebgz cupsd[3881]: *** WARNING *** The program
    > 'cupsd' uses the Apple Bonjour compatibility layer of Avahi.
    > May 9 07:34:42 linux-ebgz cupsd[3881]: *** WARNING *** Please fix your
    > application to use the native API of Avahi!
    > May 9 07:34:42 linux-ebgz cupsd[3881]: *** WARNING *** For more
    > information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=cupsd>
    >
    > any suggestions on how to manual fix would be appreciated. I can not print
    > from my production system without emailing the file to my 11.2 system.


    Problem solved. after reading several bug reports about avahi. I went into
    YaST and Software Management --> avahi and installed all rpms that said
    avahi. Then went into cups. did add printer and this time the printer
    showed. It then printed test page and I printed a document that would not
    print again.

    Not sure which rpm actually fixed it, must have been a file that the ext3
    error corrupted and even though the repair function on the DVD said they
    were successfully repaired, something must have remained bad.
    --
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •