Results 1 to 4 of 4

Thread: General shortcuts not working

  1. #1

    Exclamation General shortcuts not working

    i'm using openSUSE 11.1 and KDE 4.2.2 release 114

    after last update general shortcuts stoped working

    when I go to Personal Settings->Keyboard & Mouse->Keyboard Shortcuts I get this dialog:
    Failed to contact KDE global shortcuts daemon
    Message: No such object path '/KdedGlobalAccel'
    Error: org.freedesktop.DBus.Error.UnknownObject
    if I try to change general shortcuts in any application, dialog saying "The shortcut 'typed shortcut' conflicts with the following key combinations:" and no combinations listed

    does anybody know how to solve it?


  2. #2

    Default Re: General shortcuts not working

    Running OpenSuse 11.1 KDE 4.2.3 release 116

    I know there is a conflict with amarok and global shortcuts in KDE4, with a link to a (possible) fix below.
    'Fix for crashing kded4 with KDE 4.1' - MARC

    I have the same problem, with a slightly different error message:

    Failed to contact KDE global shortcuts daemon
    Message: Could not get owner of name 'org.kde.kded': no such name
    Error: org.freedesktop.DBus.Error.NameHasNoOwner
    Sadly it didn't work for me, so I uninstalled amarok, but still have the problem of the daemon crashing .

    If anyone has any ideas? Many thanks

  3. #3

    Default Re: General shortcuts not working

    well, this isn't exactly my problem:
    all local shortcuts (set in apps) are working, no app cause kded4 crash, but global shortcuts don't work

    but thanks for recurrence

  4. #4
    juaurib NNTP User

    Default Re: General shortcuts not working


    I have the same problem. Most annoyingly Alt-Tab doesn't work.

    I tried the amarok fix but still no shortcuts.

    Any ideas?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts