Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: desktop folder problems

  1. #1
    Join Date
    May 2009
    Location
    Hot 'Lanta!
    Posts
    11

    Default desktop folder problems

    hello ... somehow I lost all my desktop folders; googled for instructions how to get them back, but now all of them open in Kwriter. please help me fix this!! (have to go to menu to get Firefox, documents won't open correctly from desktop icons, etc.-everything goes to Kwriter). Ugh-h-h-h!! Please be specific; I just dumped Windows and know next to nothing about OpenSUSE (11.1).

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: desktop folder problems

    Hi,

    Alright, what you'll want to do is right click on your desktop and choose Add Widgets. The add widgets dialog will come up and you'll see it has a search bar. Type Folder View into the search bar. Click on Folder View and then click Add Widget. This will bring the desktop folder back.

    You can change the folder being viewed (I'm guessing you want the Desktop folder if it had your application launchers in it) by hovering the mouse over the folder view widget and then selecting the wrench icon. Tell it to show the Desktop Folder.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3
    Join Date
    May 2009
    Location
    Hot 'Lanta!
    Posts
    11

    Default Re: desktop folder problems

    Thanks very much, Ian; wow, that was a fast reply ... unfortunately I don't think it's going to be that easy. I followed your instructions, which I is same way I got them back earlier, but now I just have duplicate sets of icons that all open up into Kwrite (incl. Firefox). I know I can delete one set but still this problem: any application icons show as a "T" (text file) and they default to/open in Kwrite. I see a filter in desktop widget settings about file types but it's greyed out. I have .jpeg, .zip, doc file icons, etc., which had been opening with correct programs but now just go to "open with" and when I don't know/click the correct program to open them with, they just don't open at all (I guess that's why). I should mention I had been going thru all the menus, checking out the settings including updating when I came across it, trying to learn my options, and I guess I did something I shouldn't have, but didn't realize until I'd already been thru so many menus/settings that I have no clue what it is I must've done wrong. Ah- I see when clicking 'properties' on a .jpeg icon it says 'mime type'. I recall a number of update errors referring to mime types. I hadn't gotten around to investigating that yet. I'm beating my head against the wall here ... (!) Please bear with me. Ideas? Quick directions to reinitiating/correcting the failed mime updates? (It would take me a WHILE to find it.) Thank you!

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: desktop folder problems

    Haha I know how you're feeling. I was just introduced to linux a little over 5 months ago and the switch was actually very fun for me. I loved the challenge of linux and learned a lot through trial and error. I know that this isn't the case for most, so I'll try to help you out to the best of my knowledge.

    Those launchers in that folder? They're called Desktop Configuration Files. They end in .desktop. So, for example, firefox on there would be Firefox.desktop or mozillafirefox.desktop. This gives instructions for what to launch and the icon for the launcher. When it's not set as executable it will open in Kwrite. So to fix this, right click on the launcher that won't open properly and go to the permissions tab and make sure "is executable" is checked.

    As for the .jpeg and .zip files, they should open with their respective programs. For KDE when you go to open a .jpeg file, if it asks what to open with, under Known Applications find the category Graphics. Click the plus next to it then (for mine it's under photography, but it should be under one of those subcategories) find Gwenview and click it. It will show up under Open with (for me it shows up as gwenview %u -caption "%c" %i). Down at the bottom put a check next to Remember application association for this type of file.

    Do the same thing for .zip except this time you'll use ark. It can be found under Utilities>Archiving>Ark.

    I think that's what you're saying. If those don't work just post back.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5
    Join Date
    May 2009
    Location
    Hot 'Lanta!
    Posts
    11

    Smile Re: desktop folder problems

    Ah-HA! But ... there isn't a 'universal' way to just put them back the way they were, which was, all were working just fine in the first place (after installation, before I started fishing around in all the user settings & encountered some unresolved update errors) before something screwed up?? Wish I knew how it happened so I might avoid it happening again. if not, still ... THANKS, Ian!!

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: desktop folder problems

    That will make any .zip or .jpeg open with the right application. Otherwise the only other thing I can think of is to click the Application Launcher (similar to the start menu in windows, it should either be a k-icon or a green openSUSE lizard icon in your panel) then choose Configure Desktop (Personal Settings) then click the advanced tab. Under Advanced User Settings is File Association. Here you can tell the different extensions what to open with.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7

    Default Re: desktop folder problems



    Easy way here is to rename the .kde(*) folder/s to .kde_bak or delete them if you rename then you can try to save some bits without reconfiguring everything.

    That should get you back to defaults or try a new user see if they replicate the problem
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  8. #8
    Join Date
    May 2009
    Location
    Hot 'Lanta!
    Posts
    11

    Red face Re: desktop folder problems

    " ... Easy way here is to rename the .kde(*) folder/s to .kde_bak or delete them ..."

    Say what? Okay, you Linux guru ... you're writing to a complete newbie here (sorry!!). Please explain in 'layman's terms' so I won't screw something else up by thinking I've found it but not really and changing the wrong thing. How exactly do I get to/where do I find the .kde(*) folder/s and what goes where the asterisk is, do I drop the parentheses, etc.?? Not sure I get that - I'll be guessing. Thank you so much for your time!

  9. #9
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: desktop folder problems

    .kde is found by opening up Dolphin (your file browser). It should automatically be at Home. At the top click view, then choose Show hidden files. Find the folder .kde and rename it .kde_bak if you'd like to try to save settings or just delete it if you don't mind reconfiguring you background, settings, etc... Then log out and log back in.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  10. #10
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: desktop folder problems

    Also rename and/or delete the .kde4 folder as well. The two folders will be next to each other.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •