Page 1 of 7 123 ... LastLast
Results 1 to 10 of 66

Thread: Compiz newbie

  1. #1

    Default Compiz newbie

    I read some of the other threads but Im new to opensuse. I installed Nvidia drivers(geforce 5500FX). Also, I removed all compiz through software manager, and did rm -rf ~/.config/compiz. I clicked the 1 click install for gnome. and I get this...

    "An error occurred while initializing the software repository.
    Details:
    System management is locked by the application with pid 4869 (/usr/lib/YaST2/bin/y2base).
    Close this application before trying again.
    Try again?"

    I am in failsafe mode bc when I boot the gui doesnt come up in regular mode. Is there anyway to reset sax2 to default. I think its bc I was playing around with the graphics card settings, But Im not sure.

    One last question is whats the difference between (default) and (pae)

  2. #2

    Default Re: Compiz newbie

    Then I clicked retry and got to where u need to name the repository and got to this...

    "There are some conflicts on the transaction that must be solved manually. .... requires compiz=0.8.2

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz newbie

    Hi,

    You'll need to run

    Code:
    sax2 -r -m 0=nvidia
    Then restart and the gui should work.
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz newbie

    Also, I think these are the conflicts you're getting when installing compiz, follow this thread to get it sorted out.

    Compiz Problim - openSUSE Forums

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5

    Default Re: Compiz newbie

    well lets start with the easiest fix (hopefully) gettin you back out of having to run in failsafe switch your system to runlevel 3, if your unclear on how this is done let me know and i will walk you through that

    once in runlevel 3 sign in as root and run the following command
    Code:
    sax2 -r -m 0=nvidia
    this should correct your display if not then some of the advice in this thread

    next there is no reason to remove all your compiz software simply to use the one click install as this will inevitably lead to duplication of the same repo in your system(eats time with no real purpose)as i am opposed to this if you'd like i can walk you through adding the compiz repo to yast instead

    just let me know and i will try to be as helpful as possible

  6. #6

    Default Re: Compiz newbie

    I finally got it installed and everytime I go to desktop effect to enable them it says its not compatible with my hardware or configuration, and I enable it anyways. But none of the stuff works. And when I close out of desktop efeects and go back into it they are not enabled anymore.


    And ty entreatos, I dont know how to get to runlevel 3.

  7. #7

    Default Re: Compiz newbie

    I got to init 3. then typed it in and it said no x server was running. Then it said sorry could not start configuration server.

  8. #8
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz newbie

    Could you post a copy of your xorg.conf?

    It's located at /etc/X11/
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  9. #9

    Default Re: Compiz newbie

    Here it is.

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 23 15:33:27 PST 2009

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-05-02T16:03:22-0500.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen "Screen[0]" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "freetype"
    Load "dbe"
    Load "glx"
    Load "extmod"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImPS/2 Logitech Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    ModeLine "1024x768" 78 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "DELL"
    ModelName "E773C"
    UseModes "Modes[0]"
    DisplaySize 310 230
    HorizSync 30.0 - 70.0
    VertRefresh 50.0 - 160.0
    Option "CalcAlgorithm" "XServerPool"
    Option "DPMS"
    Option "PreferredMode" "1280x768"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    VendorName "NVidia"
    BoardName "GeForce FX 5500"
    Screen 0
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    Option "UseInt10Module"
    Option "CIOverlay"
    Option "MultisampleCompatibility"
    Option "Dac8Bit"
    Option "NoBandWidthTest"
    Option "HWcursor"
    Option "Overlay"
    Option "CursorShadow"
    Option "AllowDFPStereo"
    Option "ForceEmulatedOverlay"
    Option "RenderAccel" "True"
    Option "AddARGBGLXVisuals" "True"
    SubSection "Display"
    Depth 15
    Modes "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

  10. #10

    Default Re: Compiz newbie

    Also, when I go to the Nvidia X server setting it says you do not appear to be using the Nvidia x driver. But when I go to sax2 it says the name of my vid card(GeForce 5500FX). (I already typed in nvidia-xconfig and rebooted.)

Page 1 of 7 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •