I recently tried to clone my openSUSE installation (ext3 based) with the "dd" command. After some four hours it seemed that everything was cloned. I changed the fstab entries on the cloned installation to reflect all the new changes. I couldn't get the grub to work so I used the grub on the old hard drive to boot into the cloned drive and it worked. I was able to boot into the cloned drive with no problems. However here is where I ran into a serious issue. It seemed that all my KDE preferences were reset. Like font sizes, color themes, etc. Same went for preferences for every single application from Firefox to Opera and similar. It looked like "dd" command cloned/copied everything except application preferences.

Anyone have any idea how I can clone my openSUSE install in full, app preferences and all?

I am running 64bit openSUSE 11.1 and KDE 3.5

Any assistance would be appreciated.

Also, the source and destination drives weren't really drives. Source was a PATA RAID0 array (2x160GB) and destination was a SATA RAID0 array (2x160GB). So you can understand why I couldn't use utilities like gparted or any of the rescue distros since none of them really recognize my RAID arrays. (gparted for example only sees individual drives)