Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Digikam recently only sees the 1st image in my camera

  1. #1

    Default Digikam recently only sees the 1st image in my camera

    When I connect my digital camera to my computer and it automatically brings up Digikam to download my camera images, it now only shows the 1st picture out of many in the camera?? I never had a problem until recently. I think it is because of a version update. When I click on the /media/disk folder, I see all the images, but Digikam does not see them. Strange. I have opensuse/packman repos on my computer with all the latest software updates.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Digikam recently only sees the 1st image in my camera

    Except you don't tell us what version of kde

    Maybe post your repo info:

    Code:
    zypper lr
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Digikam recently only sees the 1st image in my camera

    3.5.10 "release 46"....sorry about that.

    Doug@linux08:~> zypper lr
    # | Alias | Name | Enabled | Refresh
    --+--------------------------+--------------------------+---------+--------
    1 | KDE:KDE4:Factoryesktop | KDE:KDE4:Factoryesktop | Yes | Yes
    2 | repo-oss | openSUSE-11.0-Oss | Yes | Yes
    3 | Packman Repository | Packman Repository | Yes | Yes
    4 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | Yes
    5 | repo-debug | openSUSE-11.0-Debug | No | No
    6 | KDE:Qt | KDE:Qt | Yes | Yes
    7 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    8 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
    9 | X11GL | X11GL | Yes | Yes

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Digikam recently only sees the 1st image in my camera

    Quote Originally Posted by Doug08 View Post
    3.5.10 "release 46"....sorry about that.

    Doug@linux08:~> zypper lr
    # | Alias | Name | Enabled | Refresh
    --+--------------------------+--------------------------+---------+--------
    1 | KDE:KDE4:Factoryesktop | KDE:KDE4:Factoryesktop | Yes | Yes
    2 | repo-oss | openSUSE-11.0-Oss | Yes | Yes
    3 | Packman Repository | Packman Repository | Yes | Yes
    4 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | Yes
    5 | repo-debug | openSUSE-11.0-Debug | No | No
    6 | KDE:Qt | KDE:Qt | Yes | Yes
    7 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    8 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
    9 | X11GL | X11GL | Yes | Yes
    You say kde3
    But you list kde4 factory??
    If you have kde3 and kde4 you need to be clear

    kde4 factory should be deleted and replaced with the following:
    Index of /repositories/KDE:/42/openSUSE_11.0
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE_42

    You need to do an update all unconditionally in these 2 repo's above!

    you probably don't need that kde qt repo.

    If you just check what version of digikam you are using because recent updates might have confused matters!!
    Code:
    rpm -qi digikam
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Digikam recently only sees the 1st image in my camera

    OK, I deleted those 2 repos, and added the 2 new repos to my YAST/Smart repo list. I did a full update and upon installing the new KDE4 programs, I got an error from Smart that some of the new KDE4 programs to be installed clashed with some of my kde 3.5 programs.

    Smart Error> file /usr/share/man/man1/kbookmarkmerger.1.gz from install of kde4-konqueror-4.2.2-79.20 conflicts with file from package kdebase3-3.5.10-101.1
    file /usr/share/man/man1/ark.1.gz from install of kde4-ark-4.2.2-52.12 conflicts with file from package kdeutils3-3.5.10-48.5
    file /usr/share/man/man1/kfind.1.gz from install of kde4-kfind-4.2.2-79.20 conflicts with file from package kdebase3-3.5.10-101.1

    Digikam:
    Doug@linux08:~> rpm -qi digikam
    package digikam is not installed
    Doug@linux08:~> rpm -qi kde3-digikam
    Name : kde3-digikam Relocations: (not relocatable)
    Version : 0.9.5 Vendor: openSUSE Build Service
    Release : 6.4 Build Date: Thu 30 Apr 2009 09:22:41 PM EDT
    Install Date: Sat 02 May 2009 06:00:28 PM EDT Build Host: build22
    Group : Productivity/Graphics/Viewers Source RPM: kde3-digikam-0.9.5-6.4.src.rpm
    Size : 27688046 License: GPL v2 or later
    Signature : DSA/SHA1, Thu 30 Apr 2009 09:23:50 PM EDT, Key ID 58d8ff412e1efa87
    URL : http://www.digikam.org/
    Summary : A KDE Photo Manager
    Description :
    digiKam is a simple digital photo management application for KDE, which
    allows you to import and organize your digital photos easily. The
    photos can be organized in albums, which can be sorted chronologically,
    by directory layout, or by custom collections. An easy-to-use interface
    that enables you to connect to your camera and preview, download, or
    delete your images, is provided.

    Please let me know if I should change these (2) repos on SMART, I suspect they are the problem with the new installs. Thanks

    kde4 extra apps> Index of /repositories/KDE:/KDE4:/STABLE:/Extra-Apps/openSUSE_11.0

    KDE3 Repo> Index of /repositories/KDE:/KDE3/openSUSE_11.0


    I also deleted the qt repo.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Digikam recently only sees the 1st image in my camera

    The kde3 build service should be fine
    But the kde4 stable certainly needs to go

    Do you have different repo's in smart than was reported in zypper?

    No wonder this is messed up.

    Smart is fine and I used to use it back in the 10.0 days, but all it needs to be now is a fallback.
    Use Yast software management and make sure you have the correct repo's. Your zypper output before didn't show the kde3 build service or the kde4 stable you just quoted.
    You need to get this sorted and stick with one system.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Digikam recently only sees the 1st image in my camera

    OK, deleted the "stable" repo, then did a channel update and went to install and got the same error again regarding the kde3-3.5. I like Smart much better than Yast. What do I do to get rid of the error. I want BOTH KDE3 and KDE4 installed on my computer so I have a choice.

    Doug@linux08:~> zypper lr
    # | Alias | Name | Enabled | Refresh
    --+-----------------------+-----------------------+---------+--------
    1 | repo-oss | openSUSE-11.0-Oss | Yes | Yes
    2 | Packman Repository | Packman Repository | Yes | Yes
    3 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | Yes
    4 | KDE: | KDE: | Yes | Yes
    5 | repo-debug | openSUSE-11.0-Debug | No | No
    6 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    7 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
    8 | X11GL | X11GL | Yes | Yes

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Digikam recently only sees the 1st image in my camera

    Quote Originally Posted by Doug08 View Post
    OK, deleted the "stable" repo, then did a channel update and went to install and got the same error again regarding the kde3-3.5. I like Smart much better than Yast. What do I do to get rid of the error. I want BOTH KDE3 and KDE4 installed on my computer so I have a choice.

    Doug@linux08:~> zypper lr
    # | Alias | Name | Enabled | Refresh
    --+-----------------------+-----------------------+---------+--------
    1 | repo-oss | openSUSE-11.0-Oss | Yes | Yes
    2 | Packman Repository | Packman Repository | Yes | Yes
    3 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | Yes
    4 | KDE: | KDE: | Yes | Yes
    5 | repo-debug | openSUSE-11.0-Debug | No | No
    6 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    7 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
    8 | X11GL | X11GL | Yes | Yes
    Now you didn't add these though
    Index of /repositories/KDE:/42/openSUSE_11.0
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE_42

    do this and try the update from Yast software management
    If you get the error there I might have more idea.

    But there will be issues with kde3 and kde4 for now. Why?
    Well early on kde4 apps were prefixed eg: kde4-digikam and kde3 was just digikam.
    But now it's just digikam in kde4, and kde3 has the prefix; kde3-digikam

    FYI: I find the kde4 version much better
    And I suspect you will have to delete some packages to sort dependency issues, at least for the time being. You may be able to bring them back after. It's tricky.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Digikam recently only sees the 1st image in my camera

    Everything screwed up now. Before the only problem I had was digikam not seeing all my pics. Now I changed the repos, and I cannot get everything to install now due to errors. Since I ONLY use kde3, how can I get rid of kde4 without losing all my programs? Using Smart.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Digikam recently only sees the 1st image in my camera

    Don't even consider that. It will bork your system for sure. You really need to know what you are doing.

    Your issue is solvable!

    Save errors to file with the expert button and let us see them
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •