Results 1 to 10 of 10

Thread: Impossible to connect to NXserver with NX client on Windows

  1. #1

    Default Impossible to connect to NXserver with NX client on Windows

    Today I upgraded my nxserver 3.2.0 to 3.3.0 and since then, nothing but trouble.
    I even completely removed it and reinstalled it but still no go.

    When I try to connect I get this :

    NX> 203 NXSSH running with pid: 2376
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: 192.168.1.3 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    NX> 204 Authentication failed.


    The strange thing is that it says authenticating user nx while I'm using my own username. I don't know if it's normal.

    I tried about everyting I found on the net, enabling and disabling encryption in the client, regenerating keys with the keygen command, checking my user with the --usercheck option which created my correct ssh keys etc...

    Nothing works. I know I had a hard time getting the previous version to work as well but I forget how I fixed it.

    So for as far as I can see in the error, it's all about key issues, but I don't know how to get it fixed.

  2. #2
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: Impossible to connect to NXserver with NX client on Wind

    I will try to help on this as I installed this few times after I had some issues. First of all the server is on the opensuse? the client is on the windows? Can you connect via ssh from windows to suse? if yes it seems that everything is ok with ssh. Can you post the server configuration file so I can compare it with my file ? Please block all info which are sensitive in the file(ip address,ports,etc). don't worry about nx client in the log it's the same in my logs. Also be aware that port 22 for ssh if it's open it will be scanned and you'll have hackers trying to get into your machine. I would suggest to turn it off on the router until you change it to a different one. I had few thousands attacks in just few days. I have the ip's and found even the servers from they attacked me and I will try to alert the providers if they care about it.

  3. #3

    Default Re: Impossible to connect to NXserver with NX client on Wind

    Well, just as with the previous version I didn't change anything in the config files. Just installed the packages and tried to connect as the manual says that in its default config it will allow any systemuser to connect right away.

    Only not this time.
    Even right after the installation I get this message :

    Preparing... ########################################### [100%]
    1:nxserver ########################################### [100%]
    NX> 700 Installing: server at: Sat May 02 10:47:56 2009.
    NX> 700 Autodetected system: suse.
    NX> 700 Install log is: /usr/NX/var/log/install.
    NX> 700 Creating configuration file: /usr/NX/etc/server.cfg.
    NX> 723 Cannot start NX statistics:
    NX> 709 NX statistics are disabled for this server.
    NX> 700 WARNING: Error when trying to connect to NX server, error is:
    NX> 700 WARNING: nxsetup cannot validate the sanity of the current installation:
    NX> 700 WARNING: the current system or NX configuration could be broken.
    NX> 700 WARNING: If difficulties arise (for example sessions cannot be started),
    NX> 700 WARNING: it is advisable that you try to uninstall the NX server and the
    NX> 700 WARNING: NX client packages then install them again.
    NX> 700 WARNING: Search also the NoMachine Knowledge Base at the URL below:
    NX> 700 WARNING: NoMachine NX - Support: Knowledge Base Search
    NX> 700 WARNING: for common errors encountered when performing a software update
    NX> 700 WARNING: and the related hints on how to solve them..
    NX> 700 Installation of NX server was completed with warnings.
    NX> 700 Please review the install log '/usr/NX/var/log/install'
    NX> 700 for further details.
    NX> 700 Showing file: /usr/NX/share/documents/server/install-notices


    I then followed the manual and tried this :

    Generating a new DSA key-pair
    ● Login as root on on the NX server host machine and run:
    /usr/NX/bin/nxserver --keygen
    Distributing the new SSH private key to the clients
    ● Change the ownership and permissions on the authorized_keys file. Depending on
    which O.S. your NX is running on, you may need to execute:
    chown nx:root /usr/NX/home/nx/.ssh/authorized_keys2
    chmod 0644 /usr/NX/home/nx/.ssh/authorized_keys2
    Or:
    chown nx:root /usr/NX/home/nx/.ssh/authorized_keys
    chmod 0644 /usr/NX/home/nx/.ssh/authorized_keys
    ● Change the ownership and permissions on the following file.
    chown nx:root /usr/NX/home/nx/.ssh/default.id_dsa.pub
    chmod 0644 /usr/NX/home/nx/.ssh/default.id_dsa.pub
    Document Prot.D-811_002-NXS-SAG Page 13 of 36
    en
    NX Server System Administrators Guide
    Prepared by:
    Silvia Regis
    N:
    D-811_002-NXS-SAG
    Approved by:
    Sarah Dryell
    Signature: Date:
    12/11/2008
    Amended:
    A
    ● Distribute the private key from the newly generated key pair located in the file:
    /usr/NX/share/keys/default.id_dsa.key
    ● Once the new key has been distributed to clients, place it under the subdirectory
    'share/keys' of the NX Client installation tree reserved for this purpose.
    When the key has been placed in the above location, use the key management
    facilities provided by the NX Client GUI in the 'General' tab of the session
    configuration window, click on the 'Key' button and choose Import to import the new
    key by navigating to the appropriate directory above. Click Save to save your
    changes.


    But the issue remains.
    Whatever I do, it's not working.


    The installation is done on an opensuse 11.1 and yes, SSH is working fine.
    The box is sitting behind a router and all ports are closed from the outside, its use is intended for inside the network only.
    My ISP blocks all incoming traffic below port 1024 anyway, so it wouldn't work out of the box from the net anyway.

  4. #4

    Default Re: Impossible to connect to NXserver with NX client on Wind

    I also installed the NXManager to administer this thing via a webinterface, all is setup correctly, I open the interface, log in with the default credentials and as soon as I click on any of the option in the interafe I'm thrown back to the login screen telling me that I'm not logged in.

    When I try to login as guest, the same thing happens. When I try to change my password it seems to do it but when I try to login no password at all is accepted, not the default and not my own.

    I get the feeling that this whole thing is not working at all on opensuse 11.1.

    I've been loosing more than 6 hours already with this "simple as install and run"-thing.

  5. #5

    Default Re: Impossible to connect to NXserver with NX client on Wind

    And I just did the same thing again, following these steps :

    http://www.linux-tip.net/cms/content/view/368/1/

    And teh result is the same, unable to connect with the same error message in the client :

    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    NX> 204 Authentication failed.

  6. #6

    Default Re: Impossible to connect to NXserver with NX client on Wind

    I just reinstalled opensuse 11.1 in VMware virtual machine and installed NX Server inside the VM.
    This time it installed without the error message :

    NX> 700 WARNING: Error when trying to connect to NX server, error is:
    NX> 700 WARNING: nxsetup cannot validate the sanity of the current installation:
    NX> 700 WARNING: the current system or NX configuration could be broken.
    NX> 700 WARNING: If difficulties arise (for example sessions cannot be started),
    NX> 700 WARNING: it is advisable that you try to uninstall the NX server and the
    NX> 700 WARNING: NX client packages then install them again.
    NX> 700 WARNING: Search also the NoMachine Knowledge Base at the URL below:
    NX> 700 WARNING: NoMachine NX - Support: Knowledge Base Search
    NX> 700 WARNING: for common errors encountered when performing a software update
    NX> 700 WARNING: and the related hints on how to solve them..
    NX> 700 Installation of NX server was completed with warnings.


    When I try to start it on the normal pc, it seems to do something but when I run "nxserver --status" it gives the same authentication problem as on the client.

    So my conclusion is that this is not exactly a key-pair issue but more something that on the system that prevents nxserver to install and run correctly.
    The question is what ?? Why does it work inside the newly installed opensuse and not on my existing one ?

    This is really timeconsuming...

  7. #7

    Default Re: Impossible to connect to NXserver with NX client on Wind

    Finally solved !!

    I discovered that the installed tries to add a new system user to the list of users when installed.
    This user has the name "nx" and needs to be allowed to log on to SSH (for whatever reason that may be).

    But it could not log on to the ssh server during installation because I configured my ssh server to only allow one specific end user to connect so the nx user could not be used, hence, the installer stops and the server does not start.

    I now added nx as alowed user in SSH and the installer did the jb correctly and it runs fine now and it connects with the default or my own created keys.

    At last, after more than a complete day of searching.

    Now I need to get this thing running with compisiting on. For now, it loads the screen with the screenlets and cairo-dock at one applet every 15 seconds.
    More than 5 minutes to get control over the desktop.

    Yet some more stuff to get me going...

  8. #8
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: Impossible to connect to NXserver with NX client on Wind

    Glad to hear that you were able to solve it. Not sure how you setup ssh server to limit/restrict the numbers of users. I was thinking that the problem was with incorrect key. I connect from work home and don't have any issues with the speed. I use a higher port to connect to my network and then the router forward the request to my server. My way of doing it was in 3 steps :
    1. one computer - connect via ssh from opensuse to itself. After I did this I connected the Nxclient to the server on the same machine.
    2. internal network - connect via ssh from another machine(my windows machine) and then through nxclient on the windows to the server on the opensuse.
    3. outside world - via ssh (initially on port 22 then changed the port to another higher port. ) and then via NX
    I found this to be a step by step approach which would eliminate the complexity of trying to figure out where the problem is.

  9. #9

    Default Re: Impossible to connect to NXserver with NX client on Wind

    Limiting logins to SSH is easy and important for security, especially on an open system.
    Anyway, the speedissue is resolved.

    It was due to the screenlets being loaded when the Windowmanager starts.
    I created a script that removes the screenlets autostart files whenever I use NX connections and restores them when I'm on the machine itself.

    Pretty simple and functional.

    Still need to fix my recycle bin issue though.

  10. #10

    Default Re: Impossible to connect to NXserver with NX client on Wind

    Here is my findings on OpenSuSE 12.2, I've fixed issue straight after install with command.
    sudo mv /usr/NX/home/nx/.ssh/authorized_keys2 /usr/NX/home/nx/.ssh/authorized_keys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •