Results 1 to 4 of 4

Thread: Mouse Config (MX1100)

  1. #1

    Default Mouse Config (MX1100)

    Hey all. Just got a Logitech MX1100 Laser Mouse and it's working great except for one thing... horizontal scroll (the wheel is a tilt wheel, so I should be able to scroll up/down and also tilt left/right).

    Nothing is showing up as far as events go under xev for the tilting, so I am not sure where to start. Here's the xorg.conf section:

    Code:
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"
        Option         "Buttons" "10"
        Option         "Emulate3Buttons" "on"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "Logitech MX1100 Laser Mouse"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
        Option         "ButtonMapping" "1 2 3 7 6"
    EndSection
    Any help would be appreciated, thanks.

  2. #2

    Default Re: Mouse Config (MX1100)

    Well, I've made some progress by changing the driver to "evdev" and the device to "/dev/input/event8".

    Now all the buttons do something (including the horiztonal titling). Now, though, I cannot make the tilting actually do horizontal scrolling, it is acting as a back/forward set (like the thumb buttons).

  3. #3

    Default Re: Mouse Config (MX1100)

    I managed to get this working with a combination of evdev, xbinkeys, and xmodmap.

  4. #4
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •