Results 1 to 4 of 4

Thread: Gconf Error when running as root

  1. #1

    Exclamation Gconf Error when running as root

    hey hello everyone,

    well i really need your help with this, this is the first time i post something here, and Ive been looking in google for days and for the first time in my life i cant find something that i can use to fix this.

    I have a problem with my Gconf i think, because everytime i run any command as SU it gives me an error, the weird thing is that it only happens when i try to run graphical things like "nautilus &" or "firefox &", but if i do any command to copy, move, etc it works fine.

    Im using OpenSuse 11.1 with gnome 2.24.1, Kernel version 2.6.27-0.1-pae

    Thanks for your help everyone

    here is the error im getting,


    (nautilus:24311): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

    (nautilus:24311): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

    (nautilus:24311): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    GConf warning: failure listing pairs in `/apps/nautilus/preferences': Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    (nautilus:24311): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

    (nautilus:24311): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

    (nautilus:24311): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

    (nautilus:24311): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

  2. #2

    Default Re: Gconf Error when running as root

    by the way if i do Alt+F2 then enter gnomesu nautilus it works fine, thanks for your help once again

  3. #3
    Join Date
    Sep 2008
    Location
    Belgium
    Posts
    243

    Default Re: Gconf Error when running as root

    Quote Originally Posted by hdorath View Post
    I have a problem with my Gconf i think, because everytime i run any command as SU it gives me an error, the weird thing is that it only happens when i try to run graphical things like "nautilus &" or "firefox &", but if i do any command to copy, move, etc it works fine.
    Same here (errors, but the application opens).
    This happens under KDE - and other distribution - as well.
    (See: Mandriva bug #43701 and openSUSE bug #463994)
    (Makes me think it's a bug at the kernel level.)

    dbus related problem ? -> bug #428963

    New habit to take (use "su -" instead of "su") ?

    Anyway, in the meantime this problem is resolved, I suggest to either use:
    Code:
    gnomesu <application>
    <password>
    or
    Code:
    su -
    <password>
    <application>
    The dark side of the American Dream of few may enjoy is that it is often built upon the nightmare many have to live with.

  4. #4

    Talking Re: Gconf Error when running as root

    hey thanks for the reply,
    yes i was checking the link u posted and it seems to be a kernel issue, well i hope they fix it as soon as posible, and thanks for your advice, i did "su -" and it worked fine, so ill continue to use that, because id been checking all over the internet and nothing seemed to work so thanks once again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •