Results 1 to 5 of 5

Thread: kopete is not detecting my webcam

  1. #1

    Default kopete is not detecting my webcam

    Hi.. I am using dell studio 15 laptop..it has an integrated webcam... I'm able to view my webcam in skype but not in kopete... in kopete, no image is displayed...morover, when i'm sending a request, the other person is not getting the request.... I'm also not able to accept others invitations... and I'm using yahoo client...plz help...

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,195
    Blog Entries
    1

    Default Re: kopete is not detecting my webcam

    Similar thread. Not sure where this bug is at...

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,195
    Blog Entries
    1

    Default Re: kopete is not detecting my webcam

    This KDE Wiki: Webcam How To may also be of value re network port configuration if applicable.

    It also contains a troubleshooting section describing possible webcam detection issues due to udev:

    Kopete doesn't see your webcam: in Kopete's configuration dialog, the device section desperately stays empty, but the webcam works with other programs.
    Please check your udev rules and make sure there isn't a rule that create /dev/v4l/by-path/xxxxxxx device that points to /dev/videoX.
    In this case, Kopete will fail to detect your webcam.
    Workaround:
    1) suppress the udev rule that creates the "by-path" device for v4l devices. In my case I did remove the file /etc/udev/rules.d/60-persistent-v4l.rules but this might distro dependent.
    2) remove the offending /dev/v4l/by-path/xxxx file and more over you have to suppress the complete /dev/v4l folder: rm -rf /dev/v4l
    3) restart udev
    4) restart kopete and enjoy now your webcam with kopete :-)
    I wonder if this could be the problem?

  4. #4

    Default Re: kopete is not detecting my webcam

    There is no file called /etc/udev/rules.d/60-persistent-v4l.rules



    sarin@linux-lxe3:/etc/udev/rules.d> ls
    40-alsa.rules 51-packagekit-firmware.rules 55-hpmud.rules 56-sane-backends-autoconfig.rules 70-kpartx.rules 71-multipath.rules 99-pcsc_lite.rules
    40-bluetooth.rules 52-irda.rules 55-libsane.rules 60-pcmcia.rules 70-persistent-cd.rules 77-network.rules
    51-lirc.rules 52-usx2yaudio.rules 56-idedma.rules 65-wacom.rules 70-persistent-net.rules 79-yast2-drivers.rules

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,195
    Blog Entries
    1

    Default Re: kopete is not detecting my webcam

    It was just an idea. Disregard. Anyway, if you search via google you'll get other similar threads:

    Re: [opensuse] Kopete Webcam

    Webcam in openSuSE 11.1 no longer works - openSUSE Forums

    Looks like bug reports have been filed and worked on, so chances are this will be fixed soon via an update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •