Results 1 to 2 of 2

Thread: SANE with iSight camera

  1. #1
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default SANE with iSight camera

    Has anyone got any experience with SANE on the iSight camera (on the MacBook Pro)?
    I'm trying to take a snap and getting the following:
    Code:
    SANE_DEBUG_V4L=255 scanimage
    [sanei_debug] Setting debug level of v4l to 255.
    [v4l] SANE v4l backend version 1.0 build 4 from sane-backends 1.0.19
    [v4l] attach: trying to open /dev/video0
    [v4l] attach: found videodev `Built-in iSight' on `/dev/video0'
    [v4l] sane_get_devices
    [v4l] sane_open: device /dev/video0 found in devlist
    [v4l] sane_open: 1 channels, 0 audio devices
    [v4l] sane_open: minwidth=48, minheight=32, maxwidth=1280, maxheight=1024
    [v4l] sane_open: V4L device can capture to memory
    [v4l] sane_open: can't ioctl VIDIOCGCHAN /dev/video0: Invalid argument
    scanimage: open of device v4l:/dev/video0 failed: Invalid argument
    [v4l] sane_exit: all devices freed
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: SANE with iSight camera

    Don't worry about this now. I reported this bug to sane developers and currently, I am following it up with them - compiling CVS snapshots, testing, sending logs ...
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •