Results 1 to 3 of 3

Thread: Possible to mark a package as "never downgrade"?

  1. #1
    wadenelson NNTP User

    Default Possible to mark a package as "never downgrade"?

    I've got geany 0.16 installed from OBS, but I don't have the repo it came from enabled. Geany 0.15 is available in one of my enabled repos, so every time I run `zypper dup` it tries to downgrade geany from 0.16 to 0.15.

    Is there a way to mark a package so that it is never downgraded, no matter what?

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Possible to mark a package as "never downgrade"?

    * wadenelson,

    man zypper, check the section named "Package Locks Management"
    In short, "sudo zypper addlock packagename"

    HTH

    Uwe

  3. #3
    Join Date
    Jun 2008
    Location
    Albuquerque, NM, USA
    Posts
    87

    Default Re: Possible to mark a package as "never downgrade"?

    As always, the yast software module can be used to lock the package as well.
    It's really that much fun!
    Geeko Samurai (cc)
    My Recent Tracks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •