Results 1 to 3 of 3

Thread: Resume wireless after wifi kill switch on/off

  1. #1
    Join Date
    Jun 2008
    Posts
    40

    Default Resume wireless after wifi kill switch on/off

    I am using Opensuse 11.1 on HP Compaq 6530s, it is in the Novell Yes Certified list for SLED 10, I am not sure how it is certified(SLED 10 is based on Opensuse 10.2, right? X4500 intel video card can work on that?), but I have several problems, the biggest one is, I have to turn on wifi when booting, and keep it on, if I switch it off, then switch it on, the network manager still shows "wireless is disabled".

    As I have to carry the laptop around uni, and I may not be using wifi all the time, so I want to turn it off to save some power(the switch also turns the bluetooth off). After switch off and on, bluetooth can be resumed as the bluetooth icon appears again, but wireless never comes back.

    What can I do to make it work? Do I have to reload/modprobe some module after switch it on?

    Thanks!

  2. #2
    Join Date
    May 2009
    Location
    Jakarta, Beijing
    Posts
    77

    Default Re: Resume wireless after wifi kill switch on/off

    try to restart the network service,

    rcnetwork restart

    worked for me

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: Resume wireless after wifi kill switch on/off

    Ther's a setting in Yast > network devices > network config > edit your wireless > global settings, that let you choose how to connect. This is usually set to <startup>.

    In my laptop, with this set to <on plug> (or something like that, am typing from memory), I can switch the wireless off and on again without problems. I *think* there's a similar setting in the networkmanager applet.

    This laptop is running OS 11.0/KDE3.5.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •