Results 1 to 6 of 6

Thread: Solved the Gnome Firefox Font issue... but

  1. #1
    walid97 NNTP User

    Question Solved the Gnome Firefox Font issue... but

    Hi there,

    I recently installed OpenSuse 11.3 but the Firefox font was way too ugly.

    To solve it, I tried this tip: either delete the .fonts.conf file from the home folder, or delete one entry from this file.

    The file is:

    <?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <fontconfig>
    <match target="font" >
    <edit mode="assign" name="rgba" >
    <const>none</const>
    </edit>
    </match>
    <match target="font" >
    <edit mode="assign" name="hinting" >
    <bool>true</bool>
    </edit>
    </match>
    <match target="font" >
    <edit mode="assign" name="hintstyle" >
    <const>hintmedium</const>
    </edit>
    </match>
    <match target="font" >
    <edit mode="assign" name="antialias" >
    <bool>true</bool>
    </edit>
    </match>
    </fontconfig>

    Now, if you delete the antialias entry, the files becomes:

    <?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <fontconfig>
    <match target="font" >
    <edit mode="assign" name="rgba" >
    <const>none</const>
    </edit>
    </match>
    <match target="font" >
    <edit mode="assign" name="hinting" >
    <bool>true</bool>
    </edit>
    </match>
    <match target="font" >
    <edit mode="assign" name="hintstyle" >
    <const>hintmedium</const>
    </edit>
    </match>
    </fontconfig>

    Save it and restart Firefox. You will notice that the Font is much better (check the letter 'a' in the word Bookmarks in the Firefox menu). Desktop font are also much better!

    Please check out these screenshots:

    Bad:


    Good:


    But another issue popped out: bigger fonts are now crappy (when I removed the antialias entry or the entire fonts.conf file).

    What do you think this issue is? and how to solve it? I thought that I have solved the Firefox font issue, but a new issue came out as a result.

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Solved the Gnome Firefox Font issue... but

    I prefer the bad! Really I do.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Solved the Gnome Firefox Font issue... but

    Me too, the Bad ones are pretty because of the AA and the "Good" ones are ugly. Quadrature of the wheel?
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  4. #4
    Camalen NNTP User

    Default Re: Solved the Gnome Firefox Font issue... but

    walid97 wrote:

    > I recently installed OpenSuse 11.3 but the Firefox font was way too
    > ugly.


    You meant openSUSE 11.1, right? :-)

    > To solve it, I tried this tip: either delete the .fonts.conf file from
    > the home folder, or delete one entry from this file.


    Latest versions of openSUSE (as I recall from 10.3) doesn't need these kind
    of hacks so far. You can disable "antialias" directly from Control center
    (at least from gnome as well as kde).

    So basically, the only thing you have to do is:

    1) Disable antialising from control center
    2) Select the desired font face and font size for apps.

    And that's all. Any app should honor that setting.

    So I suggest you to restore the original ~/.fonts.conf file and proceed that
    way (by adjusting control center's settings) and see what happens.

    (...)

    > Save it and restart Firefox. You will notice that the Font is much
    > better (check the letter 'a' in the word Bookmarks in the Firefox menu).
    > Desktop font are also much better!
    >
    > Please check out these screenshots:
    >
    > Bad:
    > [image: http://img402.imageshack.us/img402/866/bad.png]
    >
    > Good:
    > [image: http://img165.imageshack.us/img165/6512/goodt.png]


    Oh, yes. The "god" image looks better for me, too ;-)

    > But another issue popped out: bigger fonts are now crappy (when I
    > removed the antialias entry or the entire fonts.conf file).
    >
    > What do you think this issue is? and how to solve it? I thought that I
    > have solved the Firefox font issue, but a new issue came out as a
    > result.


    Well, adjusting this is quite easy under KDE's control center, but I have
    not seen any place to configure this under Gnome's control center.

    Let's say you want all fonts smaller than <18 pt keep anti-aliasing off but
    fonts bigger than >18 pt get antialiased. In KDE you can choose a "size
    range" to set up this, but under Gnome I have not found its counterpart :-?

    Greetings,

    --
    Camalen

  5. #5

    Cool Re: Solved the Gnome Firefox Font issue... but

    I think the "bad" one is cool. It looks smooth!

  6. #6
    Join Date
    Jan 2010
    Posts
    2

    Default Re: Solved the Gnome Firefox Font issue... but

    This has been going on for years with all LINUX distributions (KDE and Gnome). Personally the Cleartype fonts look fuzzy and strain my eyes since the fonts are blurry on purpose and my eyes look for edges and borders for feedback that things are focused. Its always a pain to google how to turn off the rendering "features" and recompile the truetype rendering and setting the bytecode thing. Then firefox always requires an extra hack. Its just one of those dumb things about LINUX distributions that never gets addressed in a consistent and intuitive way... partly because of patent issues and partly because Linux community is addressing bigger issues. Hopefully not because fuzzy fonts are the way of the future (Microsoft has gone that direction).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •