Results 1 to 5 of 5

Thread: cannot turn off screensaver in KDE4.2.2

  1. #1

    Default cannot turn off screensaver in KDE4.2.2

    I recently did a clean install of openSUSE 11.1 64 bit with KDE4.1 which I immediately updated to 4.2.2 Factory. I am using a clean/new user ID, so nothing copied or reused from an old user profile, and thus no old settings polluting the install.

    I'm having an issue that I cannot resolve... regardless of screensaver settings, the screensaver kicks in after 6 or 7 minutes, and locks the screen (requiring a password to get back to the desktop).

    I've gone through all the settings I can find in the Personal Settings.

    In Personal Settings > Desktop > Screen Saver, all settings to turn the screensaver on/off and delay times are ignored. Setting password to stop on/off has no effect. No matter what is set, after 6 or 7 minutes, the screensaver kicks in, and requires a password to stop.

    I can change the screensaver type, and this is respected.. ie when the screensaver kicks in, the selected screensaver is shown.

    I want to completely disable the screensaver, and especially the password lock.

    Has anyone observed this behavior? and have any suggestions for what I can do, or where I can go to figure out what is making the screensaver come on when all options are set to OFF?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: cannot turn off screensaver in KDE4.2.2

    Check here

    General tab
    Display
    Power control
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: cannot turn off screensaver in KDE4.2.2

    That's not necessarily the whole story.

    This is one of those areas where KDE really frustrates me... for a lot of things, there are several different ways to do the same thing. Often, you don't achieve your objective until you've gone through ALL the ways, instead of just one! It's one of KDE's biggest problems for user-friendliness.

    Anyway, rant over... There is an additional screensaver setting:

    Go to your system settings
    (Application Launcher -> Configure Desktop)

    There, you have:
    - the 'Desktop' icon (click for screensaver options) and
    - the 'Display' icon (click for monitor powersaving options).

    These are probably the settings you've tried. But there are more... Click the 'Advanced' Tab near the top of the system settings window...

    You'll find a number of duplicated power management settings by clicking on the 'Power Management' icon.

    Hope this helps, I only just worked it out after several frustrating days!

    - Tom C

    Running:
    Opensuse 11.1
    KDE Version 4.1.3 (KDE 4.1.3) "release 4.10.4"

  4. #4

    Default Re: cannot turn off screensaver in KDE4.2.2

    Just an additional point to my earlier post...

    Once in the Advanced -> Power Management dialogue box, you'll need to look both in the 'General Settings' tab, and 'Edit Profiles'. 'Edit profiles' contains three further tabs for Actions, Screen and CPU settings.

    Summary of the click-chain:
    (Application Launcher -> Configure Desktop -> Advanced -> Power Management -> Edit Profiles -> Screen)

    That's 6 layered menus to change a screensaver... Enough said...

    Hope this helps

    - Tom C

  5. #5

    Default Re: cannot turn off screensaver in KDE4.2.2

    I guess choosing the profile 'Presentation' when viewing a movie is the intended way of (temporarily) disabling screensaver.
    AMD XP 2200+ 735MB RAM, 250GB HD Nvidia GeForce 3 with OpenSuSE 11.1 (custom kernel)

    HP DV7-1010ed laptop Athon-64, 2GB RAM, 250GB HD, ATI RAdeon 3450 with OpenSuSE 11.1 (custom kernel)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •