Results 1 to 4 of 4

Thread: Multimedia Server

  1. #1

    Default Multimedia Server

    Im setting up a media server using openSUSE 11.1 and have a few setup issues i will explain what im tring to achive and hopeful someone will be able to help.

    Im installing openSUSE 11.1 with mediatomb to stream media to my PS3 and Transmission to download torrents. I want a headless server running at runlevel 3 so i can then RDP onto the server from another PC on the network to control it.

    The problems im facing are as follows:

    First off im tring to get everything working in runlevel 5 before i move to runlevel 3.

    I have mediatomb running fine as the loged in user but can't get it to run as a daemon. I have set the daemon to run in the System Services within Yast but this doesn't seem to work, when i go to a web browser and go to the media tomb address i get a mediatomb webpage with a login that i can't log into, and mediatomb doesn't appear on the PS3, some help getting this to work would be great.

    I don't know how to get Transmission to run as a daemon? I know that i have to create a script in /etc/init.d, however i have no idea what to create in this script. An example of what to do would be great or someone who has already done this would be even better. I know there is a Skeleton file but it doesn't really help. Also running Transmission as a daemon will it allow me to login to the server using rdp and add torrents?

    Last problem or more a question as i haven't tried it, if the server is running at runlevel 3 can i connect to it from an Ubuntu 8.10 PC using RDP and login and get a gui? Also will i then be able to open Transmission and add torrents or would i only be able to add torrents using the web page as its running as a daemon, and when i logout of the current session the Transmission will close and the Torrents removed? Sorry of that sounds a bit confusing.

    If there is any better software or way of doing any of the above im open to any suggestions.

    Thanks.

  2. #2
    Rodney_Jr NNTP User

    Default Re: Multimedia Server

    You might have done this already but have you checked your OS firewalls. When installing twonky(Never used media tomb) I had problems with the firewall when I had connectivity problems.

  3. #3
    Join Date
    Jul 2008
    Location
    Antwerp, Belgium
    Posts
    42

    Default Re: Multimedia Server

    Since you are running mediatomb, which requires a apache, mysql and php server, you could checkout torrentflux, this is a web based torrent client.

    For your problem with mediatomb, it sounds like you installed it in your home environment, not system wide. Normally if you have these webbased programs, your computer will never have to go as far as init 3.

    I never boot to init 5 with my server (running xen, with virtual machines for dns, ldap, apache, mysql, oracle, torrentflux, samba, ....).

    Once you start playing with this, you'll never stop :-)
    http://www.philipraets.be
    Hardware: Dell Mini 9, Dell Vostro 1510, Sony Vaio FZ21M, SelfMade PC
    Software: openSUSE, Xen, openLDAP, Samba, Nagios, Apache, MySQL, Oracle, Still no mailserver

  4. #4

    Default Re: Multimedia Server

    Thanks for the reply. I will have to checkout torrentflux, is it in the repository's?

    As for mediatomb i have configured the config file for system wide in /etc/mediatomb but this still hasn't helped when i run it as a daemon in system services?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •