Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Unlock position of KDE4 desktop items

  1. #1
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Unlock position of KDE4 desktop items

    Hi
    I'm running openSUSE 11.1 KDE4 version 4.1.3 standard


    Desktop Settings are Type= Folder View

    Folder View settings are:
    • Location = show the desktop folder
    • Display = Align Icons and Lock Icons are Unticked


    The Gold widget top right hand corner has widgets Unlocked

    Today all the icons and other items on my Desktop became locked in place. I've rebooted to see if they unlock.

    If I move an item it springs back to the place it is locked to / pinned to.

    How do I unlock/unpin everything.

    Thanks
    Swerdna
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Unlock position of KDE4 desktop items

    Seems like a curious case. I'm two releases ahead of you (kde 4.3) and I've tried messing around with some things.

    First, if you're in folderview as your desktop, the unlock and lock widgets only applies to your panel and any widgets you add manually. The files inside the folder view can move even if widgets are set to locked.

    Second, your placement of files gets reset when you change from the folderview desktop activity to regular Desktop then back to folderview. Have you tried switching the desktop activity type to desktop then back to folderview? Perhaps this could reset the whole not-being-able-to-move-things problem.

    Sorry that that's all I can come up with aside from doing the whole rename or delete the .kde4 folder.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Unlock position of KDE4 desktop items

    Another thing you could try is to click on the cashew looking menu on the top right and clicking zoom out. Then choose Add Activity. This will open another Desktop activity. Press the magnifying glass with the plus sign on it to zoom into the new activity. Set the activity to Folder View and see if the problem still persists with the new activity.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Unlock position of KDE4 desktop items

    A variation on your ideas finally worked for me:
    R-click desktop --> select Folder View Settings --> Location. The radio button for "Show the desktop folder" was enabled. I moved it to "Show a custom folder" and selected the folder /home/john/Desktop. That works and back to how I want it.

    Curiously, if I show the Desktop using the original (default) method, they're all still locked.

    But with KDE4 my motto is: whatever works, works.

    Thanks for the advice.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  5. #5

    Default Re: Unlock position of KDE4 desktop items

    This behavior appeared recently on my desktop as well and I'm extremely annoyed by it.

    It worked as expected until the latest round of updates, then all heck broke loose. It seems the developers decided to introduce a new bug into the icon position functions.

    Specifically in my case:

    Until yesterday - "Desktop Folder" widget icon arrangement worked perfectly. Now - all Icons are sorted alphabetically and in a fixed position, regardless of the fact that I have "Unsorted" selected and "Align to grid" and "Lock in Place" un-ticked.

    Just to add insult to injury, after I tried to "fix" it following the suggestion in the above post, my desktop "toolbox" widget disappeared and won't come back.

    grrr

  6. #6

    Default Re: Unlock position of KDE4 desktop items

    toolbox widget reappeared after kwin crash...

  7. #7
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Unlock position of KDE4 desktop items

    oshunluvr adjusted his/her AFB on Sunday 10 May 2009 16:46 to write:

    >
    > toolbox widget reappeared after kwin crash...
    >
    >


    Quick, write a how-to

    :-p


    --
    Mark

    Nullus in verba
    Nil illigitimi carborundum


  8. #8

    Default Re: Unlock position of KDE4 desktop items

    lol -- good one!

  9. #9
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default Re: Unlock position of KDE4 desktop items

    Quote Originally Posted by swerdna View Post
    ...R-click desktop --> select Folder View Settings --> Location. The radio button for "Show the desktop folder" was enabled. I moved it to "Show a custom folder" and selected the folder /home/john/Desktop. That works and back to how I want it. ...
    Thanks a lot swerdna, that helped me too!

    Cheers,
    Hardy

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,846
    Blog Entries
    14

    Default Re: Unlock position of KDE4 desktop items

    Anybody posted a bug report about this?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •