Results 1 to 4 of 4

Thread: autostart in KDE is flipping ?? Need advice from specialists

  1. #1

    Default autostart in KDE is flipping ?? Need advice from specialists

    Hi,

    I have some stuff loading when KDE 4.2 starts. Everything loads correctly but one item, that is cairo-dock, is also autoloading when KDE 4.2 starts.

    I checked the KDE Autostart option in the Configure Destop tool and cairo-dock shows up one time in the list and is checked and enabled.

    But when I start KDE it loads most of the time twice, sometimes it can load up to four processes, making me have 4 docks over each other on the desktop.

    In gnome I don't have this issue ?

    How do I deal with that ? Making it load only once ?

    Thanks.

  2. #2

    Default Re: autostart in KDE is flipping ?? Need advice from special

    Maybe an extra note, I saw that the autostart is done from the .config folder inside the homedir. Same for Gnome.
    When I disable cairo-dock autostart in KDE it still loads in KDE but only once, which is correct, but then it no longer loads when I start Gnome.
    When I activate cairo dock in either KDE Autostart or Gnome Startup Application it loads once and fine in Gnome but at least two times in KDE.


  3. #3

    Default Re: autostart in KDE is flipping ?? Need advice from special

    What about




    Do you have "Restore previous session" set ?
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  4. #4

    Default Re: autostart in KDE is flipping ?? Need advice from special

    No, I configured KDE not to save the session but let me save the session manually whenever I want.
    But I never saved the session after cairo-dock was launched.

    I activated the autostart in gnome and it was automatically started in KDE as well when I did.
    But in Gnome it only starts once, in KDE always twice.

    If I add it to the KDE Autostart myself, then it starts twice in KDE as well and still only once in Gnome.

    If I remove it completely from KDE Autostart then it no longer starts in Gnome but still starts in KDE, but only once.

    If I add it again, the same issue comes back.

    So my guess is that it is started from two different locations, but I can't find from where. I checked all known autostart locations but they are all empty and the once that are filled don't contain cairo-dock as startup item.

    So you see, or I don't start it automatically or I have to close one process manually each time I log in to KDE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •