Results 1 to 5 of 5

Thread: kmail files on samba

  1. #1

    Default kmail files on samba

    Hi community!
    as a new SUSE user (and on switching over from XP to a mixed system environment) I have encountered KMAIL issues I haven't found solved yet:
    I'm trying to save my mails on a remote samba raid disk (at present managed by XP, in near future by linux)
    The samba is mounted via smbfstab:
    //IP-Adress/Mail /home/myself/Documents/Mail cifs,gid=users,fmask=0664,dmask=0775,iocharset=iso8859-15,username=myself,password=mypasswd

    the smyptom is the old-known lost subject/from information which can usually be restored by deleting all index files, but not in my case.
    Only difference I found are the access rights of the local maildir and the samba-maildir:

    local: drwx------ 8 myself users 4096 22. Apr 12:56 mail
    SAMBA: drwxrwxr-x 1 root users 0 23. Apr 23:34 Mail

    Any more information required?

    Where can I find a solution? Samba does not allow me to change the owner, so I couldn't try this!

    Thanks,
    Mirakulix

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: kmail files on samba

    Let's leave out the masks and charset for a moment. You remember that they're there. I want to talk about these bits:
    cifs,gid=users,username=myself,password=mypasswd
    First up, there's a syntax error. You have bundled cifs in as part of the options. It should be separated from the options by a space like so:
    Code:
    cifs gid=users,username=myself,password=mypasswd
    Just so we're on the same page: "myself" and "mypassword" as you've used them above, are the credentials required to be sent from the client machine to the server. "myself" is the username on the server and "mypassword" is the password on the server. Maybe they are exactly the same on the server as on the client. If not then you must use
    Code:
    cifs gid=users,username=myself_on_server,password=my_server_passwd
    I don't use (or understand) kmail. But if the problem is for the ownership to be user:group = myself:users for the directory /home/myself/Documents/Mail, then change the options to this:
    Code:
    cifs uid=myself,gid=users,username=myself_on_server,password=my_server_passwd
    So try this as the line in fstab, perhaps leaving out the masks and charset for a while just to get it working at an elementary level, then try the masks, but see what this does first:
    Code:
    //IP-Adress/Mail /home/myself/Documents/Mail cifs uid=myself,gid=users,username=myself_on_server,password=my_server_passwd

    Here's a reference for a cifs mount: Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 10 & 11 plus FAQs
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  3. #3

    Default Re: kmail files on samba

    Thanks swerdna
    changed the comma (worked with comma in other smb-mounts, so not an obvious error)
    The interpretation of the user/pwd was as you presumed.
    The ownership changed as desired.
    dirs and files are now rwx for all

    This solved the problem partially, some of the mails are ok, others not and none of the mails in subdirs are OK.
    This I read about somewhere, have to search for the thread again.
    Also no index files are created in the Samba/Mail dir (or I don't find them if they are saved somewhere else...)

    so something I've to search... (or someone here knows the solution)

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: kmail files on samba

    If you chmod the directory on the server to a particular mask, it should automagically transfer across to the mount directory. That's a good way to set the mask.

    That's about where my help stops because I don't do Kmail. Hopefully some passer-by will help.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  5. #5

    Default Re: kmail files on samba

    Now an update to my configuration and some test results:
    The samba server I use is a WIN XP NTFS-HDD. The result were partially unreadable mails. My search suggested a filename incompatibility with SAMBA/FAT32, maybe also SAMBA or NTFS, so I tried a suse11.1 samba server.
    Samba (mounted in smbfstab) works fine, but my kmail refuses to start at all, I think it doesn't find the samba mount. Using a local dir works fine.
    access rights I have successfully set to 777 for all used samba directories.
    any ideas?

    How could I perhaps set kmail to a samba dir directly? (kmailrc general folder)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •