Results 1 to 3 of 3

Thread: How to install One-Click install package from terminal

  1. #1
    Join Date
    Oct 2008
    Posts
    27

    Question How to install One-Click install package from terminal

    Hello,

    I currently face the common Yast2 segfault due to an update of libqt for the current SVN version of KDE4.

    I saw that the solution to the problem is to downgrade yast2-qt-pkg to its original version. The problem I'm facing is that I can't seem to install One-Click-Install packages from a terminal.

    I would like to do that because I have not found any other way to install another version of a program with yast, which is why I use Webpin to locate and install the package.

    Previously, I could use the One-Click-Install program for this task but witht the latest update of libqt, even that module segfaults.

    While I'm at it, how can I ask Yast not to update a specific package? Should I taboo it?

    Any help is greatly appreciated,
    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,377
    Blog Entries
    1

    Default Re: How to install One-Click install package from terminal

    You can start a text mode (ncurses) version of yast from a shell if required.

    su (to become root user, enter root password when prompted)
    yast

    Its a bit more difficult to navigate (uses tab and arrow keys), but you will need to search for the 'yast2-qt-pkg' rpm, then you tab to 'View' menu --> 'Package Versions'. If other versions exist they will be listed. Click on the required package version, then 'Accept'.

    Alternatively, via zypper:

    zypper se yast2-qt-pkg --details

    For example, on my openSUSE 11.0 system, I get

    linux:/home/dean # zypper se --details yast2-qt-pkg
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    --+--------------+---------+-------------+--------+------------------
    i | yast2-qt-pkg | package | 2.16.48-0.2 | i586 | Updates for 11.0
    v | yast2-qt-pkg | package | 2.16.48-0.1 | i586 | Updates for 11.0
    v | yast2-qt-pkg | package | 2.16.47-0.2 | i586 | Updates for 11.0
    v | yast2-qt-pkg | package | 2.16.46-4.1 | i586 | openSUSE-11.0-Oss
    i | yast2-qt-pkg | patch | 63 | noarch | Updates for 11.0
    So I could downgrade to 2.16.48-0.1 with

    zypper in yast2-qt-pkg-2.16.48-0.1

    Hope this helps.

  3. #3
    Join Date
    Oct 2008
    Posts
    27

    Default Re: How to install One-Click install package from terminal

    Thank you for your help. I got to install another version of the package.

    I still have the same issue but it is not related to the topic which is why I'll post another one.

    Thanks again!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •