Results 1 to 3 of 3

Thread: phpMyAdmin issue

  1. #1
    saeeddeep NNTP User

    Exclamation phpMyAdmin issue

    Need help to get phpMyAdmin work on LAMP installed on OpenSuse 10.1 !!
    runnung: "rpm -q" command result:
    apache2-2.2.0-21.7
    php5-5.1.2-29.25.3
    MySQL5.0.18
    phpMyAdmin-2.9.1.1-2.3
    webmin-1.360-1
    My problem is when trying to connect to:
    "hxxp://www.m-y-d-o-m-a-i-n.com/phpMyAdmin"
    I reported Error 404:
    PHP Code:
    Object not found!
    The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.
    If 
    you think this is a server errorplease contact the webmaster.
    Error 404 
    Any suggestions ??

    this my help !!
    PHP Code:
    === cat /srv/www/htdocs/phpMyAdmin/config.inc.php ===
    <?php
    $cfg
    ['blowfish_secret'] = 'xxxxxxxx';
    $cfg['PmaAbsoluteUri'] = 'hxxp://m-y-d-o-m-a-i-n.net/phpMyAdmin/';
    $i 0;
    $i++;
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
    $cfg['Servers'][$i]['host'] = 'm-y-d-o-m-a-i-n.net';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['compress'] = false;
    $cfg['Servers'][$i]['extension'] = 'mysql';
    $cfg['Servers'][$i]['bs_garbage_threshold'] = 50;
    $cfg['Servers'][$i]['bs_repository_threshold'] = '32M';
    $cfg['Servers'][$i]['bs_temp_blob_timeout'] = 600;
    $cfg['Servers'][$i]['bs_temp_log_threshold'] = '32M';
    $cfg['Servers'][$i]['controluser'] = 'shagi';
    $cfg['Servers'][$i]['controlpass'] = 'shagipass';
    $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
    $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
    $cfg['Servers'][$i]['relation'] = 'pma_relation';
    $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
    $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
    $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
    $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
    $cfg['Servers'][$i]['history'] = 'pma_history';
    $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
    $cfg['Servers'][$i]['auth_swekey_config'] = '/etc/swekey-pma.conf';
    $cfg['UploadDir'] = '';
    $cfg['SaveDir'] = '';
    ?>

    === tail -f /var/log/apache2/error_log ===
    [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [warn] Init: (m-y-d-o-n-a-i-n.net:443) You configured HTTP(80) on the standard HTTPS(443) port!
    [warn] Init: SSL server IP/port conflict: virtual1.com:443 (/srv/www/vhosts/virtual1.com/conf/httpd.include:12) vs. virtual2.com:443 (/srv/www/vhosts/virtual2.com/conf/httpd.include:12)
    [warn] Init: SSL server IP/port conflict: m-y-d-o-m-a-i-n.net:443 (/etc/apache2/conf.d/zz010_psa_httpd.conf:122) vs. virtual2.com:443 (/srv/www/vhosts/virtual2.com/conf/httpd.include:12)
    [warn] Init: SSL server IP/port conflict: default-xxx-xx-xxx-xxx:443 (/etc/apache2/conf.d/zz010_psa_httpd.conf:70) vs. virtual2.com:443 (/srv/www/vhosts/virtual2.com/conf/httpd.include:12)
    [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
    [notice] mod_python: Creating 10 session mutexes based on 10 max processes and 0 max threads.
    [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [error] [client 40.0x.0xx.xx] File does not exist: /srv/www/vhosts/default/httpsdocs/user
    [error] [client 40.0x.0xx.xx] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)


    === cat /etc/apache2/httpd.conf ===
    Include /etc/apache2/uid.conf
    Include /etc/apache2/server-tuning.conf
    ErrorLog /var/log/apache2/error_log
    Include /etc/apache2/sysconfig.d/loadmodule.conf
    Include /etc/apache2/listen.conf
    Include /etc/apache2/mod_log_config.conf
    Include /etc/apache2/sysconfig.d/global.conf
    Include /etc/apache2/mod_status.conf
    Include /etc/apache2/mod_info.conf
    Include /etc/apache2/mod_usertrack.conf
    Include /etc/apache2/mod_autoindex-defaults.conf
    TypesConfig /etc/apache2/mime.types
    DefaultType text/plain
    Include /etc/apache2/mod_mime-defaults.conf
    Include /etc/apache2/errors.conf
    Include /etc/apache2/ssl-global.conf
    <Directory />
        Options None
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>
    <Directory "/srv/www/htdocs/phpMyAdmin">
            Options None
            AllowOverride None
            Order allow,deny
            Deny from all
    </Directory>
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
    </Files>
    DirectoryIndex at_domains_index.html index.html index.html.var index.shtml index.cfm index.php index.htm
    Include /etc/apache2/default-server.conf
    Include /etc/apache2/sysconfig.d/include.conf
    Include /etc/apache2/vhosts.d/*.conf
    AddOutputFilter INCLUDES .shtml
    AddType text/html .shtml
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
    AccessFileName .htaccess
    ServerName m-y-d-o-m-a-i-n.net

  2. #2

    Default Re: phpMyAdmin issue

    saeeddeep wrote:
    > LAMP installed on OpenSuse 10.1 !!


    http://en.opensuse.org/SUSE_Linux_Lifetime
    http://lists.opensuse.org/opensuse-s.../msg00004.html

    Kind regards,
    Andreas Stieger

  3. #3
    saeeddeep NNTP User

    Default Re: phpMyAdmin issue

    I'm sorry, Do you mean:
    build the whole things from scratch on openSUSE 11.1 ??
    should I try to solve this problem or you see it's noway to get it work...
    THANKS for help.

    regards,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •