Results 1 to 2 of 2

Thread: bug in ssh??

  1. #1
    Join Date
    Jul 2008
    Location
    Pottstown PA, US
    Posts
    150

    Question bug in ssh??

    Hi everyone
    would someone be able to try this...maybe its just my system?

    Im using public/private key authentication (RSA) for passwordless logins between my laptop (artemis) and desktop (zeus)...if I type:

    Code:
    ssh zeus sudo ls
    (you can replace "ls" with any command..")

    ssh connects to the desktop with no problems (via public key authentication)...then sudo prompts me for my password (as expected).

    low and behold, when i type my password for sudo, it appears as PLAIN TEXT on the screen. it does not replace the typed characters with "****", nor does it replace the characters with blanks as you type the password.

    any thoughts?
    Desktop| opensuse11.3| Core2Q Q9450 | nVidia GeForce 8800 GT
    Server| Arch | mythtv 024 | Core2D E7500| nVidia GT210
    HTPC| opensuse11.3 | mythtv 024| Atom 330 | ASUS AT3IONT-I Deluxe | nVidia ION
    Laptop| System76 | opensuse11.3| Core2D P8600 | nVidia 9300M

  2. #2
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: bug in ssh??

    On Wed, 2009-04-22 at 18:56 +0000, pimanac wrote:
    > Hi everyone
    > would someone be able to try this...maybe its just my system?
    >
    > Im using public/private key authentication (RSA) for passwordless
    > logins between my laptop (artemis) and desktop (zeus)...if I type:
    >
    >
    > Code:
    > --------------------
    >
    > ssh zeus sudo ls
    >
    > --------------------
    >
    >
    > (you can replace "ls" with any command..")
    >
    > ssh connects to the desktop with no problems (via public key
    > authentication)...then sudo prompts me for my password (as expected).
    >
    > low and behold, when i type my password for sudo, it appears as PLAIN
    > TEXT on the screen. it does not replace the typed characters with
    > "****", nor does it replace the characters with blanks as you type the
    > password.
    >
    > any thoughts?


    sudo interactively prompts for a password from a real terminal
    or pseudo terminal. Try using the -t option and see if that
    helps (-t forces it).




Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •