Results 1 to 4 of 4

Thread: XDMCP & gdm remote login Bug?

  1. #1
    ferbhome NNTP User

    Question XDMCP & gdm remote login Bug?

    Hi all,
    I am trying to figure out why I can't access my Desktop from a remote machine.

    My configuration:
    server runs openSUSE 11.1 with gnome Desktop (gdm)
    client runs openSUSE 11.0 with KDE Desktop (kdm)
    (both 64bit)

    What I did (on server):
    in /etc/X11/xdm/xdm-config I checked for
    !DisplayManager.requestPort: 0

    I enabled graphical remote login in yast!

    I stopped the firewall (on both machines)!

    Softwareversions (installed packges):
    (I also tried gdm 2.24 and libXdmcp 7.4-2 -> no effect)

    What works fine:
    I can access the X Desktop through xdmcp on my local machine typing: X -query localhost :1
    I can access another (kdm) Desktop from the client machine typing: X vt8 :1 -query ANOTHERHOST

    When I access my server:
    I type: X vt8 :1 -query server
    X starts and the grey screen appears with the X-Mouse-Cursor in the middle.
    Now the Mouse turns into a pointer and the background gets a new grey structure.
    From this point on it hangs. (Mouse and Keybaord are dead)

    Useful output could be:
    in /var/log/gdm/server:1-greeter.log:
    Fenstermanager-Warnung:Schwerwiegender E/A-Fehler 11 (Die Ressource ist zur Zeit nicht verfgbar) auf Anzeige ::ffff:
    gdm-simple-greeter: Fatal IO error 104 (Die Verbindung wurde vom Kommunikationspartner zurckgesetzt) on X server ::ffff:
    gnome-session: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfgbar) on X server ::ffff:
    in /var/log/messages:
    gdm-simple-slave[19098]: WARNING: Child process -19115 was already dead.
    gdm-simple-slave[19098]: WARNING: Unable to kill D-Bus daemon
    This is all I have. In /etc/gdm/custom.conf I set:
    # GDM configuration storage

    # SuSEconfig: displaymanager:DISPLAYMANAGER_REMOTE_ACCESS


    # SuSEconfig: displaymanager:~DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN

    But this did not help.

    Any ideas how to solve the problem? Is it a Bug?


  2. #2
    mmm_37 NNTP User

    Default Re: XDMCP & gdm remote login Bug?

    Since I'm having the exact same problem, I was wondering if any solution has been found in the meantime...

    BTW, Marvin, what was the graphics card driver you'd been using?


  3. #3
    ferbhome NNTP User

    Thumbs down Re: XDMCP & gdm remote login Bug?

    Hi again,

    I worked a lot an that problem in the last weeks. My conclusion is: It simply does not work. The xdmcp between gdm and kdm is not supported. Instead you can try a VNC connection.

    I was using an NVIDIA graphics driver of version 180.51

    If somebody has proofed the opposite please tell me


  4. #4
    mmm_37 NNTP User

    Default Re: XDMCP & gdm remote login Bug?

    However it's not only when the login omes from kdm - the nomachine nx server produces exactly the same sequence of errors when trying to connect to gdm ...


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts