Results 1 to 4 of 4

Thread: GNOME/Compiz missing Window Controls

  1. #1
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default GNOME/Compiz missing Window Controls

    I just (re)installed 11.1 (GNOME) on my Dell Latitude D531. I normally use KDE4, but the ATI card on this laptop throws fits with KWin effects, and my attempt at using Compiz/KDE4 were so-so. Anyways, after experimenting with Kubuntu (where I found the same issue), I decided that KDE isn't for this machine and reinstalled openSUSE with GNOME.

    Aside from that introduction, I have fglrx and Compiz working beautifully with GNOME, with one problem. The window titlebars don't have any visible control buttons (minimize, maximize, close). They are actually "there"; I can click on them with a bit of guessing, but they are invisible.

    I am going to try removing my .compiz and .gnome2 dirs to see if that helps. By the way, if this makes any difference, this is GNOME 2.26 (from the GNOME/Stable/2.26 repo).
    Dell Inspiron 530 - C2Q@2.4Ghz; 6GB RAM; openSUSE 11.2 x86_64; KDE 4.4.1
    Dell Inspiron 1440 - C2D@2.2Ghz; 4GB RAM; openSUSE 11.2 x86; KDE 4.4.1
    Dell Latitude D531 - AMD Turion X2 64@2.0Ghz; 2GB RAM; Linux Mint 8

  2. #2
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default Re: GNOME/Compiz missing Window Controls

    You know, what it actually looks like is a Compiz inactive window titlebar; the same nice vertical white to transparent gradient, and no window controls!

    Frustrating...
    Dell Inspiron 530 - C2Q@2.4Ghz; 6GB RAM; openSUSE 11.2 x86_64; KDE 4.4.1
    Dell Inspiron 1440 - C2D@2.2Ghz; 4GB RAM; openSUSE 11.2 x86; KDE 4.4.1
    Dell Latitude D531 - AMD Turion X2 64@2.0Ghz; 2GB RAM; Linux Mint 8

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: GNOME/Compiz missing Window Controls

    Hi,

    This would be a problem with Emerald. I get this sometimes when I change my window decoration theme or edit a theme in emerald. Usually a restart fixes it or changing the theme until the buttons come back.

    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4

    Default Re: GNOME/Compiz missing Window Controls

    I had this, and uninstalling everything compiz related (zypper remove compiz*) then reinstalling using the one click method fixed it for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •