Page 3 of 13 FirstFirst 12345 ... LastLast
Results 21 to 30 of 126

Thread: VirtualBox USB grey

  1. #21
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: VirtualBox USB grey

    consused wrote:

    >
    > upscope;1975693 Wrote:
    >> Not sure which version, it was the one that proceeded 2.1.4...

    > Thanks for all the info, although not quoted by me here.
    >
    > The previous version was 2.1.2, but you susbsequently said you upgraded
    > from 2.1.0 to 2.1.4 (my interpretation anyway). However, you didn't say
    > that you added the temporary directory as a repo to Yast, so I assume
    > you didn't.

    Yes I do have the temp directory added as a YaST repository and turn it on
    for install, then off. I may have skipped 2.1.2, since the original download
    is not in my backup file.
    >
    > That (i.e. 2.1.0) may explain the rather shorter 60-vboxdrv.rules in
    > your previous post, that would have been left over from your previous
    > install. That file is not deleted by 2.1.4 which was responsible for
    > placing 10-vboxdrv.rules in etc/udev/rules.d/ (also placed there on a
    > clean install).
    >
    > Unlike the OP, you upgraded from a previous usb-working system, and my
    > understanding is that after the upgrade, it only works if you manually
    > mount usbfs.

    Yes this is correct.
    > As you already have a working fstab entry, why not try this
    > first:
    >
    > 1. Remove *60-vboxdrv.rules* to your home directory (in case you need
    > to put it back). Place the command *mount -a* in the file
    > *etc/init.d/boot.local* and restart your system. Start VirtualBox and
    > test usb.
    >
    > If that doesn't work, try solution 2. or 3. below, and comment-out your
    > fstab mod and the -mount -a- to test these:
    >
    > With 11.1 and VirtualBox 2.1.4, fstab modification doesn't always work,
    > and 2.1.4 is supposed to work without it. There are now two solutions
    > authored by @hank_se, assuming just the file 10-vboxdrv.rules is present
    > as installed by VirtualBox. @hank_se prefers 3. I believe they work, but
    > need more testing to make sure they consistently deliver the same result
    > to the guest os.
    >
    > 2. Execute the command *mv 10-vboxdrv.rules 60-vboxdrv.rules* (as
    > root), then restart your system and test. This is effectively a rename
    > to reposition (priority wise) the rules file.
    >
    > *or*,
    >
    > 3. Edit *10-vboxdrv.rules* to add NAME="vbusb" as in the last line
    > Code:
    > --------------------
    > SUBSYSTEM=="usb", NAME="vbusb", ENV{DEVTYPE}=="usb_device",
    > GROUP="vboxusers", MODE="0664"
    > --------------------
    >
    >
    > I hope that helps you decide. As usual we would like you to post back
    > with the result.
    >
    >


    I will test that some time today hopefully and will post back, I assume the
    first solution leaves 10- where it is.

    Thanks for all your help!
    -----------------------------
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



  2. #22
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    Quote Originally Posted by upscope View Post
    ...Yes I do have the temp directory added as a YaST repository and turn it on for install, then off. I may have skipped 2.1.2, since the original download is not in my backup file.
    Even better, thanks for confirming.
    ... I assume the
    first solution leaves 10- where it is...
    It should, as you only remove the 60- file. If you do 2. you only rename the 10- to 60-, or if 3. you just edit the 10-

    Once usb works, get rid of the original -60 (in your home).

  3. #23

    Default Re: VirtualBox USB grey

    Execute the command *mv 10-vboxdrv.rules 60-vboxdrv.rules* (as
    > root), then restart your system and test. This is effectively a rename
    > to reposition (priority wise) the rules file.
    This works for me on a fresh install of Suse 11.1 /w KDE 4.2
    and a fresh install of VirtualBox 2.2.0 r45846

  4. #24
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    Pleased to hear that. Thanks for the feedback.

  5. #25
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: VirtualBox USB grey

    consused wrote:

    >
    > upscope;1976161 Wrote:
    >> ...Yes I do have the temp directory added as a YaST repository and turn
    >> it on for install, then off. I may have skipped 2.1.2, since the
    >> original download is not in my backup file.

    > Even better, thanks for confirming.
    >> ... I assume the
    >> first solution leaves 10- where it is...

    > It should, as you only remove the 60- file. If you do 2. you only
    > rename the 10- to 60-, or if 3. you just edit the 10-
    >
    > Once usb works, get rid of the original -60 (in your home).
    >
    >

    I tried step one but it did not appear to work. I moved 60- to my home
    directory, left 10 where it is, added mount -a* to boot.local. I do not need
    anything in addition to mount -a* as there were error messages during start
    up but I do not see them in the system log. Still usb devices are greyed out
    once XP starts and you go to the the menu bar devices-usb devices.

    Will try #2 later tonight. Am I correct That the # sign will comment out the
    usbfs entry in fstac and that I comment out the whole line? I removed the
    mount from boot.local so it will not be a problem.

    Also today I completed my install of my test openSUSE 11.1 system on a
    seperate hard drive. I tried installing the new 2.2 version of Vbox but it
    gets a compile error if I run vboxdrv setup. Will worry about that after I
    get my old version running. I downloaded the rpm from runs website and used
    YaST to install it from a temp directory on my system. There were no
    dependence messages or error message from YaST.

    Thanks again for your continuing help.
    --
    -----------------------------
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



  6. #26
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: VirtualBox USB grey

    consused wrote:

    >
    > Pleased to hear that. Thanks for the feedback.
    >
    >

    I tried #2 and it worked mostly.
    First I commented out the complete fstab entry for usbfs, remove mount -a*
    from boot.local, moved 10- to 60-vboxdrv.rules in /etc/udev/rules.d and
    rebooted.

    Then started Vbox. Setting showed three device filters, checked them and
    started The Guest XP System. I got the following error:

    Failed to create a proxy device for the USB device. (Error:
    VERR_FILE_NOT_FOUND).

    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: Console
    Interface: IConsole {e3c6d4a1-a935-47ca-b16d-f9e9c496e53e}

    CHESEN PS2 to USB Converter [0010] [this is the device that caused the
    above]

    Trying to start it under devices, hangs my Keyboard and Mouse Converts the
    PS devices to usb then they share one usb port.

    If I do not try to start it under devices, the mouse and keyboard seem to
    work. When It hangs its like guest additions has the problem. I can hit keys
    and XP moves around but if I move to Linux and start something that covers
    The vbox display, I cannot execute the Linux applications, takes a complete
    manual power off to free up. Did not happen when I manually start usbfs.
    My Linux is using KDE4.2.1 at this time.

    I'll see if I can find anything else.

    Thanks again.

    --
    -----------------------------
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



  7. #27
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    Quote Originally Posted by upscope View Post
    ...Also today I completed my install of my test openSUSE 11.1 system on a seperate hard drive. I tried installing the new 2.2 version of Vbox but it gets a compile error if I run vboxdrv setup. Will worry about that after I get my old version running. I downloaded the rpm from runs website and used YaST to install it from a temp directory on my system. There were no dependence messages or error message from YaST.
    Did you install kernel-source package so that virtualbox can compile a driver for the kernel? Also, you might read this wiki page, for a list of dependent packages go to the section "Installation from VirtualBox home page (OSE and non-OSE)". Make sure to install any missing packages.

    Re-run /etc/init.d/VirtualBox setup

    If that doesn't do it, re-install the VirtualBox rpm, and repeat the setup.

  8. #28
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    Quote Originally Posted by upscope View Post
    I tried #2 and it worked mostly.
    First I commented out the complete fstab entry for usbfs, remove mount -a*
    from boot.local, moved 10- to 60-vboxdrv.rules in /etc/udev/rules.d and
    rebooted.

    Then started Vbox. Setting showed three device filters, checked them and
    started The Guest XP System. I got the following error:

    Failed to create a proxy device for the USB device. (Error:
    VERR_FILE_NOT_FOUND).

    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: Console
    Interface: IConsole {e3c6d4a1-a935-47ca-b16d-f9e9c496e53e}

    CHESEN PS2 to USB Converter [0010] [this is the device that caused the
    above]

    Trying to start it under devices, hangs my Keyboard and Mouse Converts the
    PS devices to usb then they share one usb port.

    If I do not try to start it under devices, the mouse and keyboard seem to
    work. When It hangs its like guest additions has the problem. I can hit keys
    and XP moves around but if I move to Linux and start something that covers
    The vbox display, I cannot execute the Linux applications, takes a complete
    manual power off to free up. Did not happen when I manually start usbfs.
    My Linux is using KDE4.2.1 at this time.
    When you manually started usbfs, before you tried 1., what was the actual command used? It may be possible to put that manual command into /etc/init.d/boot.local in place of the mount -a command. Remember to reboot the system. After all, you had a working system that you just needed to automate. Worth a try, but beforehand, you should reset the -60 file name back to -10, by swapping the filenames over in the original mv command and executing it.

    As you are doing several tests, it's best to delete any hidden vbox directory/files in /tmp before each test.

    Remember the original OP of this thread had a problem with one of his devices that locked up k/b and mouse. We reduced the complexity for testing by using one simple device - see the early part of the thread. We don't know how he got on with the other devices (yet).

    Sorry, I can't help with the specifics of your failing device as I don't have it. We don't know that these solutions work for all devices.

  9. #29
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    When you manually started usbfs, before you tried 1., what was the actual command used? It may be possible to put that manual command into /etc/init.d/boot.local in place of the mount -a command. Remember to reboot the system. After all, you had a working system that you just needed to automate. Worth a try, but beforehand, you should reset the -60 file name back to -10, by swapping the filenames over in the original mv command and executing it.
    @upscope Sorry, in my last post, I forgot to mention: Edit /etc/fstab to uncomment your original usbfs statement.

  10. #30
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: VirtualBox USB grey

    consused wrote:


    > upscope;1976425 Wrote:

    <snip>
    > When you manually started usbfs, before you tried 1., what was the
    > actual command used?

    manual command I used as root was: mount usbfs No options.
    > It may be possible to put that manual command into
    > /etc/init.d/boot.local in place of the mount -a command. Remember to
    > reboot the system. After all, you had a working system that you just
    > needed to automate. Worth a try, but beforehand, you should reset the
    > -60 file name back to -10, by swapping the filenames over in the
    > original mv command and executing it.

    Will try this later today and post results.
    >
    > As you are doing several tests, it's best to delete any hidden vbox
    > directory/files in */tmp* before each test.

    Will do this also to be safe. My config is sda 320Gb drive with test
    environment and sdb 320 GB drive with production environment. sdb is one
    having problem that we have been working, sda has problem with above
    mentioned device, even thought keyboard and mouse work fine if I ignore
    error message.

    Will post results tonight. All so when I work on test system problem if I
    need help I'll open new thread but I do not think it is Vbox issue at this
    time.

    Thanks.

    --
    -----------------------------
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)



Page 3 of 13 FirstFirst 12345 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •