Page 2 of 13 FirstFirst 123412 ... LastLast
Results 11 to 20 of 126

Thread: VirtualBox USB grey

  1. #11
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    Thanks for the info. One of the usb devices (or more) may be causing the crash. To reduce complexity for testing (as root for now), I suggest you use just one device only in the vm, i.e. memory stick (mine works well) i.e. the uncomplicated one that you know works all the time on the host. Can you unplug the other devices? Delete the usb filters in virtualbox settings - they are easy to add again later.

    My device works this way: exit virtualbox; plug in the device it should mount on the host; start virtualbox, but not the guest; go to usb settings and click on the little + button once (Add Filter fom Device), but don't click the small white box yet in the popup, just hover the mouse over small white box and it will display the State of the device as "Busy" (if State=Unavailable, don't bother starting the vm - it will not work); click on the small box to add the filter; start the vm and check it mounts ok.

    Tell us what happened...

  2. #12
    Join Date
    Apr 2009
    Location
    Germany, Erfurt
    Posts
    7

    Default Re: VirtualBox USB grey

    Okay, I've selected only my usb stick.
    It works, and it runs.
    But only out of the terminal with: su -> VirtualBox
    How can I use now with the normal user the usb feature?

  3. #13
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    That's good. Now we know more about the problem as others reported. We could try modifying fstab with various alternative statements, but it's hit & miss, and time consuming, as they were for different versions of openSUSE. VirtualBox with usb is supposed to just work with release 2.1.4 onwards. Your situation coming from clean install matches what is ongoing in the last stages of this long thread I am involved in. The last proposed solution is being tested. You can go for that or try this one in the meantime, after closing down VirtualBox:

    Look in the directory /etc/udev/rules.d/ for the file 10-vboxdrv.rules

    If it's the only file of type xx-vboxdrv.rules, then execute the following command from Konsole (as root) in /etc/udev/rules.d/
    Code:
    mv 10-vboxdrv.rules 60-vboxdrv.rules
    Then reboot and test again but as normal user and just the memory stick.

    Post back with result or question...

  4. #14
    Join Date
    Apr 2009
    Location
    Germany, Erfurt
    Posts
    7

    Default Re: VirtualBox USB grey

    It works gerat.
    The speed from usb to virtualOS is realy slow.
    But it works, maybe I set up an ftp oder other server to speed up that.

    Thankyou for solving my problem

  5. #15
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    You're welcome, and I hope you manage to sort out the rest of your devices. If you succeed or not, perhaps you could post back here with the results as it could help others following this thread.

    If you chose to do the file name change, at some time you could change the name back and try modifying the rules file as detailed toward the end of that thread link in my previous post. The author of the fix, hank_se, is claiming that it would be better.

    Finally,
    Quote Originally Posted by neonlex View Post
    ...The speed from usb to virtualOS is realy slow.
    Have a read of this thread, it may give a clue but I haven't had time to read it properly, so sorry if it doesn't.

    Best of luck.

  6. #16
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: VirtualBox USB grey

    consused wrote:

    >

    <snip> That's good. Now we know more about the problem as others
    reported. We > could try modifying fstab with various alternative
    statements, but it's> hit & miss, and time consuming, as they were for
    different versions of
    </snip>
    <snip>

    > Code:
    > --------------------
    > mv 10-vboxdrv.rules 60-vboxdrv.rules
    > --------------------
    >
    > Then *reboot* and test again but as normal user and just the memory
    > stick.
    >
    > Post back with result or question...
    >

    </snip>

    OpenSUSE11.1, Vbox 2.1.4 from Sun website.

    I have a simular problem. My usb devices show up under settings, but are
    greyed out when I start vbox. everything works fine if I manually mount
    usbfs before starting vbox. I read the posts and forum on the rules files
    but I'm a little confused as to the correct rule. I have both a 10- and 60-
    entry in /etc/udev/rules.d. Should I just move the 10- rule to 60-??

    /etc/udev/rules.d> less 10-vboxdrv.rules

    KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root",
    MODE="0600"
    SUBSYSTEM=="usb_device", GROUP="vboxusers", MODE="0664"
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device",
    GROUP="vboxusers", MODE="0664"

    /etc/udev/rules.d> less 60-vboxdrv.rules
    KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root",
    MODE="0600"

    Thanks for any help.
    --
    -----------------------------
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc
    (2)



  7. #17
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    @upscope
    Your situation is a little different from the others I have seen, so I would like to clarify some points before answering your question.

    The fact you have those 2 files, including 60-vboxdrv.rules, indicates you had a previous version of VirtualBox installed before 2.1.4, so what version was that? How did you make the change, clean install or upgrade using Yast local repo? Did you add any usbfs lines to your fstab?

    Thanks...

  8. #18
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: VirtualBox USB grey

    consused wrote:

    >
    > @upscope
    > Your situation is a little different from the others I have seen, so I
    > would like to clarify some points before answering your question.
    >
    > The fact you have those 2 files, including 60-vboxdrv.rules, indicates
    > you had a previous version of VirtualBox installed before 2.1.4, so what
    > version was that? How did you make the change, clean install or upgrade
    > using Yast local repo? Did you add any usbfs lines to your fstab?


    Not sure which version, it was the one that proceeded 2.1.4. All were
    openSUSE RPMS downloaded from the SUN website.

    Present version:
    VirtualBox-2.1.4_42893_openSUSE111-1.x86_64.rpm

    Last version:
    VirtualBox-2.1.0_41146_openSUSE111-1.x86_64.rpm

    All were downloaded from to a temporary directory and then installed with
    YaST software management. So I guess you would say I upgraded.

    Yes there was a mod mad to FSTAB. It was actually made when I first
    started using Vbox per and item on a forum. Otherwise USB would not work.

    usbfs /proc/bus/usb usbfs
    auto,busgid=1000,busmode=0775,devgid=1000,devmode=0664

    If you need any other information please feel free to send email direct to:
    Russbucket@nwi.net or thru the mail list.
    -----------------------------
    Russ
    openSUSE 11.1 (2.6.27.21-0.1-default [x86_64) KDE 4.2.1 release 106, Intel
    DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc
    (2)



  9. #19
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VirtualBox USB grey

    @upscope
    You should not post your email address in the forum.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #20
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VirtualBox USB grey

    Quote Originally Posted by upscope View Post
    Not sure which version, it was the one that proceeded 2.1.4...
    Thanks for all the info, although not quoted by me here.

    The previous version was 2.1.2, but you susbsequently said you upgraded from 2.1.0 to 2.1.4 (my interpretation anyway). However, you didn't say that you added the temporary directory as a repo to Yast, so I assume you didn't.

    That (i.e. 2.1.0) may explain the rather shorter 60-vboxdrv.rules in your previous post, that would have been left over from your previous install. That file is not deleted by 2.1.4 which was responsible for placing 10-vboxdrv.rules in etc/udev/rules.d/ (also placed there on a clean install).

    Unlike the OP, you upgraded from a previous usb-working system, and my understanding is that after the upgrade, it only works if you manually mount usbfs. As you already have a working fstab entry, why not try this first:

    1. Remove 60-vboxdrv.rules to your home directory (in case you need to put it back). Place the command mount -a in the file etc/init.d/boot.local and restart your system. Start VirtualBox and test usb.

    If that doesn't work, try solution 2. or 3. below, and comment-out your fstab mod and the mount -a to test these:

    With 11.1 and VirtualBox 2.1.4, fstab modification doesn't always work, and 2.1.4 is supposed to work without it. There are now two solutions authored by @hank_se, assuming just the file 10-vboxdrv.rules is present as installed by VirtualBox. @hank_se prefers 3. I believe they work, but need more testing to make sure they consistently deliver the same result to the guest os.

    2. Execute the command mv 10-vboxdrv.rules 60-vboxdrv.rules (as root), then restart your system and test. This is effectively a rename to reposition (priority wise) the rules file.

    or,

    3. Edit 10-vboxdrv.rules to add NAME="vbusb" as in the last line
    Code:
    SUBSYSTEM=="usb", NAME="vbusb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE="0664"
    then restart your system and test.

    I hope that helps you decide. As usual we would like you to post back with the result.

Page 2 of 13 FirstFirst 123412 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •