Results 1 to 5 of 5

Thread: vmware error after reboot

  1. #1
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default vmware error after reboot

    hi
    i installe dvmware VMware-Workstation-6.5.1-126130.x86_64[1] bundle after disabling kvm and the removed the modlues binery folder as said in this forum tutorial and it wnet fine

    but next time i rebooted and run vmware it loads fine but when powering up a guest os it says "unable to find vmmont module" or something like this

    for solving this i have to uninstall and install vmware again.but after next reboot it gives the same error again.

    any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default Re: vmware error after reboot

    the exact error is

    Could not open /dev/vmmon: No such file or directory. Please make sure that the kernel module `vmmon' is loaded

    i have to run as root this command to fix it every time

    vmware-modconfig --console --install-all

    but why?
    it there a way to fix this?\

  3. #3
    suruma NNTP User

    Default Re: vmware error after reboot

    I'm having the same problem. Really would like to know what's wrong maybe something in /etc/init.rd(./vmware status); maybe i need to add vmware services to init.rd. Anyway using this script for now instead of re-installing:
    Code:
    #!/bin/bash
    modprobe vmmon
    modprobe vmnet
    modprobe vmblock
    modprobe vmci
    modprobe vsock
    modprobe vsock
    vmware-networks --start

  4. #4
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default Re: vmware error after reboot

    Quote Originally Posted by rd1381 View Post
    the exact error is

    Could not open /dev/vmmon: No such file or directory. Please make sure that the kernel module `vmmon' is loaded

    i have to run as root this command to fix it every time

    vmware-modconfig --console --install-all

    but why?
    it there a way to fix this?\
    it seems it got fixed
    i think executing "vmware-modconfig --console --install-all" as root , after successfully running a vm, fixed it

  5. #5

    Lightbulb Re: vmware error after reboot

    To solve the problem... do the following.

    Close down VMWare host´s, and shut down VMWare.

    Change in the file: /etc/rc.local

    Command: sudo nano /etc/rc.local

    Add line /etc/init.d/vmware start &

    Save with Ctrl + O

    Sudo reboot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •