Results 1 to 3 of 3

Thread: How do I change libmysqlclient ?

  1. #1

    Default How do I change libmysqlclient ?

    I have some how ended up with the wrong libraries in the mysql path and it is causing all kinds of problems. How can I remove libmysqlclient.so.15 and libmysqlclient.so.15.0.0 and replace them with the proper libraries ?

    Here is what is installed now.

    /usr/lib64/libmysqlclient.so.15
    /usr/lib64/libmysqlclient.so.15.0.0
    /usr/lib64/libmysqlclient.so.16
    /usr/lib64/libmysqlclient.so.16.0.0
    /usr/lib64/libmysqlclient_r.so.16
    /usr/lib64/libmysqlclient_r.so.16.0.0

    /usr/lib64/mysql/libmysqlclient.so.15
    /usr/lib64/mysql/libmysqlclient.so.15.0.0

    which should be

    /usr/lib64/mysql/libmysqlclient.so.16
    /usr/lib64/mysql/libmysqlclient.so.16.0.0

    I'm pretty sure that will fix my problems.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,433

    Default Re: How do I change libmysqlclient ?

    How about opening a console and entering:
    su --
    mv /usr/lib64/libmysqlclient.so.16* /usr/lib64/mysql/
    exit

  3. #3

    Default Re: How do I change libmysqlclient ?

    Thanx for the reply. However, that didn't fix the problem. I had better go into more detail.

    After I did an Mysql and PHP update using Yast I got a message on the website I am developing. It is multifaceted ( gallery, store, and a section where users can select preferences that I am building from scratch. )

    I got: Database Error: Unable to connect to the database:Could not connect to MySQL. or Unable to connect to database server!

    phpMyAdmin gave me error #2002.

    I checked Yast -> System -> System Services and it showed that the server was running, but there was an asterisk (*) next to YES* indicating a problem. When I tried to refresh it I got /etc/init.d/mysql status returned 100 (unspecified error): and then system services indicated NO the server is not running.

    Then I tried Mysql Administrator and Query Browser and, surprise, surprise everything works fine. So obviously the server is running.

    Someone on line had fixed the problem by changing 'localhost' to 127.0.0.1. so I changed the config file in phpMyAdmin and it connected. However, at the bottom of the splash page it says:
    "Your PHP MySQL library version 5.0.45 differs from your MySQL server version 5.1.33. This may cause unpredictable behavior."

    So with the help of the above post ( I can never remember command line stuff. ) I put version 5.1.33. into /usr/lib64/mysql and removed the 5.0.45 versions. Did a restart and...

    Nothing has changed and I still get "Your PHP MySQL library version 5.0.45 differs from your MySQL server version 5.1.33. This may cause unpredictable behavior."

    I would delete the 5.0.45 versions all together, but I get a bunch of dependency issues according to Yast. I have also re-updated all things PHP and Mysql, but nothing helped.

    So am I manipulating the wrong files? Does anybody have an idea about what is doing on?

    BTW I am using Suse 10.3 if that has any relevance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •