Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: I uninstalled YaST and i want to reinstall it

  1. #1

    Default I uninstalled YaST and i want to reinstall it

    Hi... i have opensuse 11.0.
    During an update YaST told me that there was a conflict between the patch downloaded and some packages installed.
    I could choose not to install the new patch (that was related to softwaremgmt) or uninstall some packages.
    I chose to uninstall some packages...and now, after reboot, YaST isn't in my system.
    by typing "yast2" with superuser, it tells me "command not found".

    I want to reinstall YaST, from the DVD or from the web, what can i do?



    Thank you all

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: I uninstalled YaST and i want to reinstall it

    zypper in -t pattern yast2_basis sw_management

  3. #3
    Join Date
    Mar 2009
    Location
    Bangalore, India
    Posts
    44

    Default Re: I uninstalled YaST and i want to reinstall it

    a similar thing happened to me too. yast2 was uninstalled.
    but yast was still there
    that is, the one which i can run from a terminal not the full fledged gui.
    try using that
    --
    vijay
    Time Zone : GMT + 05:30

  4. #4

    Default Re: I uninstalled YaST and i want to reinstall it

    Code:
    Linux9000:/home/stefano # zypper
    bash: zypper: command not found
    i think that zypper has been uninstalled too...

    Code:
    Linux9000:/home/stefano # yast
    bash: yast: command not found

  5. #5
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: I uninstalled YaST and i want to reinstall it

    Well that makes it all a little trickier, you could theoretically install it via rpm, I doubt *that* has been uninstalled :-)

    You could install via the net with the rpm like this:
    You'll most likely need to grab some dependencies to go along with it (such as libzypp, satsolver-tools etc.) of course if you have the installation media, you could insert it, then mount it and go to the suse/i586 folder and manually install the files from there. It might be a little tricky. You could also use the installation media and repair function to restore the tools.

    edit:
    Stupid retard forum software automatically urlifies the link. Brr..

  6. #6

    Default Re: I uninstalled YaST and i want to reinstall it

    Code:
    Linux9000:/home/stefano # rpm -i http://download.opensuse.org/distribution/11.1/repo/oss/suse/i586/zypper-1.0.2-1.5.i586.rpm
    error: Failed dependencies:
    	libzypp.so.523 is needed by zypper-1.0.2-1.5.i586

  7. #7
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: I uninstalled YaST and i want to reinstall it

    Yes as I said you'll need to pick the dependencies, such as libzypp satsolver etc. and add them to that rpm line - you need to look up the filenames.

    So the line is rpm -i <url> <url> <url>

    For example:

    Code:
    rpm -i http://download.opensuse.org/distribution/11.1/repo/oss/suse/i586/zypper-1.0.2-1.5.i586.rpm http://download.opensuse.org/distribution/11.1/repo/oss/suse/i586/libzypp-5.24.5-1.1.i586.rpm http://download.opensuse.org/distribution/11.1/repo/oss/suse/i586/satsolver-tools-0.13.0-3.3.i586.rpm
    And possibly others.

  8. #8

    Default Re: I uninstalled YaST and i want to reinstall it

    Thank you for the hints...
    I found this http://linux.derkeiler.com/pdf/Maili...2/msg00815.pdf
    it says that i only need zypper and then i will install yast with it.

    But now i have a strange issue.

    Code:
    Linux9000:/home/stefano # rpm -i libzypp-4.28.1-0.1.i586.rpm
    error: Failed dependencies:
    	satsolver-tools = 0.9.6 is needed by libzypp-4.28.1-0.1.i586
    Linux9000:/home/stefano # rpm -i satsolver*.*
    warning: satsolver-tools-0.9.6-1.1.i586.rpm: Header V3 DSA signature: NOKEY, key ID 7fb7f464
    	package satsolver-tools-0.13.2-0.1.1 (which is newer than satsolver-tools-0.9.6-1.1) is already installed
    	file /usr/bin/deltainfoxml2solv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/dumpsolv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/mergesolv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/patchxml2solv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/repo2solv.sh from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/rpmdb2solv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/rpmmd2solv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/rpms2solv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/susetags2solv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    	file /usr/bin/updateinfoxml2solv from install of satsolver-tools-0.9.6-1.1 conflicts with file from package satsolver-tools-0.13.2-0.1.1
    It say that i need satsolver v9, but i have v13....
    what should i do?

  9. #9
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: I uninstalled YaST and i want to reinstall it

    In a way that's ok, you have the updated satsolver, you might want to try this:

    Code:
    rpm -i http://download.opensuse.org/update/11.1/rpm/i586/libzypp-5.25.3-0.1.2.i586.rpm http://download.opensuse.org/update/11.1/rpm/i586/zypper-1.0.5-2.1.2.i586.rpm

  10. #10

    Default Re: I uninstalled YaST and i want to reinstall it

    Ok, thank you...i understood the mechanism...
    but i can't solve problem like this:
    error reading from file /var/tmp/rpm-xfer.IqEIrb

    here is what i've done:

    Code:
    Linux9000:/home/stefano # rpm -i http://download.opensuse.org/update/11.1/rpm/i586/libzypp-5.25.3-0.1.2.i586.rpm http://download.opensuse.org/update/11.1/rpm/i586/zypper-1.0.5-2.1.2.i586.rpm
    error: Failed dependencies:
    	libboost_signals.so.1.36.0 is needed by libzypp-5.25.3-0.1.2.i586
    Linux9000:/home/stefano # rpm -i http://download.opensuse.org/update/11.1/rpm/i586/libzypp-5.25.3-0.1.2.i586.rpm http://download.opensuse.org/update/11.1/rpm/i586/zypper-1.0.5-2.1.2.i586.rpm ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/mithro:/backports:/rpm/openSUSE_11.0/i586/libboost_signals1_36_0-1.36.0-8.1.i586.rpm
    warning: /var/tmp/rpm-xfer.ihq01e: Header V3 DSA signature: NOKEY, key ID 788c6492
    error: Failed dependencies:
    	boost-license = 1.36.0 is needed by libboost_signals1_36_0-1.36.0-8.1.i586
    Linux9000:/home/stefano # rpm -i http://download.opensuse.org/update/11.1/rpm/i586/libzypp-5.25.3-0.1.2.i586.rpm http://download.opensuse.org/update/11.1/rpm/i586/zypper-1.0.5-2.1.2.i586.rpm ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/mithro:/backports:/rpm/openSUSE_11.0/i586/libboost_signals1_36_0-1.36.0-8.1.i586.rpm ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/mithro:/backports:/rpm/openSUSE_11.0/i586/libboost_signals1_36_0-1.36.0-8.1.i586.rpm
    warning: /var/tmp/rpm-xfer.EDhQQb: Header V3 DSA signature: NOKEY, key ID 788c6492
    error: error reading from file /var/tmp/rpm-xfer.rrPAjR
    Linux9000:/home/stefano # man rpm
    Linux9000:/home/stefano # rpm -i --nosignature http://download.opensuse.org/update/11.1/rpm/i586/libzypp-5.25.3-0.1.2.i586.rpm http://download.opensuse.org/update/11.1/rpm/i586/zypper-1.0.5-2.1.2.i586.rpm ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/mithro:/backports:/rpm/openSUSE_11.0/i586/libboost_signals1_36_0-1.36.0-8.1.i586.rpm ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/mithro:/backports:/rpm/openSUSE_11.0/i586/libboost_signals1_36_0-1.36.0-8.1.i586.rpm
    error: error reading from file /var/tmp/rpm-xfer.IqEIrb

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •