Results 1 to 9 of 9

Thread: XOrg High CPU Usage With Screensaver

  1. #1

    Unhappy XOrg High CPU Usage With Screensaver

    Hello There,

    I am running openSuSE 11.1 with KDE4.2, I have updated all my packages to the latest stable version. About a month ago I used to have a problem with XOrg consuming high CPU after a few minutes of running, but that was fixed with one of the updates.

    My problem now is that whenever my monitor is locked or the screensaver runs, the CPU load of XOrg shoots up to about 60%, this drops as soon as i unlock the machine. This is not a problem specific to the screensaver itself, because i changed that screensaver to just a blank screen and i still get that problem.

    Any help is greatly appreciated.

    Thanks,

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,843

    Default Re: XOrg High CPU Usage With Screensaver

    It may be related to your video card/driver, to powerdevil (if you're using it) or other issues.

    If you search this forum for "XOrg High CPU" you'll find some tips that may help, like High X server CPU utilization in 11.1 when X session idle - openSUSE Forums or CPU hungry Xorg process in KDE4 - openSUSE Forums or even XOrg CPU - openSUSE Forums, among others.

  3. #3

    Default Re: XOrg High CPU Usage With Screensaver

    Thanks brunomcl for your reply,

    I have in fact searched for this problem on this forum before and encountered the threads you referred me too. However, i believe the problem of XOrg cpu utilization shooting up after some time of operation due to powerdevil has been fixed by an update that is available from the KDE4 factory repo and i installed that.

    My problem now is that only when the screen saver starts does the CPU utilization of Xorg and Kwin jump to 50% each, and I am wondering if anybody else has encountered that ? or if any one would happen to know of a solution ?

    I do not have powerdevil installed on my machine at the moment, and the problem is not specific to a particular screen saver. Also, the cpu utilization problem seems to go away as soon as kpowersave kicks in and puts the monitor on standby for energy savings.

    If it is any help, i have an ATI Radeon x1300 graphics card with the fglrx driver installed as provided from the ATI repo.

    Any ideas ?

    Thanks again for your help

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,843

    Default Re: XOrg High CPU Usage With Screensaver

    Do you have the same problem if you choose 'blank screen' (or clear screen) for the screensaver? Also, in KDE 3.5 Screensaver settings > Advanced you can also change it's priority (mine is set to 'low'). check if there's something similar is 4.2.

    Also you may try to update the ATI driver (maybe first check the 'changelist' to see this problem was noticed/fixed).

    That's all I can think of right now.

  5. #5

    Default Re: XOrg High CPU Usage With Screensaver

    Thanks brunomcl,

    The 'Blank Screen' screensaver also gives me the same problem. The screensaver priority is set to low, and there are no pending updates for the ATI driver.

    It seems this problem only persists for 10 minutes until the power manager just turns off the screen (puts it in standby).

    hmm .. weird.

    Thanks again.

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,843

    Default Re: XOrg High CPU Usage With Screensaver

    Yes, weird. Usually these things go away (or appear) after an update, either of xorg or the video driver - I'd vote for the last one.

    The obvious workaround is to set your pm utility to turn off the screen sooner (1 minute, perhaps). Not much pretty screen savers, though.

  7. #7

    Default Re: XOrg High CPU Usage With Screensaver

    I have same problem too.
    when pc is idle ,screen saver actived ,opensuse 11.1 cost 50% of my cpu .
    but i do not know which program consume my cpu ,because when i stop the screen saver by moving mouse or hit keyboard,the cpu usage derease to normal .
    i set screensaver to blank background,problem still occur

  8. #8

    Default Re: XOrg High CPU Usage With Screensaver

    Thanks brunomcl.

    wangcgfan, the way i was able to find which process consumes my CPU is by letting it go into screensaver and the "ssh"ing into my machine from another one and doing a 'top' from there.

    If you can not access your machine from another one, you can try to achieve the same thing by starting a terminal, running 'top', and then locking your screen and unlocking it .. usually the 'top' output takes a second or two to update, this could give you a hint to what is going on, but it is probably not accurate/not helpful. I'd recommend sshing into your machine when it is locked to find out.

  9. #9
    donderdwolk NNTP User

    Default Re: XOrg High CPU Usage With Screensaver

    I also have the same problem with 11.1 and Gnome. Blank screen also gives high cpu load. I will try to ssh to my machine when it goes idle and see what is causing this.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •