Results 1 to 8 of 8

Thread: H.264 Codec & Mplayer

  1. #1
    bull205 NNTP User

    Default H.264 Codec & Mplayer

    Greetings,

    This is my first post as a new user of suse. I played with Ubuntu for a while and now I am over here and loving it. Things are a little different...I am still a newbie though and need some help.

    I can't get the apple trailers to play in the firefox browser. When I click on it, it says missing codecs. One of which is the H.264. All I can find in the packman repo is the X264. Are they the same?

    Also, mplayer doesn't recognize the previews either. I've read somewhere that I have to download the codecs then recompile Mplayer. Ummmm, how do I go about that?

    Thanks
    Bull

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: H.264 Codec & Mplayer

    Add packman to your repo's list & update allyour multimedia & codecs. Should sort it. or you could use the 1-click install here
    Restricted Formats/11.0 - openSUSE-Community for 11.0
    Restricted Formats/11.1 - openSUSE-Community for 11.1

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3
    bull205 NNTP User

    Default Re: H.264 Codec & Mplayer

    My bad, I forgot to mention I already have the packman repo installed and updated. I just updated it this morning.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,566
    Blog Entries
    38

    Default Re: H.264 Codec & Mplayer

    Quote Originally Posted by bull205 View Post
    I can't get the apple trailers to play in the firefox browser.
    Apple trailers can be a pia to get working. Even with the codecs, the web site is setup such that the videos do not always work under Linux. Currently I get less than user friendly playback from their trailers, and it is constantly very time consuming on my time to figure out a way to hack into an Apple site trailer that I want to see from Linux.

  5. #5
    bull205 NNTP User

    Default Re: H.264 Codec & Mplayer

    Good to know, everything else seems to work great, so I was [ahem] befuddled when apple's gave me a no-go. Probably not worth the effort then, huh? So where's a guy to get his movie trailer fix...not something I take lightly? (probably off topic)

  6. #6

    Default Re: H.264 Codec & Mplayer

    Mmm strange diff distro at the moment but I'm getting the same problem.

    Curious will it play the url off the cli/plain mplayer. I'm getting a lot of errors and I'm using mplayer-svn.

    Code:
    FAAD: Failed to decode frame: Maximum number of scalefactor bands exceeded 
    FAAD: Failed to decode frame: Channel coupling not yet implemented 
    FAAD: Failed to decode frame: Gain control not yet implemented 
    FAAD: Failed to decode frame: First SBR frame is not the same as first AAC frame
    But stranger still is I use the gxine plugin, which doesn't auto play but will play of the cli.

    Do you get similar?
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  7. #7
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: H.264 Codec & Mplayer

    I have no such problems with mplayerplug-in and apple trailers

  8. #8

    Default Re: H.264 Codec & Mplayer

    You got any ideas how to track it microchip? I'm guessing it is something related to both as I'm struggling with both players, (Could this be h264-svn I suspect you're using it(Does mplayer))
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •