Results 1 to 7 of 7

Thread: Trouble when updating or installing software rpm

  1. #1

    Question Trouble when updating or installing software rpm

    Hello,

    When I update or install a rpm in yast2 I always get the same
    messages: 'package requires rpmlib(CompressedFileNames) <= 3.0.4-1
    but can't provide this dependancy' or 'package requires librpm-4.4.so but can't provide this dependancy'
    I can't find rpmlib(CompressedFileNames) and I don't understand the second one librpm-4.4.so because It's installed already with rpm-4.4.2.3-20.1

    I don't have any clue about this.

  2. #2
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    301

    Default Re: Trouble when updating or installing software rpm

    Hi,

    it looks like you are trying to install packages compiled for a different suse version but it's just a guess. Maybe you should tell which suse version you are using, which package you want to install and the output of zypper lr -d.

  3. #3

    Default Re: Trouble when updating or installing software rpm

    I am using openSUSE 11.1 but it seems to be the same for any packages.

    here is the log of zypper:

    # | Alias | Nom | Activ | Rafrachir | Priorit | Type | URI | Service
    ---+----------------+-----------------------+--------+------------+----------+----------+----------------------------------------------------------------------------------------------+--------
    1 | Banshee | Banshee | Oui | Oui | 99 | rpm-md | Index of /repositories/Banshee/openSUSE_11.1 |
    2 | Emulators | Emulators | Oui | Oui | 99 | rpm-md | Index of /repositories/Emulators/openSUSE_11.1 |
    3 | Emulators-Wine | Emulators-Wine | Oui | Oui | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.1 |
    4 | Mono | Mono | Oui | Oui | 99 | rpm-md | Index of /repositories/Mono/openSUSE_11.1 |
    5 | OpenOffice | OpenOffice | Oui | Oui | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |
    6 | anubisg1 | anubisg1 | Oui | Oui | 99 | rpm-md | Index of /repositories/home:/anubisg1/openSUSE_11.1 |
    7 | google | google | Oui | Oui | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
    8 | mozilla | mozilla | Oui | Oui | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    9 | my-repository | my-repository | Oui | Oui | 99 | plaindir | hd:///home/Arminius/my_inst_src?device=/dev/disk/by-id/edd-int13_dev80-part3&filesystem=auto |
    10 | packman-gwdg | packman-gwdg | Oui | Oui | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/11.1 |
    11 | repo-debug | openSUSE-11.1-Debug | Oui | Oui | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
    12 | repo-non-oss | openSUSE-11.1-Non-Oss | Oui | Oui | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    13 | repo-oss | openSUSE-11.1-Oss | Oui | Non | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    14 | repo-source | openSUSE-11.1-Source | Oui | Oui | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
    15 | repo-update | openSUSE-11.1-Update | Oui | Non | 100 | rpm-md | Index of /update/11.1 |
    16 | suser-jengelh | suser-jengelh | Oui | Oui | 99 | rpm-md | Index of /pub/linux/misc/suser-jengelh/SUSE-11.1 |
    17 | third-party | third-party | Oui | Oui | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.1 |
    18 | videolan | videolan | Oui | Oui | 99 | rpm-md | Index of /pub/vlc/SuSE/11.1/

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,529
    Blog Entries
    37

    Default Re: Trouble when updating or installing software rpm

    Quote Originally Posted by 5uzeUser8 View Post
    I am using openSUSE 11.1 but it seems to be the same for any packages.

    here is the log of zypper:
    # | Alias | Nom | Activ | Rafrachir | Priorit | Type | URI | Service
    ---+----------------+-----------------------+--------+------------+----------+----------+----------------------------------------------------------------------------------------------+--------
    1 | Banshee | Banshee | Oui | Oui | 99 | rpm-md | Index of /repositories/Banshee/openSUSE_11.1 |
    2 | Emulators | Emulators | Oui | Oui | 99 | rpm-md | Index of /repositories/Emulators/openSUSE_11.1 |
    3 | Emulators-Wine | Emulators-Wine | Oui | Oui | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.1 |
    4 | Mono | Mono | Oui | Oui | 99 | rpm-md | Index of /repositories/Mono/openSUSE_11.1 |
    5 | OpenOffice | OpenOffice | Oui | Oui | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |
    6 | anubisg1 | anubisg1 | Oui | Oui | 99 | rpm-md | Index of /repositories/home:/anubisg1/openSUSE_11.1 |
    7 | google | google | Oui | Oui | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |

    8 | mozilla | mozilla | Oui | Oui | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    9 | my-repository | my-repository | Oui | Oui | 99 | plaindir | hd:///home/Arminius/my_inst_src?device=/dev/disk/by-id/edd-int13_dev80-part3&filesystem=auto |
    10 | packman-gwdg | packman-gwdg | Oui | Oui | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/11.1 |
    11 | repo-debug | openSUSE-11.1-Debug | Oui | Oui | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
    12 | repo-non-oss | openSUSE-11.1-Non-Oss | Oui | Oui | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    13 | repo-oss | openSUSE-11.1-Oss | Oui | Non | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    14 | repo-source | openSUSE-11.1-Source | Oui | Oui | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
    15 | repo-update | openSUSE-11.1-Update | Oui | Non | 100 | rpm-md | Index of /update/11.1 |
    16 | suser-jengelh | suser-jengelh | Oui | Oui | 99 | rpm-md | Index of /pub/linux/misc/suser-jengelh/SUSE-11.1 |
    17 | third-party | third-party | Oui | Oui | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.1 |
    18 | videolan | videolan | Oui | Oui | 99 | rpm-md | Index of /pub/vlc/SuSE/11.1/
    If it were me, I would remove all those in Red. For certain keep those in green. Those with no colour could be kept , as they are unlikely to cause dependency conflicts.

    Keeping additional repos that are unnecessary is just asking for trouble.

    In case you did not know, there is very little testing done on most rpms from those repos in red.

  5. #5

    Thumbs up Re: Trouble when updating or installing software rpm

    I deactivated those in red like you suggested and It fixed the problem, thanks.

    I need some package on other third-parties but I will care if they
    require that dependancy
    rpmlib(CompressedFileNames) <= 3.0.4-1
    Some packages require this but It don't even seems to exist in any 'rpm' packs.

  6. #6
    Andy Sipowicz NNTP User

    Default Re: Trouble when updating or installing software rpm

    > If it were me, I would remove all those in Red. For certain keep those
    > in green. Those with no colour could be kept , as they are unlikely to
    > cause dependency conflicts.


    ow, the colors do not come through for nntp users...so, for those
    users i hereby pass along:

    with reference to oldcpu's post:

    green--keep 10, 12, 13, & 15
    red--remove 1, 2, 4, 5, 6, 7, 9, 11, 14, 16, 17 & 18
    no color--either, you choose: 3 & 8

    --
    Andy Sipowicz

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,201
    Blog Entries
    1

    Default Re: Trouble when updating or installing software rpm

    I remember a while ago (when openSUSE 11.0) was released, that the rpm payload format was changed from bz2 to lzma, (so the rpm package itself had to be upgrded before upgrading the distro). In any case, care has to be taken when trying to install rpm packages manually, that they are built for your distro version.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •