Results 1 to 4 of 4

Thread: Gedit

  1. #1
    UncleOwen NNTP User

    Default Gedit

    I am trying to do a fix I read in another post however I am having a problem running gedit.

    if I type
    Code:
    gedit sysctl.conf
    it works fine, however I wouldn't be able to save obviously, so I typed
    Code:
    sudo gedit sysctl.conf
    however once I added sudo it wouldn't open I get this.
    Code:
    cannot open display: 
    Run 'gedit --help' to see a full list of available command line options.
    I really don't know what I'm doing wrong here.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,517
    Blog Entries
    15

    Default Re: Gedit

    Hi
    You need to use gnomesu rather than sudo
    Code:
    gnomesu gedit /etc/sysctl.conf
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
    up 1 day 10:57, 1 user, load average: 0.22, 0.42, 0.28
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  3. #3
    UncleOwen NNTP User

    Default Re: Gedit

    Thank you very much! I guess it's obvious I recently switched from a different distro. I just need to get used to some of the differences. Thank you again.

  4. #4
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: Gedit

    hi,

    Another option would be to enter:
    Code:
    su
    then
    Code:
    gedit /etc/sysctl.conf
    or you could use vi or emacs:
    Code:
    sudo vi /etc/sysctl.conf
    or
    Code:
    sudo emacs /etc/sysctl.conf
    Take care,
    Barry.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •