Results 1 to 2 of 2

Thread: Choosing a compiler when installing in yast?

  1. #1

    Default Choosing a compiler when installing in yast?

    Hi,

    I'm trying to build LAPACK/ATLAS on my system, as I use a scientific computing package that requires them. I installed the newest LAPACK and ATLAS from the Scientific Linux repo. Installing everything plus building my other package from source went fine, but there are some usage issues now that I think are related to the compiler used. I need the compiler used to build all of the packages to be the same. Is there a way to specify in Yast which compiler to use or should I just build all of the binaries from source (not looking forward to doing this for ATLAS)?

    Sorry to be so vague about the problem, but I've done some troubleshooting already and think I have narrowed it down to the same compiler not being used across builds.

    Thanks for any help!

  2. #2

    Default Re: Choosing a compiler when installing in yast?

    Ok, I now understand that this is an incredibly stupid question. Packages are already compiled, hence the usefulness of package repos! In any case, is there any way to tell what compiler was used to build a package?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •