Results 1 to 4 of 4

Thread: Another VMware question

  1. #1
    daggett8888 NNTP User

    Default Another VMware question

    Hi every one. I posted this before but it was in an older thread so I apologize for the repost. I fear it got buried in the old post. I am a newbie to linux so I hope some one may be able to help me.

    I tried to install the patch that was in the old vmware thread but am running into some errors. I installed opensuse 11.1 64bit version and installed VMWare server 2 64bit version.
    I entered what was in the patch verbatim. When I run the patch command I get this.

    Code:
    linux-4mdc:/usr/bin # sudo patch /usr/bin/vmware-config.pl /usr/bin/vmware-config.pl.patch.txt
    patching file /usr/bin/vmware-config.pl
    Hunk #1 FAILED at 4121.
    Hunk #2 FAILED at 4148.
    2 out of 2 hunks FAILED -- saving rejects to file /usr/bin/vmware-config.pl.rej.
    This is the patch I wrote using text off the other post. saved it as vmware-config.pl.patch.txt

    Code:
    --- /user/bin/vmware-config.pl.orig     2008-11-28 12:06:35.641054086 +0100
    +++ /user/bin/vmware-config.pl  2008-11-28 12:30:38.593304082 +0100
    @@ -4121,6 +4121,11 @@
            return 'no';
            }
    
    +       if ($name eq 'vsock') {
    +       print wrap("VMWare config patch VSOCK!\n");
    +       system(shell_string($gHelper{'mv'}) . ' -vi ' , shell_string($build_dir . '/../Module.symvers') . ' ' . shell_string($build_dir .'/vsock-only/' ));
    + }
    +
            print wrap('Building the ' . $name . ' module.' . "\n\n", 0);
            if (system(shell_string($gHelper{'make'}) . ' -C '
            . shell_string($build_dir . '/' . $name . '-only')
    @@ -4143,6 +4148,10 @@
            if (try_module($name, $build_dir . '/' . $name . '.o', 0, 1)) {
            print wrap('The ' . $name . module loads perfectly into the running kernel.'
                    . "\n\n", 0);
    +       if ($name eq 'vmci') {
    +       print wrap("VMWare config patch VMCI!\n");
    +       system(shell_string($gHelper{'cp'}) . 'vi ' . shell_string($build_dir.'/vmci-only/Module.symvers') . ' ' . shell_string($build_dir . '/../"));
    + }
            remove_tmp_dir($build_dir);
            return 'yes';
     }
    This is the reject file.

    Code:
    ***************
    *** 4121,4126 ****
            return 'no';
            }
    
            print wrap('Building the ' . $name . ' module.' . "\n\n", 0);
            if (system(shell_string($gHelper{'make'}) . ' -C '
            . shell_string($build_dir . '/' . $name . '-only')
    --- 4121,4131 ----
            return 'no';
            }
    
    +       if ($name eq 'vsock') {
    +       print wrap("VMWare config patch VSOCK!\n");
    +       system(shell_string($gHelper{'mv'}) . ' -vi ' , shell_string($build_dir . '/../Module.symvers') . ' ' . shell_string($build_dir .'/vsock-only/' ));
    +  }
    +
            print wrap('Building the ' . $name . ' module.' . "\n\n", 0);
            if (system(shell_string($gHelper{'make'}) . ' -C '
            . shell_string($build_dir . '/' . $name . '-only')
    ***************
    *** 4143,4148 ****
            if (try_module($name, $build_dir . '/' . $name . '.o', 0, 1)) {
            print wrap('The ' . $name . module loads perfectly into the running kernel.'
                    . "\n\n", 0);
            remove_tmp_dir($build_dir);
            return 'yes';
      }
    --- 4148,4157 ----
            if (try_module($name, $build_dir . '/' . $name . '.o', 0, 1)) {
            print wrap('The ' . $name . module loads perfectly into the running kernel.'
                    . "\n\n", 0);
    +       if ($name eq 'vmci') {
    +       print wrap("VMWare config patch VMCI!\n");
    +       system(shell_string($gHelper{'cp'}) . 'vi ' . shell_string($build_dir.'/vmci-only/Module.symvers') . ' ' . shell_string($build_dir . '/../"));
    +  }
    "vmware-config.pl.rej" [readonly] 39L, 1393C
    Thanks for any help.

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Another VMware question

    * daggett8888,

    I'm running VMWare Server 2 on Opensuse 11.1 64bit without any patch.

    Uwe

  3. #3
    daggett8888 NNTP User

    Default Re: Another VMware question

    Thanks Uwe,

    I have VMWare installed and it runs. I have not installed an OS in it yet. You are not running into any issues? Some say they have been seeing speed issues without the patch.
    Thanks again,

    Glen

  4. #4
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Another VMware question

    * daggett8888 wrote, On 04/06/2009 06:36 PM:
    > Thanks Uwe,
    >
    > I have VMWare installed and it runs. I have not installed an OS in it
    > yet. You are not running into any issues? Some say they have been seeing
    > speed issues without the patch.


    No issues so far.

    Uwe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •