Results 1 to 9 of 9

Thread: KDE4.2 screen locking every few minutes

  1. #1
    nickjennings NNTP User

    Default KDE4.2 screen locking every few minutes

    Hello all,

    This is a bit of an odd problem. I rebooted and now my KDE4.2 session randomly decides to lock the screen every few minutes. This could happen as I'm typing or surfing the web, etc.

    It has something to do with my power management (I'm on a laptop). I know this because I get a little notification from the power management icon saying it's locking the screen (though it gives no reason why). I've gone through the settings and see nothing which could be causing this. I'm very new to KDE (I've been a long time alternative WM user and have recently started loving KDE4) so not sure where to look, though I've gone through any settings I can find which could at all be relevant and am out of ideas.

    (it just locked the screen on my as I was writing this! )

    Any and all help greatly appreciated!
    -Nick

  2. #2

    Default Re: KDE4.2 screen locking every few minutes

    Well sadly I cannot help but I can offer sympathy. I am not on a laptop and it happens less often than hourly. Probably but not necessarily an unrelated phenomenon with similar but not identical symptoms. I am now on 4.22 and it stills happens I am looking for a pattern of actions that preempt the screen freeze. Fortunately for me the with the keyboard I can bring up the shutdown dialog that even responds to mouse commands.

  3. #3

    Default Re: KDE4.2 screen locking every few minutes

    Anyone ever find a solution to this? All of a sudden my laptop is doing this as well. About every 5 minutes it just locks. Battery is full power on AC. I have not run an update in several days but this just started today. WEIRD. I'm on OpenSuse 11.1/KDE 4.2.3

  4. #4

    Default Re: KDE4.2 screen locking every few minutes

    Just a quick update/note - When this happens, I get a notification from "Power Management" saying "The screen is being locked"

  5. #5

    Default Re: KDE4.2 screen locking every few minutes

    Mine was doing the same thing. The only thing I changed was when I went to power management settings I changed the "when idle for 15 minutes - lock" to "do nothing" instead. Since then my screen hasn't locked yet. Not sure if that was the fix for me, but it's the only thing I've tried and it seems to have worked.

  6. #6
    Join Date
    May 2009
    Location
    Luton, United Kingdom
    Posts
    51

    Lightbulb Re: KDE4.2 screen locking every few minutes

    I am a desktop user, and had the same or similar problem with the screen freezing/locking up. When that happened no input is possible. Sometimes it would lockup for such a long time that I resort to the reset button to restart the computer. My system multi boots openSUSE/WinXP and multiusers.

    My KDE profile is set to run some eye candy (Superkaramba, Skype, Amarok.). The other users are profile with default KDE setup. they don't have the same problem. So I reasoned it was my setup, after going through my setup and removing most of the applications, it started working, no more lockups.
    Installed one by one those applications and found it lockup when SuperKaramba is running and desktop effect is enabled. If SuperKaramba is turned of it works better, but not perfect. Desktop Effect off and it work as it should no lockups or sluggishness. Superkaramba running Desktop Effect disable, No lockups or sluggishness. So it appears that Desktop Effect is the cause of my problem. I now have it set Desktop Effect disabled

    Maybe it might help you to diagnose your problem.. good luck
    machanch

    ..system
    DesktoppenSUSE11.1, Kernel 2.6.27.21, KDE4.2.3
    CPU: Athlon XP 2200+ (1800MHz), 1GB DDR2 memory,
    ATI Sapphire Radeon 9600 Pro. 3HD (40G, 2x80G), DVD RW

  7. #7

    Default Re: KDE4.2 screen locking every few minutes

    My setup is the same, and the same problem of the keyboard locking happens. I get the same answer. It is a bother, but I am glad to see that it is not only my unit.

    Interesting how a solution has not been posted.

  8. #8

    Default Re: KDE4.2 screen locking every few minutes

    I'm not getting this anymore, I upgraded to KDE 4.2.86 and its working fine.

  9. #9
    soti NNTP User

    Default Re: KDE4.2 screen locking every few minutes

    I had similar problems on my laptop. I solved it by going to Configure Desktop -> Advanced -> Power management.

    There you go to Edit profiles. In every profile, there is (the 3rd line) "When the system is idle for more than" choose the "Do nothing" option.

    hope this helps
    soti

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •