Results 1 to 6 of 6

Thread: A bit of Kde/Nx weirdness

  1. #1

    Default A bit of Kde/Nx weirdness

    New one on me this

    I'm using Suse 11 64 on Kde 3.5, it's a relatively fresh install which doesn't and never has had Kde 4 installed

    Yet if I remote in to an Nx desktop it boots up into Kde 4 which is annoying as hell because I really don't like it

    Anyone know how I can get it to boot into 3.5 instead of 4?

    It'd also be interesting to hear how it can be using an environment I've never installed

  2. #2

    Default Re: A bit of Kde/Nx weirdness

    I guess no-one has any more clue than I do then

  3. #3
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: A bit of Kde/Nx weirdness

    well I guess that the client might have been developed to connect to kde 4.0(as you have this option to choose from the client) for the new package. Maybe an older nx client would have the kde 3.5. just trying to make some sense in this and I might be completely off but that's all I can think of.

  4. #4
    JosephKK NNTP User

    Default Re: A bit of Kde/Nx weirdness

    On Tue, 07 Apr 2009 12:16:01 GMT, Ecky
    <Ecky@no-mx.forums.opensuse.org> wrote:

    >
    >New one on me this
    >
    >I'm using Suse 11 64 on Kde 3.5, it's a relatively fresh install which
    >doesn't and never has had Kde 4 installed
    >
    >Yet if I remote in to an Nx desktop it boots up into Kde 4 which is
    >annoying as hell because I really don't like it
    >
    >Anyone know how I can get it to boot into 3.5 instead of 4?
    >
    >It'd also be interesting to hear how it can be using an environment
    >I've never installed


    So what happens when you end the remote session?

  5. #5

    Default Re: A bit of Kde/Nx weirdness - solved

    I suddenly remembered what I had to do to get nx firing up an xcfe desktop and figured the same principle should work for kde

    Which it did, so I'll post the solution in case anyone else is trying to do the same thing:


    For xcfe in the nxclient session configuration screen, you need to set the desktop to Unix - Custom

    Then click the Settings button and in that config screen set it to run the following command:

    /usr/bin/startxcfe4


    To make the client start kde 3 instead of kde 4 it's basically the same thing except the command to use is this:

    /opt/kde3/bin/startkde


    If you want to have control over the session's resolution you may also need to do this in the same screen as you enter the command:

    Change Floating Point to New Virtual Desktop


    Basically you can start any desktop environment you have installed by changing the Desktop setting to Custom and entering the command which starts that particular environment

    Thanks to those who replied
    Last edited by Ecky; 05-May-2009 at 04:23. Reason: **** typos!

  6. #6

    Default Re: A bit of Kde/Nx weirdness

    Why not load XDM instead of one of the window managers ?
    That's how I use NX.

    It shows my KDM login screen from which I select the Window manager I want to use, remote or on the machine itself, doesn't matter, I always work the way I want.

    Maybe an idea to try ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •