Results 1 to 9 of 9

Thread: Epson ink levels

  1. #1
    Join Date
    Apr 2009
    Location
    UK
    Posts
    7

    Default Epson ink levels

    Hi, I am using SUSE version 11.1 and am having difficulty checking the ink levels on my Epson stylus photo R220. I have tried Ink and followed the instructions here Ink but it doesn't seem to want to work for me. Does anyone know of a simple way of checking the ink levels. Dave.

  2. #2
    Join Date
    Apr 2009
    Location
    UK
    Posts
    7

    Default Re: Epson ink levels

    Forgot to mention I'm using the Gnome desktop. Sorry to post but could not find the edit button (one of those days)...

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: Epson ink levels

    Your description is too vague, only someone that had the same problem would risk an answer. Is it a permission problem? Or a missing library? Or... (you get the idea)

    Try running the app from a terminal and post the error messages (if any), so more people may help.

    When I had an epson graphical ink utility (needed libink IIRC) that worked nicely, had a pretty color bar display, etc. In SUSE 10.2 it was in the DVD, try searching for it in yast. Now I only have HP's, so I use hplip.

  4. #4
    Join Date
    Apr 2009
    Location
    UK
    Posts
    7

    Default Re: Epson ink levels

    Sorry that was a bit vague. I've searched Yast for libink IIRC and it's not there. This is the output I get from Ink

    dave@linux-mqrp:~/Desktop> ink -p <usb>[-n<0>]
    bash: syntax error near unexpected token `0'
    dave@linux-mqrp:~/Desktop>

    or

    dave@linux-mqrp:~> ink -d/dev/usb/lp0
    ink v0.4.1 � 2007 Markus Heinz

    Could not access custom usb device '/dev/usb/lp0'.
    Could not get ink level.
    dave@linux-mqrp:~>

    Any ideas, Dave.

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: Epson ink levels

    IIRC is an acronym, it means If I Recall Correctly. It could also mean If I Really Cared, but that's not the case here

    From the error message it seems that the program have no permission to access the printer. This is a know issue, you have to change permissions on the printer device (or maybe add yourself to the group your printer device belongs to). This problem is documented in the ink utility site, IIRC .

    To rule out the permission issue you could try to run the utility as root (a.k.a. the system administrator in the windows world), just to confirm it. But then fix the permission and use it as a normal user, because running apps as root always poses a greater security risk.

  6. #6
    Join Date
    Apr 2009
    Location
    UK
    Posts
    7

    Default Re: Epson ink levels

    Thanks for taking the time to reply. Sorry to be so dim but I'm new to Linux. I'm not sure how to run the utility as root I guess I have to input something into a terminal. I did try searching for my printer in the configuration editor but could not find it (i.e. Desktop Gnome Peripherals). Any help would be appreciated. Dave.

  7. #7

    Default Re: Epson ink levels

    first, try to turn on your printer and make sure connected to your pc.
    then type in your konsole as a root:

    ink -p usb

    good luck!!

  8. #8
    Join Date
    Apr 2009
    Location
    UK
    Posts
    7

    Default Re: Epson ink levels

    Hi, thanks for the reply ink -p usb comes up with the following output

    dave@linux-mqrp:~/Desktop> ink -p usb
    ink v0.5.0 (c) 2009 Markus Heinz

    Could not access '/dev/usb/lp0' or '/dev/usblp0'.
    Could not get ink level.
    dave@linux-mqrp:~/Desktop>

    However sudo ink -p usb gives a result! I think it is a permissions error but I don't know what to do. Anyhow at least now I can find my ink levels.



    Photoblack: 33%
    Cyan: 50%
    Light Cyan: 54%
    Magenta: 41%
    Light Magenta: 49%
    Yellow: 29%
    dave@linux-mqrp:~/Desktop>

  9. #9
    Join Date
    Apr 2009
    Location
    UK
    Posts
    7

    Default Re: Epson ink levels

    Just to explain to others who may have a similar problem. This seems to be a permissions problem as much as anything. I added my name to the ip group in the User and Group Administration (found in Yast). I'm not sure I did it right but it works.

    It has not solved the problem but at least I get to know the ink levels. Dave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •