Results 1 to 6 of 6

Thread: I cannot use cd/dvd-burning, why

  1. #1

    Default I cannot use cd/dvd-burning, why

    My odd is TS-L632H.

    When I run a cd/dvd-burning program such as k3b or brasero. If I don't insert a disc, the program can display my odd correctly. If I insert a disc whether open the program or not, when I run the program, no odd will be detected. Then I should log off then run the program again, it can display the odd, but if I click burn button, a error dialogue will appear to show burn fails.

    I am using opensuse11.1 gnome.

    Many thanks for helping me to solve it.

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: I cannot use cd/dvd-burning, why

    I don't know if this is the problem. You need to be a member of "cdrom" group for k3b to work properly.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: I cannot use cd/dvd-burning, why

    EDIT: Haha syampillai beat me to it.

    Have you tried adding your username to the group cdrom?
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4

    Default Re: I cannot use cd/dvd-burning, why

    Quote Originally Posted by syampillai View Post
    I don't know if this is the problem. You need to be a member of "cdrom" group for k3b to work properly.
    where I can add k3b to "cdrom" group, thanks

  5. #5
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: I cannot use cd/dvd-burning, why

    I think this was a bug that has been fixed since? Make sure you update your system using YaST software management or running the command sudo zypper up. Try again, if it still fails the advice the others gave is explained below.

    YaST Control Center > Security and Users > User and group management.
    Click the 2nd tab "Groups" click the button at the top right "Set filter" set it to "System groups".
    Find the group "cdrom" click it (or double click it depending on mouse settings). At the right find your username, mark the checkbox next to it and hit OK, hit OK again and you should be all set.
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  6. #6

    Default Re: I cannot use cd/dvd-burning, why

    FWIW, I had a similar but different problem; k3b came up complaining that the system had no optical device.

    However, when I checked, I found that the device belonged to group "disk", not "cdrom"; that's what I added my user to.

    The drive is an LG GH22ns40, the device name was /dev/sr0.

    An old forum post (K3b Cannot Find Dvd And Cd Burner Open Suse 10.3 - openSUSE Forums) recommended chmod'ing the device 666; I think adding users to relevant groups is better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •