Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Help with conflicts when trying to update to KDE factory

  1. #1
    Join Date
    Jun 2008
    Location
    USA
    Posts
    150

    Default Help with conflicts when trying to update to KDE factory

    I'm slowing getting up the nerve to upgrade my system to KDE4.2. I've enabled the three factory repo's, I filter by repositories in Yast2, and select "Update unconditionally". I'm getting the following conflicts. Could anyone give me some insight on how to correct this? My current system is running KDE 4.1.3 release 75.3 from the "stable" repo's.

    Thanks for any help!

    Code:
    #### YaST2 conflicts list - generated 2009-04-03 21:03:20 ####
    
    kde4-kgreeter-plugins-4.1.3-10.2.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-72.16.x86_64[@System]
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] Following actions will be done:
    do not install kdebase4-runtime-4.2.2-94.3.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kdebase4-nsplugin-4.2.2-79.9.x86_64
        [ ] Ignore some dependencies of kde4-kgreeter-plugins
    
        [ ] do not install kde4-kgreeter-plugins-4.1.3-10.2.1.x86_64
    
    
    
    kdebase4-session-4.2.2-32.11.x86_64 requires kdebase4-workspace = 4.2.2, but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-4.2.2-217.3.x86_64[Factory_desktop]
                       kdebase4-workspace-4.2.2-217.3.i586[Factory_desktop]
        [ ] Following actions will be done:
    do not install kdebase4-session-4.2.2-32.11.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install PolicyKit-kde-0.2-20.76.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
        [ ] Ignore some dependencies of kdebase4-session
    
        [ ] do not install kdebase4-workspace-4.1.3-10.2.1.x86_64
    
    
    
    powerdevil-1.4.1-17.6.x86_64 requires libplasma.so.2()(64bit), but this requirement cannot be provided
    deleted providers: kdebase4-workspace-4.1.3-172.3.x86_64[@System]
    uninstallable providers: kdebase4-workspace-4.1.3-10.1.x86_64[repo-oss]
                       kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
        [ ] Ignore some dependencies of powerdevil
    
        [ ] Following actions will be done:
    do not install skanlite-0.3.kde4.2.2-12.2.x86_64
    do not install kdebase4-4.2.2-79.9.x86_64
    do not install kde4-sweeper-4.2.2-52.2.x86_64
    do not install kde4-marble-4.2.2-56.9.x86_64
    do not install kde4-kwrite-4.2.2-79.9.x86_64
    do not install kde4-kwalletmanager-4.2.2-52.2.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kscd-4.2.2-46.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-kpat-4.2.2-51.2.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmines-4.2.2-51.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_sysinfo-11.1.1-69.4.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-keditbookmarks-4.2.2-79.9.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kde4-akregator-4.2.2-103.6.x86_64
    do not install kdebase4-nsplugin-4.2.2-79.9.x86_64
    do not install kde4-kopete-4.2.2-68.10.x86_64
    
    
    kde4-plasmoid-quicklauncher-0.5-12.1.x86_64 requires libplasma.so.2()(64bit), but this requirement cannot be provided
    deleted providers: kdebase4-workspace-4.1.3-172.3.x86_64[@System]
    uninstallable providers: kdebase4-workspace-4.1.3-10.1.x86_64[repo-oss]
                       kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
        [ ] Following actions will be done:
    do not install ktorrent-3.2-24.33.x86_64
    do not install kde4-marble-4.2.2-56.9.x86_64
    do not install kde4-kwrite-4.2.2-79.9.x86_64
    do not install kde4-kwalletmanager-4.2.2-52.2.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kscd-4.2.2-46.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-kpat-4.2.2-51.2.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmines-4.2.2-51.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_sysinfo-11.1.1-69.4.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-keditbookmarks-4.2.2-79.9.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install PolicyKit-kde-0.2-20.76.x86_64
    do not install kde4-ark-4.2.2-52.2.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kde4-akregator-4.2.2-103.6.x86_64
    do not install kdebase4-nsplugin-4.2.2-79.9.x86_64
        [ ] Ignore some dependencies of kde4-plasmoid-quicklauncher
    
        [ ] deinstallation of kde4-plasmoid-quicklauncher-0.5-12.1.x86_64
    
    
    
    kde4-kdm-4.1.3-10.2.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-72.16.x86_64[@System]
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] Following actions will be done:
    do not install kdepim4-wizards-4.2.2-103.6.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
        [ ] do not install kde4-kdm-4.1.3-10.2.1.x86_64
    
        [ ] Ignore some dependencies of kde4-kdm
    
    
    
    kde4-kwin-4.1.3-10.2.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-72.16.x86_64[@System]
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] Following actions will be done:
    do not install kdepim4-4.2.2-103.6.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
        [ ] Ignore some dependencies of kde4-kwin
    
        [ ] do not install kde4-kwin-4.1.3-10.2.1.x86_64
    
    
    
    
    #### YaST2 conflicts list END ###

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Help with conflicts when trying to update to KDE factory

    Quote Originally Posted by Gumper View Post
    I'm slowing getting up the nerve to upgrade my system to KDE4.2. I've enabled the three factory repo's, I filter by repositories in Yast2, and select "Update unconditionally". I'm getting the following conflicts. Could anyone give me some insight on how to correct this? My current system is running KDE 4.1.3 release 75.3 from the "stable" repo's.

    Thanks for any help!

    Code:
    #### YaST2 conflicts list - generated 2009-04-03 21:03:20 ####
    
    kde4-kgreeter-plugins-4.1.3-10.2.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-72.16.x86_64[@System]
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] Following actions will be done:
    do not install kdebase4-runtime-4.2.2-94.3.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kdebase4-nsplugin-4.2.2-79.9.x86_64
        [ ] Ignore some dependencies of kde4-kgreeter-plugins
    
        [X ] do not install kde4-kgreeter-plugins-4.1.3-10.2.1.x86_64
    
    
    
    kdebase4-session-4.2.2-32.11.x86_64 requires kdebase4-workspace = 4.2.2, but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-4.2.2-217.3.x86_64[Factory_desktop]
                       kdebase4-workspace-4.2.2-217.3.i586[Factory_desktop]
        [ ] Following actions will be done:
    do not install kdebase4-session-4.2.2-32.11.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install PolicyKit-kde-0.2-20.76.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
        [ ] Ignore some dependencies of kdebase4-session
    
        [X ] do not install kdebase4-workspace-4.1.3-10.2.1.x86_64
    
    
    
    powerdevil-1.4.1-17.6.x86_64 requires libplasma.so.2()(64bit), but this requirement cannot be provided
    deleted providers: kdebase4-workspace-4.1.3-172.3.x86_64[@System]
    uninstallable providers: kdebase4-workspace-4.1.3-10.1.x86_64[repo-oss]
                       kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
        [ ] Ignore some dependencies of powerdevil
    
        [ ] Following actions will be done:
    do not install skanlite-0.3.kde4.2.2-12.2.x86_64
    do not install kdebase4-4.2.2-79.9.x86_64
    do not install kde4-sweeper-4.2.2-52.2.x86_64
    do not install kde4-marble-4.2.2-56.9.x86_64
    do not install kde4-kwrite-4.2.2-79.9.x86_64
    do not install kde4-kwalletmanager-4.2.2-52.2.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kscd-4.2.2-46.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-kpat-4.2.2-51.2.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmines-4.2.2-51.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_sysinfo-11.1.1-69.4.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-keditbookmarks-4.2.2-79.9.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kde4-akregator-4.2.2-103.6.x86_64
    do not install kdebase4-nsplugin-4.2.2-79.9.x86_64
    do not install kde4-kopete-4.2.2-68.10.x86_64
    
    
    kde4-plasmoid-quicklauncher-0.5-12.1.x86_64 requires libplasma.so.2()(64bit), but this requirement cannot be provided
    deleted providers: kdebase4-workspace-4.1.3-172.3.x86_64[@System]
    uninstallable providers: kdebase4-workspace-4.1.3-10.1.x86_64[repo-oss]
                       kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
        [ ] Following actions will be done:
    do not install ktorrent-3.2-24.33.x86_64
    do not install kde4-marble-4.2.2-56.9.x86_64
    do not install kde4-kwrite-4.2.2-79.9.x86_64
    do not install kde4-kwalletmanager-4.2.2-52.2.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kscd-4.2.2-46.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-kpat-4.2.2-51.2.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmines-4.2.2-51.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_sysinfo-11.1.1-69.4.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-keditbookmarks-4.2.2-79.9.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install PolicyKit-kde-0.2-20.76.x86_64
    do not install kde4-ark-4.2.2-52.2.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kde4-akregator-4.2.2-103.6.x86_64
    do not install kdebase4-nsplugin-4.2.2-79.9.x86_64
        [ ] Ignore some dependencies of kde4-plasmoid-quicklauncher
    
        [ X] deinstallation of kde4-plasmoid-quicklauncher-0.5-12.1.x86_64
    
    
    
    kde4-kdm-4.1.3-10.2.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-72.16.x86_64[@System]
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] Following actions will be done:
    do not install kdepim4-wizards-4.2.2-103.6.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
        [ X] do not install kde4-kdm-4.1.3-10.2.1.x86_64
    
        [ ] Ignore some dependencies of kde4-kdm
    
    
    
    kde4-kwin-4.1.3-10.2.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-72.16.x86_64[@System]
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] Following actions will be done:
    do not install kdepim4-4.2.2-103.6.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
        [ ] Ignore some dependencies of kde4-kwin
    
        [X ] do not install kde4-kwin-4.1.3-10.2.1.x86_64
    
    
    
    
    #### YaST2 conflicts list END ###

    You must have deleted / disabled any 4.1.3 repos!!

    Re: Powerdevil
    I cannot just see a solution there. But, Powerdevil is no longer a separate package. If you can see it as a package in the list - delete it because it is for 4.1.3 NOT 4.2
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    USA
    Posts
    150

    Default Re: Help with conflicts when trying to update to KDE factory

    Quote Originally Posted by caf4926 View Post
    You must have deleted / disabled any 4.1.3 repos!!

    Re: Powerdevil
    I cannot just see a solution there. But, Powerdevil is no longer a separate package. If you can see it as a package in the list - delete it because it is for 4.1.3 NOT 4.2
    I don't have any 4.1.3 repo's active right now, The only repo's that I have active are the following:

    Code:
    gumper@linux-zbeq:~> zypper lr
    #  | Alias                       | Name                        | Enabled | Refresh
    ---+-----------------------------+-----------------------------+---------+--------
    1  | Banshee                     | Banshee                     | No      | Yes
    2  | Factory_community           | Factory community           | Yes     | Yes
    3  | Factory_desktop             | Factory desktop             | Yes     | Yes
    4  | Factory_extras              | Factory extras              | Yes     | Yes
    5  | Stable_Community            | Stable Community            | No      | Yes
    6  | Stable_Desktop              | Stable Desktop              | No      | Yes
    7  | Stable_Extras               | Stable Extras               | No      | Yes
    8  | Stable_QT                   | Stable QT                   | No      | Yes
    9  | openSUSE 11.1-0             | openSUSE 11.1-0             | No      | No
    10 | qt                          | qt                          | Yes     | Yes
    11 | repo                        | Packman Repository          | No      | Yes
    12 | repo-debug                  | openSUSE-11.1-Debug         | No      | Yes
    13 | repo-non-oss                | openSUSE-11.1-Non-Oss       | Yes     | Yes
    14 | repo-oss                    | openSUSE-11.1-Oss           | Yes     | Yes
    15 | repo-source                 | openSUSE-11.1-Source        | No      | Yes
    16 | repo-update                 | openSUSE-11.1-Update        | Yes     | Yes
    17 | repo_1                      | VideoLan Repository         | No      | Yes
    18 | security:passwordmanagement | security:passwordmanagement | No      | Yes

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Help with conflicts when trying to update to KDE factory

    Quote Originally Posted by Gumper View Post
    5 | Stable_Community | Stable Community | No | Yes
    6 | Stable_Desktop | Stable Desktop | No | Yes
    7 | Stable_Extras | Stable Extras | No | Yes
    These are the KDE 4.1.3 repositories. You'll need to delete them.

    Also any of the conflicts that give the option to not install Package-4.1.3, choose that.


    Good Luck,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5
    Join Date
    Jun 2008
    Location
    USA
    Posts
    150

    Default Re: Help with conflicts when trying to update to KDE factory

    Quote Originally Posted by ijbreakey View Post
    These are the KDE 4.1.3 repositories. You'll need to delete them.

    Also any of the conflicts that give the option to not install Package-4.1.3, choose that.


    Good Luck,

    Ian
    I deleted the 4.1.3 repo's and I get the same conflicts. If I select the "do not install" for the 4.1.3 packages, I'm down to the following.


    Code:
    #### YaST2 conflicts list - generated 2009-04-03 23:54:57 ####
    
    kde4-plasmoid-quicklauncher-0.5-12.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    deleted providers: kdebase4-runtime-4.1.3-72.16.x86_64[@System]
    uninstallable providers: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] Following actions will be done:
    do not install kdebase4-runtime-4.2.2-94.3.x86_64
    do not install kde4-plasmoid-quickaccess-0.7.1-7.16.x86_64
    do not install kde4-okular-4.2.2-84.10.x86_64
    do not install kde4-marble-4.2.2-56.9.x86_64
    do not install kde4-kwrite-4.2.2-79.9.x86_64
    do not install kde4-kwalletmanager-4.2.2-52.2.x86_64
    do not install kdeartwork4-screensaver-4.2.2-32.2.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kscd-4.2.2-46.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-kpat-4.2.2-51.2.x86_64
    do not install kde4-kopete-4.2.2-68.10.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmines-4.2.2-51.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_sysinfo-11.1.1-69.4.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kget-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-keditbookmarks-4.2.2-79.9.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install PolicyKit-kde-0.2-20.76.x86_64
    do not install kde4-ark-4.2.2-52.2.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kde4-akregator-4.2.2-103.6.x86_64
    do not install kde4-dolphin-4.2.2-79.9.x86_64
        [ ] deinstallation of kde4-plasmoid-quicklauncher-0.5-12.1.x86_64
    
        [ ] Ignore some dependencies of kde4-plasmoid-quicklauncher
    
    
    
    kdebluetooth4-0.3-4.1.1.x86_64 requires solid-bluez4 >= 0.1, but this requirement cannot be provided
    deleted providers: kdebase4-workspace-4.1.3-172.3.x86_64[@System]
    uninstallable providers: kdebase4-workspace-4.1.3-10.2.1.i586[repo-update]
                       kdebase4-workspace-4.1.3-10.2.1.x86_64[repo-update]
        [ ] do not install kdebluetooth4-0.3-4.1.1.x86_64
    
        [ ] Following actions will be done:
    do not install kdebase4-session-4.2.2-32.11.x86_64
    do not install kde4-kwrite-4.2.2-79.9.x86_64
    do not install kde4-kwalletmanager-4.2.2-52.2.x86_64
    do not install kde4-ksudoku-4.2.2-51.2.x86_64
    do not install kde4-kscd-4.2.2-46.2.x86_64
    do not install kde4-kreversi-4.2.2-51.2.x86_64
    do not install kde4-kpat-4.2.2-51.2.x86_64
    do not install kde4-kopete-4.2.2-68.10.x86_64
    do not install kde4-konsole-4.2.2-79.9.x86_64
    do not install kde4-konqueror-plugins-4.2.2-41.2.x86_64
    do not install kde4-konqueror-4.2.2-79.9.x86_64
    do not install kde4-kmix-4.2.2-46.2.x86_64
    do not install kde4-kmines-4.2.2-51.2.x86_64
    do not install kde4-kmahjongg-4.2.2-51.2.x86_64
    do not install kde4-kio_sysinfo-11.1.1-69.4.x86_64
    do not install kde4-kio_kamera-4.2.2-84.10.x86_64
    do not install kde4-ksnapshot-4.2.2-84.10.x86_64
    do not install kde4-krfb-4.2.2-68.10.x86_64
    do not install kde4-krdc-4.2.2-68.10.x86_64
    do not install kde4-kgamma-4.2.2-84.10.x86_64
    do not install kde4-kfind-4.2.2-79.9.x86_64
    do not install kde4-kdnssd-4.2.2-68.10.x86_64
    do not install kde4-kcron-4.2.2-32.2.x86_64
    do not install kde4-kcalc-4.2.2-52.2.x86_64
    do not install kde4-kio_audiocd-4.2.2-46.2.x86_64
    do not install kde4-kgpg-4.2.2-52.2.x86_64
    do not install kde4-keditbookmarks-4.2.2-79.9.x86_64
    do not install kde4-kcolorchooser-4.2.2-84.10.x86_64
    do not install kde4-digikam-0.10.0-89.1.x86_64
    do not install PolicyKit-kde-0.2-20.76.x86_64
    do not install kde4-ark-4.2.2-52.2.x86_64
    do not install kde4-kate-4.2.2-49.2.x86_64
    do not install kde4-kalgebra-4.2.2-56.9.x86_64
    do not install kde4-gwenview-4.2.2-84.10.x86_64
    do not install kde4-akregator-4.2.2-103.6.x86_64
    do not install kde4-dolphin-4.2.2-79.9.x86_64
    deinstallation of kde4-kopete-4.1.3-49.13.x86_64
        [ ] Ignore some dependencies of kdebluetooth4
    
    
    
    
    #### YaST2 conflicts list END ###

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Help with conflicts when trying to update to KDE factory

    [ X] deinstallation of kde4-plasmoid-quicklauncher-0.5-12.1.x86_64


    [ X] do not install kdebluetooth4-0.3-4.1.1.x86_64


    Look at adding bluetooth after running the update
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    USA
    Posts
    150

    Default Re: Help with conflicts when trying to update to KDE factory

    Thanks for the help so far. I'll have to resume this tomorrow. I'm getting a little too tired to be messing with this tricky stuff right now.

  8. #8
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Help with conflicts when trying to update to KDE factory

    Just a side note:
    It was very easy to do the 1-Click Install to upgrade to 4.2.1 (and then, now, to 4.2.2 also).
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  9. #9
    Join Date
    Jun 2008
    Location
    Syros, Greece
    Posts
    569

    Default Re: Help with conflicts when trying to update to KDE factory

    These are my repos and updates (regarding KDE) are working flawlessly.

    Code:
    strzol@teras:~/openwrt/kamikaze> zypper lr                                        
    #  | Alias                          | Name                                                | Enabled | Refresh
    ---+--------------------------------+-----------------------------------------------------+---------+--------
    1  | Build_Service_tools            | Build Service tools                                 | Yes     | Yes
    2  | Google                         | Google                                              | Yes     | Yes
    3  | KDE_4.2_Community              | KDE 4.2 Community                                   | Yes     | Yes
    4  | KDE_4.2_Core_Packages          | KDE 4.2 Core Packages                               | Yes     | Yes
    5  | KDE_4.2_Extra_Applications     | KDE 4.2 Extra Applications                          | Yes     | Yes
    6  | KDE_4.2_Qt_Packages            | KDE 4.2 Qt Packages                                 | Yes     | Yes
    7  | Latest_git_radeonhd            | Latest git radeonhd                                 | Yes     | Yes
    8  | Latest_xorg_1                  | Latest xorg                                         | Yes     | Yes
    9  | Libdvdcss repository           | Libdvdcss repository                                | Yes     | Yes
    10 | Mumble_opensuse                | Mumble opensuse                                     | Yes     | Yes
    11 | Opensuse_11.1_Multimedia_audio | Opensuse 11.1 Multimedia audio                      | Yes     | Yes
    12 | X11_drivers                    | X11 drivers                                         | Yes     | Yes
    13 | openSUSE 11.1-0                | openSUSE 11.1-0                                     | No      | No
    14 | repo                           | openSUSE BuildService - Wine CVS Builds             | Yes     | Yes
    15 | repo-debug                     | openSUSE-11.1-Debug                                 | No      | No
    16 | repo-non-oss                   | openSUSE-11.1-Non-Oss                               | Yes     | Yes
    17 | repo-oss                       | openSUSE-11.1-Oss                                   | Yes     | Yes
    18 | repo-source                    | openSUSE-11.1-Source                                | No      | No
    19 | repo-update                    | openSUSE-11.1-Update                                | Yes     | Yes
    20 | repo_1                         | openSUSE BuildService - GNOME:Community             | Yes     | Yes
    21 | repo_10                        | openSUSE BuildService - Drivers for webcams         | Yes     | Yes
    22 | repo_11                        | openSUSE BuildService - Games                       | Yes     | Yes
    23 | repo_12                        | openSUSE BuildService - Mozilla                     | Yes     | Yes
    24 | repo_13                        | VideoLan Repository                                 | Yes     | Yes
    25 | repo_14                        | Packman Repository                                  | Yes     | Yes
    26 | repo_15                        | openSUSE Education                                  | Yes     | Yes
    27 | repo_16                        | ATI Repository                                      | Yes     | Yes
    28 | repo_2                         | openSUSE BuildService - GNOME:STABLE                | Yes     | Yes
    29 | repo_3                         | openSUSE BuildService - KDE:Backports               | Yes     | Yes
    30 | repo_4                         | openSUSE BuildService - KDE:Community               | Yes     | Yes
    31 | repo_5                         | openSUSE BuildService - Mono:Community              | Yes     | Yes
    32 | repo_6                         | openSUSE BuildService - OpenOffice.org              | Yes     | Yes
    33 | repo_7                         | openSUSE BuildService - Virtualization (QEMU)       | Yes     | Yes
    34 | repo_8                         | openSUSE BuildService - Virtualization (VirtualBox) | Yes     | Yes
    35 | repo_9                         | openSUSE BuildService - X11:Compiz                  | Yes     | Yes
    strzol@teras:~/openwrt/kamikaze>

  10. #10
    Join Date
    Jun 2008
    Location
    USA
    Posts
    150

    Default Re: Help with conflicts when trying to update to KDE factory

    I was able to work through my conflicts and install the necessary packages. So far everything seems to be working fine. It seems like applications launch much quicker than before.

    I have one more question. Is it necessary to rename my original .kde4 folder and do a restart? I didn't do this and I'm wondering if not doing it may give me problems later.

    Thanks for all the help!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •