Results 1 to 5 of 5

Thread: zmd-messages.log overcrowding /var/log

  1. #1

    Default zmd-messages.log overcrowding /var/log

    Hi all,

    I was looking at the /var/log and noticed tons of zmd-messages.log files. It seems like they do their own rotation with a YYYY-MM-DD extension formate which does not coincide with the dateext option in the logrotate.conf.

    I really do not want all of these logs and do not want them built of because it really makes the directory look "clunky".

    I would like one of two solutions, maybe a combination of both:

    1) Would it be possible to only keep the log files for say a week? This would be ideal as when I do an ls on my /var/log directory I can see something more than zmd-messages.log*
    2) This wouldn't be such a huge problem if these logs could be kept in a separate directory than /var/log. Could I specify its own directory within /var/log?

    Any other suggestions are welcome. I suppose I might have to write my own script and put it in a cronjob to remove "old" zmd-message files since it does not seems to rotate outside of the "logrotate" in /etc/cron.daily

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: zmd-messages.log overcrowding /var/log

    Are you running an openSUSE/SUSE release < 10.3? You might as well disable the zmd service as there won't be any further updates.

    If you are running SLED/S rather than openSUSE, then there are other forums for those.

  3. #3
    Conficter NNTP User

    Default Re: zmd-messages.log overcrowding /var/log

    > Are you running an openSUSE/SUSE release < 10.3? You might as well
    > disable the zmd service as there won't be any further updates.


    10.3 is supported still..
    and, will be until 11.2 pops out (now scheduled for Nov 2009)..

    --
    Conficter

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: zmd-messages.log overcrowding /var/log

    Yes, I wrote <, not <=. I hope you are not a programmer.

  5. #5
    Conficter NNTP User

    Default Re: zmd-messages.log overcrowding /var/log

    ken yap wrote:
    > Yes, I wrote <, not <=. I hope you are not a programmer.
    >
    >

    sorry ken, i suppose my eye skipped over that < thinking it was a
    artifact of a unrequested finger flick...

    and no, i've been called a lot of things, but never a computer
    programmer..

    --
    Conficter

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •