Results 1 to 6 of 6

Thread: problems compiling kismet

  1. #1

    Post problems compiling kismet

    dears, I'm trying to compile kismet on my opensuse 11.1, I have made the ./configure, then the make dep but when I made the "make" I get the following error:

    acaddr.h:267: warning: typedef was ignored in this declaration
    macaddr.h:283: warning: typedef was ignored in this declaration
    macaddr.h:288: warning: typedef was ignored in this declaration
    In file included from tcpclient.h:41,
    from frontend.h:34,
    from panelfront.h:45,
    from panelfront.cc:52:
    packet.h:60: warning: typedef was ignored in this declaration
    packet.h:321: warning: typedef was ignored in this declaration
    In file included from tcpclient.h:42,
    from frontend.h:34,
    from panelfront.h:45,
    from panelfront.cc:52:
    tracktypes.h:30: warning: typedef was ignored in this declaration
    tracktypes.h:266: warning: typedef was ignored in this declaration
    tracktypes.h:461: warning: typedef was ignored in this declaration
    In file included from frontend.h:34,
    from panelfront.h:45,
    from panelfront.cc:52:
    tcpclient.h:68: warning: typedef was ignored in this declaration
    tcpclient.h:86: warning: typedef was ignored in this declaration
    tcpclient.h:107: warning: typedef was ignored in this declaration
    In file included from packetracker.h:32,

    .
    .
    .
    .
    ....
    .... at the end, the following senteces are displayed

    panelfront.cc:1278: error: struct PanelFront::kis_window has no member named pan
    panelfront.cc:1278: error: del_panel was not declared in this scope
    make: *** [panelfront.o] Error 1


    Could you help me? had anyone installed kismet on opensuse?

    thanks in advanced.

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: problems compiling kismet

    Hi,

    Why are you compiling kismet? The latest stable version is already in the repositories.
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,109
    Blog Entries
    15

    Default Re: problems compiling kismet

    Hi
    Why not install the default from the dvd, it's the latest? If you look
    at the src rpm, there are a number of patches required.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
    up 1 day 7:52, 1 user, load average: 0.29, 0.26, 0.19
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  4. #4

    Default Re: problems compiling kismet

    I've tried installing the version from repositorys. But, it doesn't work with my wireless board. I'm using intel wireless 3945. I've read that I need to compile from source to use Kismet.

    When I install from yast, Kismet can't find my interface. Even after of editing the kismet.conf

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,109
    Blog Entries
    15

    Default Re: problems compiling kismet

    Hi
    In that case you need to download the src rpm of kismet and then use
    the patches to get rid of the error.

    What options do you need to add to the kismet configure command? If you
    need to add some then just edit the spec file and rebuild the rpm.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
    up 1:50, 2 users, load average: 0.10, 0.09, 0.09
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  6. #6
    Join Date
    Jun 2008
    Location
    Nuernberg
    Posts
    18

    Default Re: problems compiling kismet

    First, you can use the distribution supplied kismet just fine. No need to build for yourself.

    The second part is the correct configuration, whihc is harder, since it does not work out of the box.

    /etc/kismet.conf

    the source line:
    source=iwl3945,wlan0,wlan0

    or similar. (have my laptop at work so cannot check currently)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •