Results 1 to 5 of 5

Thread: New Sound Card

  1. #1

    Default New Sound Card

    Hi. I got a brand new Creative Labs XFi Audio Extreme card which replaces my old Audigy2 card. I downloaded the Linux driver for it and booted up OpenSuse. Of course it auto switched to a suitable driver which is ok, but the surround sound does not work.

    Now the problem........ From a noob's point of view all i have to do is (according to the readme), is to issue a 'Make' command in terminal. Ok this is where Linux becomes not so simple.

    I have the unzipped driver folder in the Documents folder (default unzip folder), and i open a terminal as root. I cd /home, cd barry, cd documents and get an error - 'no such file or directory'?

    no matter what i try i cannot get into the documents folder from the terminal. I put the driver folder into a new temp folder and get the same message when i try to open it.

    I can sort of see what's happening whereby a folder is not a file itself, nor a directory, but how can i open the documents folder so i can open the folder that contains the driver?

    Once (if), i get inside the driver folder do i just issue a 'make /makefile' command (there is a 'makefile' file inside the drivers folder). Once thats done does it install itself (part of the make process), or do i have to go through more hoops just to install a driver.

    Is there an easier way to install this driver? I cannot see anyway in the sound options (Yast2), that enables me to browse to a folder and let the system install it automatically (dare i say, like windoze).

    Help would be apreciated.

    Regards

  2. #2

    Default Re: New Sound Card

    First up, linux filesystems are case sensitive. So try 'cd Documents' and see if that works.

    Second, I have no idea how this particular driver works, but standard procedure is...

    Code:
    cd [directory of driver]
    ./configure
    make
    su -
    make install
    exit
    It will almost certainly have a readme file with it, but if it doesn't, try the above.

  3. #3

    Default Re: New Sound Card

    I got into the folder ok but there must be something missing as the readme says type make, then make install but i get a no target error message.

    Oh well, i'll check around the creative forums and see if i can find a solution.

    Thanks for the reply

    Regards

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: New Sound Card

    Quote Originally Posted by tictoc2 View Post
    I downloaded the Linux driver for it and booted up OpenSuse. Of course it auto switched to a suitable driver which is ok, but the surround sound does not work.
    I'm surprised you got any sound with alsa ( ? ) under openSUSE Linux with this card. ...

    Another, likely slower, option, is for you to write a bug report on openSUSE, and then follow the bug report thread, supporting the openSUSE (and also alsa) developer in their efforts to improve the alsa driver for this card.
    Submitting Bug Reports - openSUSE

    However it may be you will find that bug reporting approach difficult, as the alsa/openSUSE developer may assume users have an average to advanced level of Lilnux knowledge.

  5. #5

    Default Re: New Sound Card

    The mixer does contain a huge array of options for the card but the 3D does nothing at all. I'm not clued up enough for bug reporting.

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •