Results 1 to 10 of 10

Thread: compizFusion problems on KDE4.2

  1. #1

    Unhappy compizFusion problems on KDE4.2

    Hi,

    I have done everything in my capacity but this doesnt go. After I put Compiz as my default windows manager and I restart X, all the windows go "borderless". As per the instructions here, at the Compiz Troubleshooting page, I tried things but nothing worked. Ultimately, at 2 AM now, I am exhausted. If someone can help it, it could turn out to be a pleasant morning.

    Here below is the output of running simple-ccsm and then enabling the effects. Your help, as always, appreciated!

    Code:
    aditya@gladiator:~> simple-ccsm 
    libccs: dlopen: /usr/lib/compizconfig/backends/libkconfig4.so: cannot open shared object file: No such file or directory
    Checking for Xdmx: not present.                                                                                         
    Checking for Xgl: not present.                                                                                          
    Detected PCI ID for VGA:        Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64                  
    01:00.0 0300: 10de:01d3 (rev a1) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
    Dry run finished: everything should work with regards to Compiz and 3D.
    No compiz manager config found!
    Checking for Xdmx: not present.
    Checking for Xgl: not present.
    Detected PCI ID for VGA:        Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64
    01:00.0 0300: 10de:01d3 (rev a1) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
     * Detected Session: kde
     * Searching for installed applications...
     * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
     * Using the GTK Interface
    /usr/bin/compiz (core) - Error: Plugin 'core' has ABI version '20081121', expected ABI version '20080828'.
    
    /usr/bin/compiz (ccp) - Error: InitObject failed
    /usr/bin/compiz (core) - Error: Couldn't activate plugin 'ccp'
     * Decorator "compiz-decorator --replace" is invalid.
     * Setting decorator to KDE Window Decorator ("kde-window-decorator --replace")

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: compizFusion problems on KDE4.2

    Are you Not using kwin as WM because you want to employ themes from emerald?
    You can actually get kwin to do much more in decoration than is first apparent. And Compiz works great with it.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Feb 2009
    Location
    East Stroudsburg
    Posts
    153

    Default Re: compizFusion problems on KDE4.2

    It is unable to find Xgl, it might not be installed correctly. Try unstalling Xgl and then reinstalling it again. If it still causes the same problem, check you /usr/share/xsessions/xgl.dektop, open it up with gedit(gotta be under sudo) and post back what's in it.
    | OpenSuSE 11.4 Gnome Shell 64-bit | 4.2 i7-930 | ATI Raden 5750

  4. #4

    Default Re: compizFusion problems on KDE4.2

    caf4926: Are you Not using kwin as WM because you want to employ themes from emerald? You can actually get kwin to do much more in decoration than is first apparent. And Compiz works great with it.
    Yes. But I don't know how to get Kwin to use those themes. Is it possible? Can someone tell me, please?

    A13kSAk3:It is unable to find Xgl, it might not be installed correctly. Try unstalling Xgl and then reinstalling it again. If it still causes the same problem, check you /usr/share/xsessions/xgl.dektop, open it up with gedit(gotta be under sudo) and post back what's in it.
    I suspected that too but when I search for xgl under yast-> install software I dont get any result. Besides, my 3D effects with KWin are working fine. Also, there is one line in the last output that I posted which caught my attention. this one -
    Code:
    >/usr/bin/compiz (core) - Error: Plugin 'core' has ABI version '20081121', expected ABI version '20080828'.
    I couldnt find the file xgl.desktop. There are kde4.desktop twm.desktop there, though.

    Thanks for your help...

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: compizFusion problems on KDE4.2

    Yes. But I don't know how to get Kwin to use those themes. Is it possible? Can someone tell me, please?
    No. That is not what I mean, but rather the configuration of your decoration via the Configure Desktop. You basically just start with a theme you like and adjust all the colours and transparency as required.

    I understand there are some users who have installed Compiz in kde4 above and beyond that which is installed by default. Maybe to take advantage of the likes of Emerald. But there do seem to be a lot of issues about it in the forum. Personally, IMO, with kde4 kwin and the default compiz working so well, I wouldn't even entertain the idea of adding the compiz repo's.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: compizFusion problems on KDE4.2

    caf4926: I can't even go beyond the window borders that KDE4 ships with. I don't know if that is how it is supposed to be but that is precisely (and perhaps the only reason) why I am trying to get emerald working. When I go to configure desktop->appearance->Window decoration, I see a list of borders but I can't add to it anything more than what I see there.

  7. #7

    Default Re: compizFusion problems on KDE4.2

    To the op, are you saying everytime you login there is alway no window border?
    People who do not break things first will never learn to create anything

  8. #8

    Default Re: compizFusion problems on KDE4.2

    conram: If I use Compiz as my window manager, there is always no window border.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: compizFusion problems on KDE4.2

    Don't use Compiz as WM use kwin.
    You still have all the compiz effects even with kwin.

    Additional themes can be found in the community repo. Or from kde-look
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: compizFusion problems on KDE4.2

    Hey Aditya,

    If it can't even find your ccp then something is wrong. Try reinstalling all your compiz packages.

    Make sure your default windows manager is Kwin.

    Then, in order to get emerald to work, open up the CompizConfig Settings Manager (CCSM). Under Effects click the check next to Window Decoration and then click Window Decoration. For the Command type
    emerald --replace

    Then try to change the default window manager to Compiz. (Not compiz custom).

    Hope this helps,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •