Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: itunnel

  1. #1
    Join Date
    Mar 2009
    Location
    root/Earth/Russia/Moscow
    Posts
    11

    Question itunnel

    Hello,
    im new in linux
    i have opensuse 11.1 with kde4
    i want to copy music and videos to my ipod touch(it has the same file system as iphone) as it is described here
    but i cant install itunnel
    i downladed it from here, but i cant install it
    i downloaded itunnel-0.0.5.tgz, unpack it to my home folder, go in it, make itunnel executable , open terminal but when i type
    ./itunnel 7777 (7777 is port number)
    it writes this:
    ./itunnel: error while loading shared libraries: libiphone.so.0: cannot open shared object file: No such file or directory

    i tried to type this under root, but it doesnt help
    how can i install this programm?
    plz help me
    sry for ma english

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: itunnel

    you need the libiphone library, which afaik, is currently not packaged for suse. However, you can still get the source and compile it yourself http://matt.colyer.name/projects/iph...itle=Main_Page

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: itunnel

    hmmm, seems I was wrong. There are suse packages on Webpin

    Webpin

  4. #4
    Join Date
    Mar 2009
    Location
    root/Earth/Russia/Moscow
    Posts
    11

    Default Re: itunnel

    thank you, i installed all the packages from here, bit it doesnt help, the same error

  5. #5
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: itunnel

    install the development package of libiphone and then RECOMPILE your application again so it can pick it up.

  6. #6
    Join Date
    Mar 2009
    Location
    root/Earth/Russia/Moscow
    Posts
    11

    Default Re: itunnel

    and how to recompile application?

  7. #7
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: itunnel

    type 'make' in your terminal. For this to work, you need GCC and Make installed (maybe a few more too). Easiest way to install them is to go in YaST Software Management, choose 'patterns' and use the Development pattern

  8. #8
    Join Date
    Mar 2009
    Location
    root/Earth/Russia/Moscow
    Posts
    11

    Default Re: itunnel

    ive installed basic development pattern, which contains GCC and make
    then i type "make" bit it writes me this:
    gooseman@linux-47a4:~/Downloads/iphone/itunnel-0.0.5> make
    make: Цель `all' не требует выполнения команд.

    in english it is something like this:
    make: target "all" doesnt need commands



    i tried "make itunnel", but it said smth like "itunnel doesnt need an update"

  9. #9
    Join Date
    Mar 2009
    Location
    root/Earth/Russia/Moscow
    Posts
    11

    Question Re: itunnel

    could anybody install this app on opensuse?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,525
    Blog Entries
    15

    Default Re: itunnel

    Quote Originally Posted by TE0I0TEJIb
    could anybody install this app on opensuse?
    Hi
    I just downloaded itunnel and extracted the tarball and ran it with the
    command (no chmoding required!!);
    Code:
    ../itunnel
    It showed your error, then downloaded and installed libiphone0 found
    here;
    <http://download.opensuse.org/repositories/home:/FunkyM:/iphone/openSUSE_11.1>

    Now when run it works, but quits due to not having an iphone connected.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
    up 18:07, 2 users, load average: 0.47, 0.31, 0.21
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •