Results 1 to 7 of 7

Thread: Mis-behaving Dolphin

  1. #1

    Default Mis-behaving Dolphin

    This is strange problem, in KDE4.2

    When I launch "Dolphin - Superuser mode" from the menu, I can't open text files. I get the error KDEInit could not launch '/usr/bin/kwrite'.

    But when I got to Konsole and login as root, then call Dolphin there, the application behaves correctly and I can open text files as expected.

    But the menu option doesn't work if I then set it up to call Dolphin as user root. I get the error message Could not start process Cannot talk to klauncher

    Going back to the Konsole, I notice the following (The second CLI "kdeinit4: preparing to launch /usr/lib64" was called automatically)

    inspiron:~ # dolphin
    "/usr/bin/dolphin(20149)" Error in thread 47818219218672 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
    "/usr/bin/dolphin(20149)" Error in thread 47818219218672 : "QLocalSocket::connectToServer: Invalid name"
    dolphin(20149): Attempt to use QAction "close_tab" with KXMLGUIFactory!
    dolphin(20149): Attempt to use QAction "show_info_panel" with KXMLGUIFactory!
    dolphin(20149): Attempt to use QAction "show_folders_panel" with KXMLGUIFactory!
    dolphin(20149): Attempt to use QAction "show_terminal_panel" with KXMLGUIFactory!
    dolphin(20149): Attempt to use QAction "show_places_panel" with KXMLGUIFactory!
    dolphin(20149)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: "The name org.kde.kded was not provided by any .service files"

    inspiron:~ # kdeinit4: preparing to launch /usr/lib64/kde4/libexec/klauncher
    kdeinit4: preparing to launch /usr/bin/kded4
    kdeinit4: preparing to launch /usr/bin/kbuildsycoca4
    kbuildsycoca4 running...


    One more thing. With this still running, calling Dolphin from the menu as user root does work. So my question is, how can I get Dolphin to work from the menu, on it's own?

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,567

    Default Re: Mis-behaving Dolphin

    I too see this issue.
    Dolphin in super user mode also uses a crazy amount of cpu

  3. #3
    Join Date
    Mar 2009
    Location
    Central Utah
    Posts
    43

    Default Re: Mis-behaving Dolphin

    Same basic error.

    Open Dolphin with using icon provided under Applications - System - File Manager - File Manager - Super User Mode

    "Could not start process Cannot talk to klauncher: The name org.kde.klauncher was not provided by any .service files."


    Any help?

    Mike

  4. #4
    Join Date
    Mar 2009
    Location
    Central Utah
    Posts
    43

    Default Re: Mis-behaving Dolphin

    Quote Originally Posted by Relative View Post
    Same basic error.

    Open Dolphin with using icon provided under Applications - System - File Manager - File Manager - Super User Mode

    "Could not start process Cannot talk to klauncher: The name org.kde.klauncher was not provided by any .service files."


    Any help?

    Mike
    I see the bug has basically been fixed and is expected to be auto-updated in the next KDE4 bunch of patches. See https://bugzilla.novell.com/show_bug.cgi?id=449056 as a reference.

    Will await that fix.

    Mike

  5. #5
    Join Date
    Aug 2008
    Location
    USA: [GMT -5]
    Posts
    74

    Default Re: Mis-behaving Dolphin

    Hi all. I think this related per dolphin: Can someone tell me how
    to increase the size of cache that dolphin uses?
    Thanks.
    rob <robhwill@yahoo.com>
    Registered Linux User #356732
    Have A Healthy, Prosperous Day! Leap-15.1_x86_64 -- KDE Plasma 5-5.55 / Lenovo M78-ThinkCentre / 12gb / 500gb / Radeon 8570D
    Kernel: Linux 4.12.14-lp151.28.32-default / Linux User #3567324

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,037
    Blog Entries
    14

    Default Re: Mis-behaving Dolphin

    Hi Rob, welcome to the forum. Please start a new thread, nobody is going to find your post this way (except for me )
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Aug 2008
    Location
    USA: [GMT -5]
    Posts
    74

    Default Re: Mis-behaving Dolphin

    Thanks knurpht for info .. .. ..
    still looking for something to
    activate "post" option
    In any event...suse community rocks!
    ---rob
    Have A Healthy, Prosperous Day! Leap-15.1_x86_64 -- KDE Plasma 5-5.55 / Lenovo M78-ThinkCentre / 12gb / 500gb / Radeon 8570D
    Kernel: Linux 4.12.14-lp151.28.32-default / Linux User #3567324

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •