Results 1 to 5 of 5

Thread: Gnunet for OpenSuSe 11.1

  1. #1

    Default Gnunet for OpenSuSe 11.1

    Could someone please direct me to packages for Gnunet? software.opensuse.org finds packages for older systems (10.3, 11.0) but not OpenSuSe 11.1

    Google isn't very helpfull either.

  2. #2
    Join Date
    Oct 2009
    Location
    Kaunas, LT_lt
    Posts
    53

    Default Re: Gnunet for OpenSuSe 11.1

    Bump. Same here with 11.2 - no package gnunet. Furthermore - when trying to compile it, getting an error
    _______________________________________________________________
    checking for libextractor... --with-extractor not specified
    checking extractor.h usability... yes
    checking extractor.h presence... yes
    checking for extractor.h... yes
    checking for EXTRACTOR_loadDefaultLibraries in -lextractor... no
    configure: error: GNUnet requires libextractor

    Downloads are here
    GNUnet: Download
    The interesting thing that GNUnet-0.8.1b release needs libextractor 0.5, while 11.2 has libextractor 0.6 installed That's why despite libextractor is installed it is impossible to compile just so easy Libextractor 0.6 is good for GNUnet 0.9, it will be released somtime this year, but who knows when.

  3. #3
    Join Date
    May 2008
    Location
    Belgium
    Posts
    42

    Default Re: Gnunet for OpenSuSe 11.1

    I'm currently having a shot at packaging GNUnet 0.8.1b

    The problem is indeed that the libextractor API has changed a lot between 0.5.x and 0.6.0. I first tried to patch GNUnet to use the new API, but that's definitely too fragile and tedious, given how many changes happened and the complete lack of documentation for migrating.

    What I'm attempting now is an in-tree libextractor 0.5.9 that is linked statically, as part of the GNUnet build. That should definitely work, but takes some time to implement.

    I'll keep you updated on the progress.

  4. #4
    Join Date
    May 2008
    Location
    Belgium
    Posts
    42

    Default Re: Gnunet for OpenSuSe 11.1

    And here it is: PackMan :: Package details for gnunet

    But totally untested :-)

    Please install, test and send me feedback.

  5. #5
    Join Date
    Oct 2009
    Location
    Kaunas, LT_lt
    Posts
    53

    Default Re: Gnunet for OpenSuSe 11.1

    Well, first it needs some additional libraries

    # rpm -i http://packman.links2linux.org/downl...m.4.1.i586.rpm
    warning: /var/tmp/rpm-tmp.BudeHb: Header V3 DSA signature: NOKEY, key ID 9a795806
    error: Failed dependencies:
    libcares.so.2 is needed by gnunet-0.8.1b-0.pm.4.1.i586
    libesmtp.so.5 is needed by gnunet-0.8.1b-0.pm.4.1.i586
    libextractor.so.1 is needed by gnunet-0.8.1b-0.pm.4.1.i586
    libguile.so.17 is needed by gnunet-0.8.1b-0.pm.4.1.i586
    libmicrohttpd.so.5 is needed by gnunet-0.8.1b-0.pm.4.1.i586
    libmysqlclient.so.16 is needed by gnunet-0.8.1b-0.pm.4.1.i586
    libmysqlclient.so.16(libmysqlclient_16) is needed by gnunet-0.8.1b-0.pm.4.1.i586
    libpq.so.5 is needed by gnunet-0.8.1b-0.pm.4.1.i586

    Because of the same reason 1-click install also didn't work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •