Results 1 to 8 of 8

Thread: ~Flash...

  1. #1

    Default ~Flash...

    Hello!

    I have one problem more... Now I need an application for creating SWF Flash movies.... Like Macromedia Flash, you know..


    I found a very good think - "Flash For Linux" (or F4l) ... It might be an exactly program I need, BUT(!)... I download it, and I can't install it..

    There is no Configure and Make ... My system is OpenSUSE 11.1 with GNOME desktop...

    Here is a link for this program - Flash For Linux ..

    Here is a files in the source archive:

    Code:
    bin <dir>
    CVS <dir>
    src <dir>
    templates <dir>
    
    callgrind.cmd
    COPYING
    deneme.swf
    Doxyfile
    f4l.kdevelop
    f4l.kdevelop.pcs
    f4l.kdevses
    f4l.pro
    Makefile
    so... what's wrong?.. I've tried everything, I think ... I'm *** with this sources for 4 hours already ..


    Please, help me? Because I can't find any another programs with same functions...

  2. #2

    Default Re: ~Flash...

    I believe you need to treat it with cmake first? unpack it and cmake the folder

    like cmake /home/<user>/flash_stuff/

    Then you can make and make install ?

    But tr it for yourself, im not completely sure about that.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3

    Default Re: ~Flash...

    Hello there,

    I do not think there is another free / opensource software for linux.

    First have a look at software.opensuse.org/search/ f4l rpm is available in KDE:Community/openSUSE_11.1

    Second, if you want to use the source, I presume you did use either the cvs commands to download the source tree as explained on it's webpage or you did download the tar.bz source file from sf.net.

    Update flash for linux using cvs Howto
    by mascix

    F4L is available via anonymous cvs. Type the following to check out the latest development version from CVS:

    FOR VERSION 0.2:

    cvs -z9 -d:pserver:anonymous@f4l.cvs.sf.net:/cvsroot/f4l co f4l-0.2

    cd f4l-0.2

    make

    or try to use qmake or kdevelop.
    Did you try just using make command ? (indeed there is no readme file inside the archive for what you need more and how to build the binary. If make fails badly try using the rpm from the repo up here.

    Good luck.

  4. #4

    Default Re: ~Flash...

    No, cmake doesn't works too

    So, what about "official inst. guide" , I've tried that too, it downloads practically the same archive with same list of files and no "make" or "configure" doesn't works, course...

    And about RPM... It show message thar "F4l could not be installed" .. Now I think that maybe I loose some libraries, that f4l need?... But, as I remember, I've installed everything...

    oh...

  5. #5

    Default Re: ~Flash...

    Hello,

    cvs and the tar.bz most likely have small differences if any.

    I tried building it up from source and make / qmake gives out errors most likely because missing dependencies.

    I would suggest you try the 1-click install from the search page which will add the necessary repos and dependency packages.

    I can not test that because f4l is in KDE3 repo and I am using KDE4 which will mess my system.

    Not sure how it will interact with your system either since IIRC 11.1 has as default kde4 so I suppose the default kde libs will be the ones for kde4 but since you use gnome it might be different.

    Also I found on wikipedia this "stub" article about other alternatives: Flash for Linux - Wikipedia, the free encyclopedia

    Good luck.

  6. #6

    Default Re: ~Flash...

    Ok.. thanks .. And how do you thing - does it mean that f4l will not work on my GNOME desktop?...

  7. #7

    Default Re: ~Flash...

    It is suppose to work, I run gnome (gtk-based) apps on kde (e.g. gedit, gFTP).

    f4l seems to be qt based so you will need some of the kde packages (these will install also while using 1-click install).

  8. #8

    Default Re: ~Flash...

    Ok, sorry.... This f4l is not working at all... It's impossible to use it

    So, I download a Macromedia Flash 8, and Wine (17) without any problems install it and now I use it and no problems

    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •